Highlighted

Responsive HTML and Search Using the % character

Participant ,
Feb 08, 2018

Copy link to clipboard

Copied

Hi,

I'm using RH2017, 13.0.0.257,Responsive HTML, Azure Blue layout.

When users search for a term which includes the % character, for example, %WORK_DIR%, the correct search results display. However, nothing happens when clicking on a link in the search results.  (%WORK_DIR% is used in our documentation and returned 92 results)

The link correctly opens when selecting the link from the search results and clicking "open in new tab". However, the "Click here to see this page in full context" on the page displayed in the new tab, does not work.

Also, normally, suggestions display as the user types text in the search field.  When the % character is used in the search field, suggestions do not display.  Using the example above, as the users type WORK_DIR, suggestions display. If they type % as the first character, nothing displays and there are no suggestions even as they continue to type.

Everything's toggled on in the search setup:

This happens in both IE 10 and Chrome 64.

I know that sometimes in search engines, using % is a wildcard.  I didn't think RH permitted wildcards in their search function...but.....

Any advice?

Topics

HTML

Views

281

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Responsive HTML and Search Using the % character

Participant ,
Feb 08, 2018

Copy link to clipboard

Copied

Hi,

I'm using RH2017, 13.0.0.257,Responsive HTML, Azure Blue layout.

When users search for a term which includes the % character, for example, %WORK_DIR%, the correct search results display. However, nothing happens when clicking on a link in the search results.  (%WORK_DIR% is used in our documentation and returned 92 results)

The link correctly opens when selecting the link from the search results and clicking "open in new tab". However, the "Click here to see this page in full context" on the page displayed in the new tab, does not work.

Also, normally, suggestions display as the user types text in the search field.  When the % character is used in the search field, suggestions do not display.  Using the example above, as the users type WORK_DIR, suggestions display. If they type % as the first character, nothing displays and there are no suggestions even as they continue to type.

Everything's toggled on in the search setup:

This happens in both IE 10 and Chrome 64.

I know that sometimes in search engines, using % is a wildcard.  I didn't think RH permitted wildcards in their search function...but.....

Any advice?

Topics

HTML

Views

282

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Feb 08, 2018

Copy link to clipboard

Copied

At first I wondered if it could be because you are behind on your updates. You should be on 13.0.2.334. With that update you also have to select the layout again from the Gallery as the updates are different but they don't get applied automatically as that would override any customisation.

However, I tested with the latest versions and I see the problem you report.

It seems odd that the whole term is found but you cannot click the link. However, I think your only option is a bug report. Please follow this link to report bugs and request features. The more people who do so, the higher it gets prioritised.

https://tracker.adobe.com

Post the link to that bug/feature in this thread and others can vote for it.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Feb 08, 2018

Copy link to clipboard

Copied

Hi Peter,

Thanks for your super quick response!

I'll just add a note to the documentation to omit the % character when searching.  (however this relies on them reading it!) For now, this will do.

I was unable to login to the bug tracker from the link above,   "There was an error with this action. Try again later"

So, I'll try again later.......

thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Feb 08, 2018

Copy link to clipboard

Copied

Thinking out loud a bit here.

Does the same behavior occur if you surround the search string with quotes?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Feb 08, 2018

Copy link to clipboard

Copied

Later came sooner.

Here's the link to the reported bug:

Tracker

RH-1377 "Search doesn't work properly when a search term contains the % character"

If you need to search for it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
JGaf LATEST
Participant ,
Feb 08, 2018

Copy link to clipboard

Copied

Yes, even with quotes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...