Responsive, Merged Rh2015 project. CSH URL's being altered?

Community Beginner ,
Sep 14, 2015 Sep 14, 2015

Copy link to clipboard

Copied

I'm using RH2015 and have a Merged Project that I want to use a new Responsive layout with rather than current Webhelp output.

I have made no other changes to the structure of help so all that is new is the new layout type.

When the developers add it to the application if you click on Help – Main  the help opens at the correct opening page and you can navigate using the TOC, Index etc. This is the help page URL that is displayed….

 

index.htm#t=mergedProjects%2F00main%2Fhelphome%2Fhelp_home_page.htm

 

But when you are in a screen within the application and click the help button to get CSH (screen level help) the help page URL is being changed by something. It is adding the help home page details at the end of the page call as per....

 

index.htm?#mergedProjects/10act/act/acts012/acts012.htm=&t=mergedProjects%2F00main%2Fhelphome%2Fhelp_home_page.htm

 

This means page level help is not being displayed only the help home page.  

As a test I have reissued the help in Webhelp format and and when called from the application the help works correctly.

Is this problem likely to be a result of it being a merged project or simply as a result of the responsive html5 output?

Any ideas on how to get this resolved?   

TOPICS
HTML5 layout

Views

366

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 16, 2015 Sep 16, 2015

Copy link to clipboard

Copied

The context senstivive help call for HTML5 differs from the WebHelp call. If WebHelp works ok, your application needs to be updated.

How is your application calling the help?

See also: Context Sensitivity in Responsive and Multiscreen HTML5 | WvanWeelden.eu

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 16, 2015 Sep 16, 2015

Copy link to clipboard

Copied

Hi,

From the application the following URL is produced for the CSH and for Webhelp this works. This is an example from the development box.

ev-help//index.htm??#mergedProjects/10act/act/acts012/acts012.htm

For the QA box where the responsive layout was added, the URL was being changed by this a part being added to the end. =&t=mergedProjects%2F00 main%2Fhelphome%2Fhelp_home_page.htm

so it ended up like......

qa50-help//index.htm??#mergedProjects/10act/act/acts012/acts012.htm=&t=mergedProjects%2F00 main%2Fhelphome%2Fhelp_home_page.htm

No changes were made to the way the help was called from the application. Do you know what will need changing so it works?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 16, 2015 Sep 16, 2015

Copy link to clipboard

Copied

I don't know if this is relevant but our existing webhelp works as per the method described on Peter Grainge's website. Each help call is prefixed with either 1 or 2 query marks which then alternate.

From Peter's site:

''If you call a second topic in this way before the browser is closed, the new topic will not display and this was a problem. There are two solutions that I am aware of.

Solution 1

If your developers amend each call so that the first call has one query mark added and the next call has two query marks, then it will work correctly.

startpage?#path/topic1.htm

startpage??#path/topic2.htm

After that calls need to alternate so it would continue as below

startpage?#path/topic3.htm

startpage??#path/topic4.htm''

I note that the URL path for the help home page in the responsive layout (when opened locally on my machine directly) does not have this in it. It appears with #t= in the path as per....

index.htm#t=mergedProjects%2F00main%2Fhelphome%2Fhelp_home_page.htm

Could this be why its not working?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 16, 2015 Sep 16, 2015

Copy link to clipboard

Copied

The WebHelp method doesn't work for HTML5. What you can do is to amend your call to:

index.htm?t=path%2Fto%2Fyour%2Ftopic%2Ftopic.htm (where %2F stands for a /)

Alternatively, call the topic directly. That should avoid any issues with the URL and the help will open the skin automatically.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 16, 2015 Sep 16, 2015

Copy link to clipboard

Copied

OK thank you.

Can I just clarify this part once again please. I don't want to get the developers to make a change only to have to do it again.

You say amend the path to.........

index.htm?t=path%2Fto%2Fyour%2Ftopic%2Ftopic.htm (where %2F stands for a /)

The part i want to clarify is part directly after index.htm

Did you mean ?t=  as per your reply or should it be #t=  as per what I see when I open the help topic directly on my machine?

Many thanks for your help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 21, 2015 Sep 21, 2015

Copy link to clipboard

Copied

LATEST

Dom. Let me talk to you when I am available.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation