Highlighted

RH 2015 > nav bar layout corrupt when opening RH11 project

New Here ,
Jan 27, 2016

Copy link to clipboard

Copied

Hi,

I opened my RH11 project in RH 2015, and everything looks good except for my nav bar. My icons have all moved, there is a double scroll bar and arrow buttons appear in the header. Also - did Adobe add scrollbars, because I didn't design this project with scrollbars in it. Is there a way to turn them off?

Below are my before and after nav bars. (Don't worry about topic names, titles and content - I had to remove them before I posted this.) How can I fix this? I hesitate to do anything to the template without help as I might mess up the template.

Thanks,

Pam

Before:

RH11_nav_bar.PNG

After:

RH2015_nav_bar.PNG

I've just discovered another issue after I scrolled down to the bottom of the project - the placeholder text from the template appears. I searched through other scrollbar issues in the Forum, but can't find how to solve this.

version:  RoboHelp 2015 (12.0.0.306)

template:  Theme2_Government

placeholder_text_appears.png

TOPICS
HTML5 layout

Views

552

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

RH 2015 > nav bar layout corrupt when opening RH11 project

New Here ,
Jan 27, 2016

Copy link to clipboard

Copied

Hi,

I opened my RH11 project in RH 2015, and everything looks good except for my nav bar. My icons have all moved, there is a double scroll bar and arrow buttons appear in the header. Also - did Adobe add scrollbars, because I didn't design this project with scrollbars in it. Is there a way to turn them off?

Below are my before and after nav bars. (Don't worry about topic names, titles and content - I had to remove them before I posted this.) How can I fix this? I hesitate to do anything to the template without help as I might mess up the template.

Thanks,

Pam

Before:

RH11_nav_bar.PNG

After:

RH2015_nav_bar.PNG

I've just discovered another issue after I scrolled down to the bottom of the project - the placeholder text from the template appears. I searched through other scrollbar issues in the Forum, but can't find how to solve this.

version:  RoboHelp 2015 (12.0.0.306)

template:  Theme2_Government

placeholder_text_appears.png

TOPICS
HTML5 layout

Views

553

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 27, 2016 0
LEGEND ,
Jan 30, 2016

Copy link to clipboard

Copied

The Screen Layout is corrupted. This normally only happens when the .SLP (layout files) is opened in RoboHelp. The easiest solution:

  1. Add the (Government?) layout to the project again. Don't worry about customisations. We're fixing that in the next step.
  2. Go to the !SkinSubFolder! in the Robohelp project.
  3. Go to the folder holding the corrupted skin.
  4. Copy all the image files and the .CSS file. But only those files.
  5. Go the folder holding the newly added skin.
  6. Overwrite the images and CSS file with the copied files.
  7. Generate the project using the new skin.

Does that fix your issue?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2016 0
New Here ,
Jan 31, 2016

Copy link to clipboard

Copied

Willam,

From my backup of the Project:

  • Should I copy the entire Theme2_Government template folder into the !ScreenLayout! folder in my project folder on C:?
  • Or should I just copy the layout files into the existing, corrupted Theme2_Government template folder on C:, i.e. Layout.css, layout.js, layout_1.js?
  • Currently there are two folders in !SkinSubFolder! (in the Project folder on C:); Beautiful_Vista_Flash - which I am not using, and Default which only contains default.skn
  • Thanks,
  • Pam

RH2015_SkinSubFolder.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2016 0
Adobe Community Professional ,
Jan 31, 2016

Copy link to clipboard

Copied

I think that should have been:

2. Go to the !ScreenLayout! in the Robohelp project.

SkinSubFolder is for webhelp skins I believe.

I'd also highlight the following points (because I mis-read initially.):

- re-add the original RH theme to the project from within Robohelp.

- then use Windows Explorer to copy the following from your corrupted layout folder to the newly re-added theme folder: images and css.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2016 0
New Here ,
Jan 31, 2016

Copy link to clipboard

Copied

Amebr,

My developer looked at Willam's reply and did not understand it either.

So what she did was:

  • deleted the Theme2_Government layout from within RH that was corrupted
  • created an entirely new template and named it Theme2_Government
  • copied in the following files: images, css, js  and MasterThemeSchema.xml (what does this file do?)
  • recreated all the .slp files and copied in the content for these files. However, RH will not let us create SearchResults.slp - do you happen to know why? Can I just copy this from my backup and paste it into the Project folder?

Thanks for you help,

Pam

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2016 0
New Here ,
Jan 31, 2016

Copy link to clipboard

Copied

Well, I just generated with the changes we made (in my reply above), and that made the Project worse. Now it is totally unrecognisable. oi

What to do now?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2016 0
Adobe Community Professional ,
Jan 31, 2016

Copy link to clipboard

Copied

Disclaimers:

  • I currently use RH11 and Multiscreen HTML (not responsive)
  • I'm not an expert on Multiscreen, let alone responsive
  • I'm making some guesses about what Willam means and the problems encountered with the slp file - these guesses may be wrong.
  • Willam is the HTML5 expert.

We need Willam to chip in again as he's the expert, however, below is what I think is going on in the meantime.

I think Willam's advice assumes you haven't made extensive customisations to the HTML of the layout. so most of your changes would be changing the images and the css file only. In this case, copying your custom images and stylesheet to the newly added layout would fix the placeholder text, because the slp file would no longer be corrupt. This is why he said ONLY copy images and css file from your corrupted layout folder.

Assuming you only customised the images and stylesheet in your project (instructions are for RH11, so may be slightly different in RH2015, but should give you an idea of the process):

1. Replace your project with a copy from your backup, to get it back to the state in your original post.

2. In Robohelp, go to the Project Set-up pod and expand the Screen Layouts folder.

3. Right-click on Screen Layouts and select New Responsive Layout.

4. Select Theme2_Government, type a slightly different name (e.g. Theme2_Government_new) and click OK.

5. Right-click on the new layout and select Explore. Windows Explorer opens to the location of your new layout.

6. Navigate to your old (corrupt) layout folder (should be Theme2_Government) and select all images and css files (do not select any other file types such as javascript or the slp files).

7. Paste into your new layout folder (created in step 4. e.g. Theme2_Government_new) and overwrite the existing files.

8. Generate the project to see that everything is okay.

However (and I think this is your case) if you have customised the HTML of your layout, then I don't believe this process will completely work, as the .slp contains your HTML changes and as this is what is corrupted, you can't just copy the file across to the new layout. Willam will be able to confirm, but I think if this is your situation, you will need to manually make the HTML changes in your new .slp file - I don't know if the corruption problem is fixed in RH2015, so this may need to be done by manually opening the file in a text editor like Notepad. This manual update would slot in between steps 7 and 8 above, assuming I've understood the problem.

Feel free to wait for Willam to confirm or deny when his timezone is back online. Did I mention he's the expert.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2016 0
New Here ,
Jan 31, 2016

Copy link to clipboard

Copied

Thanks again Amebr. Yes, I did customise the layout of the template; I incorporated different colours, logo, and new buttons on the nav bar.

I guess I'll have to bring in my backup and start again. At least I have the changed topics in my Shared Resources folder and I should be able to bring these changes in once I reload the backup. I hope.

I'll also see what Willam has to say about the mess I have created.

Cheers,

Pam

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2016 0
New Here ,
Jan 31, 2016

Copy link to clipboard

Copied

Amebr,

I tried to set up the template as per your procedures above. But in step 4 - I cannot select Theme2_Government because it doesn't appear in the New Screen Layout popup, although it is clearly in my project.

new_screen_layout_popup.PNG

But I created a new layout anyway, naming it Theme2_Government_02. I then completed your steps 5 through 8. Then I manually created the Glossary, Index and Table of Contents and copied the html code for these items from my backup project. (I still can't create SearchResults.slp).

Then I generated and below are a few sections of my output. So now it's back to the drawing board. sigh

generated_output.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2016 0
Adobe Community Professional ,
Jan 31, 2016

Copy link to clipboard

Copied

I clicked the Check for New Screen Layouts and all I can think is you have a clean install rather than an over-the-top install, and the old layouts are not distributed with RH2015 any more. You can download a version of the layout for RH11 by following that link, so you could try deleting the contents of the new layout you created (in windows explorer) and pasting in the files from the zip, then replacing the images and css to see if you can at least get most of your customisations in place. Apart from that, we wait for Willam.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2016 0
LEGEND ,
Feb 01, 2016

Copy link to clipboard

Copied

From what I can gather, you are trying to add a responsive layout to the project. The government layout is Multiscreen. That explains why you don't see your layout in the list. The Responsive RoboHelp 11 layouts have been depracated and don't show up in RH2015 anymore. Based on the images you posted, you probably use the Desktop_Government multiscreen layout.

The thing is to add the layout from scratch. By copying only the CSS and images over to the newly added layout, you avoid the corrupted content but get your customisations back.

The MasterThemeSchema.xml controls the settings available in the Responsive Layout Editor in RoboHelp. You can add your own customisation for the interface there if you like mucking in the XML 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2016 0
New Here ,
Feb 01, 2016

Copy link to clipboard

Copied

Willam,

For the last 2 years I have been using Theme2_Government and generating as a Responsive layout without any real issues. This is the layout I used in RH11:

Theme2_Government layout.PNG

Yesterday my developer and I tried copying only the CSS and the images, but it still didn't generate correctly.

I then reverted to my backup project, created a new layout and called in Theme2_Government_02, copied in the CSS and images from my backup project, and manually created the Glossary, Index and Table of Contents. For the latter three items I copied the html code from the backup project. (I still can't create SearchResults.slp - it doesn't appear in the layout when I create it. Why not?) However, when I attempt to customise the layout, the layout looks nothing like the original Theme2_Government layout:

layout_customisation_popup.PNG

So where do I start now? My go-live is the 10th of Feb and I am panicking.

  • Do I import Theme2_Government into RH2015 from the Adobe website and customise it again?
  • Should I remove both the layouts I have in my projects and start again?
  • Should I try to fix the original layout?
  • Should I drink heavily?

output_setup_pod.PNG

Thanks again for all your help Willam. Again, I will have my developer look at your comments, but the problem is, my developers don't understand this application, but they try hard.

Cheers,

Pam

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2016 0
Adobe Community Professional ,
Feb 01, 2016

Copy link to clipboard

Copied

I recommend taking several deep breaths and making haste more slowly.

Let's try to get Theme2_Government into your project again, and at least see how it looks without any modifications.

Change the extension of the zip file you downloaded to .slz, then import into RH.

Change your SSL to use the newly imported layout and generate, just to see if it looks okay (without double scrollbars etc).

Once we see if the RH11 version imports okay, then we can look at what customisation options are needed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2016 0
LEGEND ,
Feb 02, 2016

Copy link to clipboard

Copied

Sorry about the confusion. I understand that I should have been more clear in what I was trying to achieve. Better late than never, so here it goes:

What I am trying to achieve with the steps I provided earlier was to create a new layout that does't have any issues. But you will want to retain your customisations.

The easiest way to get rid of a corrupted layout is to simply create a new one. Having to manually edit the HTML of the layout to make it work is not something I would recommend.

In your case, adding the second layout is exactly what was needed. This gives you a new layout. This will work when you create your output (I hope). But you will have lost your customisations.

Next up, you will need to restore your customisations. Basically all the files except for the *.slp files can be copied from the folder with the broken layout to the newly created layout. You do this using Windows, so no RoboHelp involved.

  1. In the !ScreenLayout!/Theme2_Government folder, copy the images, CSS and masterthemeschema.xml files.
  2. In the !ScreenLayout!/Theme2_Government_02 folder, paste the images, CSS and masterthemeschema.xml files.'
  3. In RoboHelp select the Theme2_Government_02 layout for your output.

If you skip the above steps, you can create an output for your project that will work. But it won't look as nice as your old layout.

After generation, your output should be ok. And all your modifications will be available as well. If this doesn't work (or is unclear) we can take other steps to get it rolling.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 02, 2016 0
New Here ,
Feb 02, 2016

Copy link to clipboard

Copied

Willam,

Ok, I have set up a meeting with my developer for tomorrow. We will start again and see if we can get this to work. You can imagine how large this project is since I have been adding to it for two years. I just don't have the time to go through the entire project and QA it again to see what the template is doing to the content. I am frustrated with the fact that Adobe got rid of this template.

In the meantime, I have reverted back to RH11 to meet my deadline. (Yes, my backup was saved for RH11 as I know RH is not backwards compatible.) After tomorrow I will let you know if we were successful or not. If not, the only other options for a project this size is to select a different template, or select a different application.

Thanks. I'll be back online after we try your above steps.

Pam

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 02, 2016 0
LEGEND ,
Feb 03, 2016

Copy link to clipboard

Copied

In the end it is an issue with the skin, not with RoboHelp itself. So no sweat on your hard work.

As a sidenode, you can downgrade RoboHelp projects to previous versions. Just check the compatibility issues you may find before downgrading. Please see: http://www.wvanweelden.eu/articles/downgrade-robohelp-project

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2016 0
New Here ,
Feb 03, 2016

Copy link to clipboard

Copied

Willam,

Thanks again for all your efforts to assist me with this issue. We have finally decided to let go of the old template and use one of the new templates. Too much hassle with the old one. And besides, I am much older and wiser now, so I know how to customise the templates with ease. We'll use RH11 for our releases with the old template until I can get the new template customised in RH2015.

Thanks again!

Bye for now,

Pam

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2016 0
Amebr LATEST
Adobe Community Professional ,
Feb 03, 2016

Copy link to clipboard

Copied

Nuts! I was hoping to piggyback off your experiences when we finally upgrade to RH2015

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2016 0