Highlighted

Rh 2019.0.9 to 2019.0.11 Behavior Change on Image Sizing

Community Beginner ,
Mar 19, 2020

Copy link to clipboard

Copied

I upgraded from 2019.0.9 to 2019.0.11 last night fix an issue.

 

After the upgrade, my 1540px x 1004px image (a png from a Visio diagram) is shrinking to fit my page width in the editor.  It previously did not shrink to fit.

 

The existing image map hot spots remain where they are, so don't align in the image map editor.  However, in HTML5 output, they align correctly.  They also look correct comparing coordinates with the coordinates of the zones in the image.

 

When I've published, the links are correct.

 

If I create a new page with the same image and add an image map, when I publish, the link is in the wrong place (because I drew it on the shrunken image).

 

This is a problem because if I want to add a new hotspot to my image map, I can't.  Well, I can, by hand-coding it in HTML.

 

a) is this a known bug on track to be fixed?

b) is there a way to set/override the page size in the editor so that it's large enough for the image not to shrink to fit?

 

Thanks.  Hoping not to have to downgrade as the extra padding at the top of the page was causing my pop-up links to be too large.

Looks like RH-6655 is the same issue or close enough.

 

Will be downgrading to 0.10 and parking there till this is fixed.  My entire project revolves around image maps.

Views

397

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Rh 2019.0.9 to 2019.0.11 Behavior Change on Image Sizing

Community Beginner ,
Mar 19, 2020

Copy link to clipboard

Copied

I upgraded from 2019.0.9 to 2019.0.11 last night fix an issue.

 

After the upgrade, my 1540px x 1004px image (a png from a Visio diagram) is shrinking to fit my page width in the editor.  It previously did not shrink to fit.

 

The existing image map hot spots remain where they are, so don't align in the image map editor.  However, in HTML5 output, they align correctly.  They also look correct comparing coordinates with the coordinates of the zones in the image.

 

When I've published, the links are correct.

 

If I create a new page with the same image and add an image map, when I publish, the link is in the wrong place (because I drew it on the shrunken image).

 

This is a problem because if I want to add a new hotspot to my image map, I can't.  Well, I can, by hand-coding it in HTML.

 

a) is this a known bug on track to be fixed?

b) is there a way to set/override the page size in the editor so that it's large enough for the image not to shrink to fit?

 

Thanks.  Hoping not to have to downgrade as the extra padding at the top of the page was causing my pop-up links to be too large.

Looks like RH-6655 is the same issue or close enough.

 

Will be downgrading to 0.10 and parking there till this is fixed.  My entire project revolves around image maps.

Views

398

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Mar 19, 2020

Copy link to clipboard

Copied

There are a number of image map items logged here: https://tracker.adobe.com/

 

If you do a search in this community, a few people have reported issues and perhaps some workarounds. Hopefully this link shows the search I tried: https://community.adobe.com/t5/forums/searchpage/tab/message?filter=location&q=image map&location=forum-board:robohelp&sort_by=-topicPostDate&collapse_discussion=true

 

(looks like it didn't translate into a link properly - copy everything from 'https' to 'true' and paste into your browser address bar)

 

I don't use image maps myself, so can't offer any advice.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 20, 2020

Copy link to clipboard

Copied

The problem is less about the image map and more about the image auto-sizing to fit the canvas in 0.11 where it did not auto size-to-fit in 0.9.

 

If I could change the canvas size to be large enough, it wouldn't auto-size (I hope).  For example, how do I create a landscape page?  Or a custom page size?

 

Either would be enough to get my diagram to not shrink.  And if it does not shrink, then the image map will work just fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Mar 23, 2020

Copy link to clipboard

Copied

I've got a 4k monitor. My image is almost a postage stamp on that monitor, and it still resizes in the editor. So at least in my experience it's not because the image doesn't fit the editor area.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 23, 2020

Copy link to clipboard

Copied

I'm a Robohelp novice, but have used various Adobe tools for years.  In my editor window, there's the white canvas (page) and a lot of dead space (I have 2k, 4k, and 3440x1440 monitors).  In Visio, I switch to a landscape canvas and there's a lot less dead space.  In Rh, the canvas is always a portrait page.

 

My diagram is in landscape, so in 0.10, it juts out off the right of the canvas (which is fine).  When the page is published, the page is the needed size and the canvas doesn't matter.  But in the editor, not so much.

 

I don't think monitor size has anything to do with it.  It's all about the size of the editable portion (canvas) where you can type and place objects.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Mar 22, 2020

Copy link to clipboard

Copied

There's no such thing as landscape and portrait on the web.

 

You could perhaps try turning off the Responsive setting in your skin, if it's on. It'll be in the Media Query section. I have no idea what effect that will have on your output though.

 

I really do think the issue you are seeing is described in the bugs logged in the tracker though. Or log your own bug if you think none of the existing issues describe your problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 22, 2020

Copy link to clipboard

Copied

Fair point about landscape/portrait.  I was really just trying to size the canvas differently since the image is auto-shrinking in the editor.

 

It renders at full size.  But the editor has it smaller, so editing the image map is creating hotspots in the wrong places.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Mar 22, 2020

Copy link to clipboard

Copied

Huh. I see what you mean. I'd report that as a bug. In my opinion, it shouldn't resize in the editor unless you specifically resize it.

 

You can report issues here: https://tracker.adobe.com/

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 22, 2020

Copy link to clipboard

Copied

Looks like RH-6655 is the same issue or close enough.

 

Will be downgrading to 0.10 and parking there till this is fixed.  My entire project revolves around image maps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Mar 23, 2020

Copy link to clipboard

Copied

I see the issue is still open . I take it that it will not be fixed for v12 then?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 23, 2020

Copy link to clipboard

Copied

I saw the priority went from "Normal" to "Critical" last night.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Mar 23, 2020

Copy link to clipboard

Copied

I've noticed that too. Images that I edited were suddenly incorrect, while the older ones still worked correctly on the output, while the image map would say they were all wrong.

 

One workaroud I found was that if you tell CSS that the image size should be exactly the size of the image in pixels, it doesn't scale in the editor. Sometimes. Maybe you need to close and restart RH. Of course, it doesn't scale in the output either if you do that.

 

This would be relatively easy to add if all your images have the same sizes. If they don't, it's not really a feasible option.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...