Highlighted

RH 2019 Classic and TFS 2017

New Here ,
May 06, 2019

Copy link to clipboard

Copied

We are moving to RH 2019 from RH 2017 and plan to initially use RH 2019 Classic until our users have the time to learn the new RH interface.   We are also moving to TFS 2017 from TFS 2013.  The RoboHelp 2019 documentation for configuring TFS Collaborate using Team Foundation Server appears to apply to the newer RH because it refers to the newer .rhpj project file, not the Classic .xpj project file.  Assuming RH 2019 Classic works with TFS 2017, how does one configure it?  Appreciate any assistance you can provide.

Topics

Classic, Version control

Views

438

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

RH 2019 Classic and TFS 2017

New Here ,
May 06, 2019

Copy link to clipboard

Copied

We are moving to RH 2019 from RH 2017 and plan to initially use RH 2019 Classic until our users have the time to learn the new RH interface.   We are also moving to TFS 2017 from TFS 2013.  The RoboHelp 2019 documentation for configuring TFS Collaborate using Team Foundation Server appears to apply to the newer RH because it refers to the newer .rhpj project file, not the Classic .xpj project file.  Assuming RH 2019 Classic works with TFS 2017, how does one configure it?  Appreciate any assistance you can provide.

Topics

Classic, Version control

Views

439

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 06, 2019 0
New Here ,
May 07, 2019

Copy link to clipboard

Copied

I have been going through this for a while now with Adobe. I've been told that for RH Classic 2019, I have to use TFS 2013 so I had to revert to that from TFS 2017, even though that had worked fine with RH 2015. Then to go forward, from what they're telling me, you have to go to TFS 2015 update 2 or later. With RH Classic 2019, the options for putting your project under Source Control are the same as in RH 2017, just select Add to Version Control under the Collaborate tab.

Adding the project under the new RH 2019 (not Classic) is what is shown in the documentation you refer to above because it's just the old way under RH Classic 2019.

My biggest caveat is make very, very sure you have checked in your good version of the project to TFS as well as taking multiple backups of your project locally so that should you have issues, you can revert.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2019 0
New Here ,
May 08, 2019

Copy link to clipboard

Copied

Thank you for your feedback.  I take your "you have to go to TFS 2015 update 2 or later" to mean RH 2017 is compatible with RH 2019 Classic.  Is the MSSCCI Provider that is required for TFS 2013 to RH 2017 connectivity also required for TFS 2017 to RH 2019 Classic connectivity?

Don't understand why someone with Adobe hasn't created a RH/TFS version compatibility chart just like Microsoft has for the TFS/Visual Studio/SQL Server products.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 08, 2019 0
New Here ,
May 08, 2019

Copy link to clipboard

Copied

I'm a bit confused by "RH 2017 is compatible with RH 2019 Classic."

Here's what I've gleaned from Adobe or my own experience:

RH 2015 was compatible with TFS 2017 and the appropriate MSSCCI.

RH Classic 2019:TFS 2013 update 5. The MSSCCI Provider is the one for TFS 2013 and is 32-bit.

RH 2019 only compatible with TFS 2015 update 2 and above.

That's my version of the table.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 08, 2019 0
New Here ,
May 09, 2019

Copy link to clipboard

Copied

Sorry, meant "TFS 2017 is compatible with RH 2019 Classic", the subject of this discussion, not "RH 2017 is compatible with RH 2019 Classic".

So to confirm, it sounds like the version of TFS compatibility to RH 2019 is dependent on the flavor, RH 2019 vs RH 2019 Classic?   For RH 2019 Classic, do you think it is TFS 2013 update 5 and above or only TFS 2013 update 5?

And if RH 2015 is compatible with TFS 2017, it doesn't make sense Adobe would go backwards and not continue to provide compatibility with TFS 2017 with RH 2019.  Perhaps your "RH 2015 was compatible with TFS 2017" isn't an official stand from Abobe - i.e. it just happen to work but no guarantees from Abobe?

Again, thanks for the info.  Been waiting for days for a response from RoboHelp.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 09, 2019 0
New Here ,
May 09, 2019

Copy link to clipboard

Copied

As far as I can tell, yes, it depends on the flavour of RH 2019. For RH Classic 2019, mine did not work with TFS 2017 and I was recommended by Adobe to revert back to TFS 2013 update 5, whereupon I was able to use Version Control.

When I had upgraded directly from RH 2015 directly through to RH 2019 without going through RH Classic 2019, the recommendation from Adobe at that point was that it was only supported with TFS 2017 update 2.

Yes, I did not understand why since I had been using RH 2015 with TFS 2017, that going up in RH version, I would have to go back in TFS version. It may not have been the RoboHelp official status at all and I was just lucky that it was working.

Again, my advice: take a million (ok, maybe three plus an extra one) local backups so you can always revert. Make sure you put a comment in your TFS  checkin before you start, something like, "Complete good version before update to RH 2019" so you can easily revert from here too.

Maybe go straight to the horse's mouth too and get it from them.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 09, 2019 0