Highlighted

RH 2019 new UI: Option to show gridlines of invisible tables in edit mode

Contributor ,
Feb 26, 2020

Copy link to clipboard

Copied

Hi,

is there an option to show the gridlines of invisible tables in the RH editor? This would make things much easier. However, I could not find such a thing. Is this a missing feature or did I simply search the wrong places?

Thanks and regards
Karin

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

There is no Word equivalent. The only thing I can suggest is a light grey border when working, then apply a master page when you generate where the border in the CSS linked to that is set to None.

 

Topics

New UI

Views

197

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

RH 2019 new UI: Option to show gridlines of invisible tables in edit mode

Contributor ,
Feb 26, 2020

Copy link to clipboard

Copied

Hi,

is there an option to show the gridlines of invisible tables in the RH editor? This would make things much easier. However, I could not find such a thing. Is this a missing feature or did I simply search the wrong places?

Thanks and regards
Karin

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

There is no Word equivalent. The only thing I can suggest is a light grey border when working, then apply a master page when you generate where the border in the CSS linked to that is set to None.

 

Topics

New UI

Views

198

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Feb 26, 2020

Copy link to clipboard

Copied

There is no Word equivalent. The only thing I can suggest is a light grey border when working, then apply a master page when you generate where the border in the CSS linked to that is set to None.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 26, 2020

Copy link to clipboard

Copied

Hmm, I think it's because of behind-the-scenes coding. When you insert a table using the button it hard codes some html properties that are deprecated in HTML5, but are valid for HTML4.

 

Specifically:

<table border="1" cellpadding="1" cellspacing="1" style="border-collapse:collapse; width:100%">

 

If you delete border="1" then you should see dashed lines for tables that don't have a border style. 

image.png

 

 

https://www.w3schools.com/tags/att_table_border.asp

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Contributor ,
Feb 28, 2020

Copy link to clipboard

Copied

Thanks Amebr,

I think this might have worked previous to update 11 (I think I remember seeing this). However, it does no longer work now. If border="1" is removed, no lines are visible in the edit mode at all.

Best regards

Karin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 28, 2020

Copy link to clipboard

Copied

The screenshot I took is with update 11, so maybe there is some other setting in your stylesheet. Check if you have the border set to white on the plain table style?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Contributor ,
Feb 28, 2020

Copy link to clipboard

Copied

Indeed, if I only remove the code you said from the default code, it works with dashed lines. However, as soon as a table style is applied, it doesn't. This is the css for my invisible table: 

table.Invisible td {
  padding-top: 3px;
  padding-right: 3px;
  padding-bottom: 3px;
  padding-left: 3px;
}

If I create a table in a topic by using the insert table function, then remove border="1" from the default code, the dashed lines are shown. Code looks as follows:

 <table cellpadding="1" cellspacing="1" style="border-collapse:collapse; width:100%">

 

If I create a table in a topic by using the insert table function, then select the table and assign the invisible table style, the dashed lines disappear. Code looks as follows:

 <table cellpadding="1" cellspacing="1" class="Invisible" style="border-collapse:collapse; width:100%">

If I do not remove the border="1" and assign my invisible table style, the table does not become invisible at all but keeps its frames in the edit mode and in the preview. Code looks as follows:

 <table border="1" cellpadding="1" cellspacing="1" class="Invisible" style="border-collapse:collapse; width:100%">

The problem seems to be something with the table style, but I don't understand why. However, if I use a table style, I have to remove the default code added by RH. Otherwise, the padding and spacing definitions exist twice (once in the default code and once in the css style) and this causes problems with the Word output.

Any further ideas?

Thanks and best regards

Karin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 28, 2020

Copy link to clipboard

Copied

Hmm I see what you mean.

 

I create a blank table without applying the style and deleted the border="1" code. The dashed lines appeared.

 

I manually typed the following style so I could select a style for the table. It has no styling so theoretically shouldn't change how the table displays.

 

table.Invisible {}

 

I selected the style and the dashed lines disappeared.

 

I think this might be technically correct for web display (there are no borders defined, so no borders should display), but for the editor I think Adobe might need to do some extra coding so that there are editing gridlines visible, like there are for a table without a style applied.

 

You can report issues here: https://tracker.adobe.com/

 

In the meantime, Peter's suggestion might work, although it's a bit tiresome.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...