Highlighted

RH11: HTML5 Web Help Search Field and Options

New Here ,
Jul 08, 2015

Copy link to clipboard

Copied

Hello-

I am creating a Responsive HTML5 user guide for a web-based application. I just generated the user guide and found one problem and a mystery:

1. When I use the Search field to search for a term in the content of the guide, I get no results and the guide only seems to refresh and send me back to the index page of the guide. What am I doing wrong?

2. These Search Options seemed to have appeared out of thin air. I don't know if these are supposed to be visible in the guide or what they are exactly supposed to do. Can you explain these features and their use to me, please?

Clip3.png

Thank you-

Michael

Topics

HTML

Views

137

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

RH11: HTML5 Web Help Search Field and Options

New Here ,
Jul 08, 2015

Copy link to clipboard

Copied

Hello-

I am creating a Responsive HTML5 user guide for a web-based application. I just generated the user guide and found one problem and a mystery:

1. When I use the Search field to search for a term in the content of the guide, I get no results and the guide only seems to refresh and send me back to the index page of the guide. What am I doing wrong?

2. These Search Options seemed to have appeared out of thin air. I don't know if these are supposed to be visible in the guide or what they are exactly supposed to do. Can you explain these features and their use to me, please?

Clip3.png

Thank you-

Michael

Topics

HTML

Views

138

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Jul 08, 2015

Copy link to clipboard

Copied

Which RoboHelp version? RH 11.0.4 or something else?

Did you per chance open the topic in the RoboHelp editor? Or did you only use the popup with settings to change the editor? The reason I ask is because the editor is known for causing problems.

If you open the Topic.slp with notepad++ and look at the end of the file, do you see some content that suggests search? Or only the topic placeholder?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 09, 2015

Copy link to clipboard

Copied

Hello Willam-

The help guide from which the image above was taken was generated using RoboHelp 11.0.2.240 by right-clicking on the Responsive HTML5 option in the Single Source Layouts pod, and selecting the Generate option from the menu which appears. This opens the Responsive HTML5 Settings dialog box. On this box I selected the Save and Generate button, and all files and topics are generated locally. I then selected the Index.htm file to open the completed help file and took the screen capture you see above.

We are currently developing a web-based application from which we intend to make this HTML5 help guide accessible.  When I generate the finished help guide and all related files on my local C: drive and then open the Index.htm file to view and test the finished help guide, it appears fine. However, when I put a search term into the search box and then hit enter, instead of searching the topic contents of the help guide and returning search results for the term I have entered, nothing happens in the help guide itself and a new Windows Explorer window opens to the local folder on my C: where all of the generated help guide files and folders reside. It's as if initiating a search via the search box in the help guide initiates a search for files on my computer instead of searching the written content of the help guide itself.

I was able to locate the Topic.slp file in Notepad and it appears that there is some content related to the generation of the search features displayed in my original screen capture above. What I am more concerned with is why the use of the Search function to search for written content among the topics of my help guide is not working.

Here's a screen capture of the area in the Topic.slp file that I believe generates those search features:

topicSLP.png

Do you have any advice for me on how to get the search function to work?

Thank you-

Michael

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jul 11, 2015

Copy link to clipboard

Copied

First off, please upgrade to RoboHelp 11.0.4. The patches contain enhancements to the output as well. Once upgraded, regenerate the output and try again.

If that doesn't help, add a new Responsive HTML5 Layout to the product and use that for generation. Does the search work in that case?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...