Highlighted

RH11 Will Not Generate a CHM

Explorer ,
Dec 17, 2015

Copy link to clipboard

Copied

Every once in a while, our RH11 applications won't generate a CHM file. It happens to me and a co-worker about once a week and usually one of the following occurs:

  • RH generates a CHM but the file doesn't have the proper weight. A normal CHM is about 10 MB but the problematic ones are usually no more than 5 KB.
  • RH displays an error message that the file is open in another application and to close the app and try to generate again. Of course, the file is not open anywhere.
  • RH completes the generation process but no CHM is generated.

After "generating" the CHM, RH display the completion message asking if we want to view the file, but clicking Yes does nothing.

We can usually solve the problem by shutting down RH, rebooting the workstation, or both. But now I've rebooted twice and even completely shutdown my pc, but still cannot generate a CHM. I've even tried changing the destination folder for the CHM, which sometimes works, to no avail. I am able to generate WebHelp.

Any ideas? Thanks.

When this has happened to me (RH10), check the output to see what file is the last one it works with. For me, it was the next .htm file alphabetically that hosed up the CHM generation. I had to go in and re-create the topic (and update any links, etc.) and then the .chm file was created just fine.

TOPICS
HTML

Views

186

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

RH11 Will Not Generate a CHM

Explorer ,
Dec 17, 2015

Copy link to clipboard

Copied

Every once in a while, our RH11 applications won't generate a CHM file. It happens to me and a co-worker about once a week and usually one of the following occurs:

  • RH generates a CHM but the file doesn't have the proper weight. A normal CHM is about 10 MB but the problematic ones are usually no more than 5 KB.
  • RH displays an error message that the file is open in another application and to close the app and try to generate again. Of course, the file is not open anywhere.
  • RH completes the generation process but no CHM is generated.

After "generating" the CHM, RH display the completion message asking if we want to view the file, but clicking Yes does nothing.

We can usually solve the problem by shutting down RH, rebooting the workstation, or both. But now I've rebooted twice and even completely shutdown my pc, but still cannot generate a CHM. I've even tried changing the destination folder for the CHM, which sometimes works, to no avail. I am able to generate WebHelp.

Any ideas? Thanks.

When this has happened to me (RH10), check the output to see what file is the last one it works with. For me, it was the next .htm file alphabetically that hosed up the CHM generation. I had to go in and re-create the topic (and update any links, etc.) and then the .chm file was created just fine.

TOPICS
HTML

Views

187

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 17, 2015 0
Contributor ,
Dec 17, 2015

Copy link to clipboard

Copied

When this has happened to me (RH10), check the output to see what file is the last one it works with. For me, it was the next .htm file alphabetically that hosed up the CHM generation. I had to go in and re-create the topic (and update any links, etc.) and then the .chm file was created just fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2015 0
Explorer ,
Dec 19, 2015

Copy link to clipboard

Copied

Thanks. That did the trick.

I found the offending topic file and conditioned it out. Then successfully generated a CHM. Funny thing - I removed the conditional tag and again successfully generated a CHM. Go figure...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2015 0
Contributor ,
Dec 21, 2015

Copy link to clipboard

Copied

That's great!   I don't think I ever did figure out why my topic was creating the problem. From what I could tell, comparing the code side-by-side, it appeared the same.  But... I decided to just be thankful it was only one topic.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 21, 2015 0