RH2015 - vertical scroll bar missing

New Here ,
Aug 12, 2015

Copy link to clipboard

Copied

RH2015 - After generating user help via Responsive HTML5 output, no vertical scroll bar is appearing on topics longer than the screen length. I am also unable to click in the topic and use the down arrow key to view entire topic contents.

TOPICS
HTML5 layout

Views

931

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

RH2015 - vertical scroll bar missing

New Here ,
Aug 12, 2015

Copy link to clipboard

Copied

RH2015 - After generating user help via Responsive HTML5 output, no vertical scroll bar is appearing on topics longer than the screen length. I am also unable to click in the topic and use the down arrow key to view entire topic contents.

TOPICS
HTML5 layout

Views

932

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 12, 2015 0
LEGEND ,
Aug 13, 2015

Copy link to clipboard

Copied

Which layout are you using? Can you create a new Layout (Azure Blue) and use that for your output. Do you see the scroll bar in that case?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 13, 2015 0
New Here ,
Aug 13, 2015

Copy link to clipboard

Copied

I was using the Charcoal layout (with the new Dynamic Content Filtering). Per your suggestion, I generated the user help again using the Azure Blue layout. Unfortunately, the missing scroll bar issue remains (in both IE and Chrome).

One thing to note, when I print a hard copy of the lengthier topic that is missing the scrollbar, the entire content is present. The information is there, the user is just unable to view the entire topic contents when displayed on screen. Thank you.

RoboHelp 2015 Version: 12.0.0.306

Operating System: Windows 7

IE version: 11.0.9600.17914

Chrome version: 44.0.2403.155 m

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 13, 2015 0
LEGEND ,
Aug 18, 2015

Copy link to clipboard

Copied

That is very strange. The technique used by the new layouts would normally prevent this kind of problem. Can you try generating the sample projects and see whether it occurs in the sample projects as well?

Would it be possible to share the long topic and your CSS with me? I would like to take a look at what is going on. You can contact me at contact [at] wvanweelden [dot] eu.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 18, 2015 0
New Here ,
Aug 18, 2015

Copy link to clipboard

Copied

Results of testing:

The scroll bars do appear after ... 

  • using the Dynamic Content Filter Multiple theme and generating the Travel_the_Whirls sample project packaged with RoboHelp
  • customizing the DCFM theme (i.e., after adding a custom logo, selecting a new font, and changing background color of header)

They do not appear after ...

  • applying my CSS to all topics contained within the sample project and using the Dynamic Content Filter Multiple theme when generating

So, it looks like we've found the culprit ... sort of ... Now to discover what piece of the CSS is preventing the scroll bars from appearing and communicate the resolution to others who are also experiencing the issue.

I will email my CSS to the email address you provided. Thank you in advance for your assistance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 18, 2015 0
LEGEND ,
Aug 19, 2015

Copy link to clipboard

Copied

The issue is caused by the CSS. Line 53 to 57 have the definition:

body {

  font-family: Arial;

  background-color: #ffffff;

  overflow-y: hidden;

}

Remove the third property 'overflow-y: hidden;' and your scroll bar returns.

Kind regards,

Willam

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2015 0
New Here ,
Aug 20, 2015

Copy link to clipboard

Copied

The 'overflow-y: hidden;' code was added by our developers to resolve a "flashing scroll bar" issue occurring when generating Responsive HTML5 user help from RoboHelp version 11. When I asked one of our developers if they recalled what was causing the flashing behavior, I was told the following.

"Each pane had its own scroll bar outside of the browser scroll bars and something was pushing the page content like 20px to the right. I think it was the navigation menu items in the table of contents as they loaded."

Nevertheless, I will remove the code as per your instruction and see what happens using RoboHelp 2015. Thank you for all of your efforts in resolving this issue. It is genuinely appreciated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2015 0
LEGEND ,
Aug 25, 2015

Copy link to clipboard

Copied

The output changed from RH11 to later. There is no longer a need for the CSS in 2015. So you won't see the flashing scrollbar issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2015 0
New Here ,
Aug 18, 2015

Copy link to clipboard

Copied

I'm having the same problem - I'd appreciate any help on how to see scroll bars.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 18, 2015 0
LEGEND ,
Aug 18, 2015

Copy link to clipboard

Copied

Are you using the same layout as the original poster? Also, does it work when you generate output for one of the sample projects?

Would it be possible to share a sample topic and your CSS with me? I would like to take a look at what is going on. You can contact me at contact [at] wvanweelden [dot] eu.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 18, 2015 0