Highlighted

RH2019.0.12 new UI Responsive HTML5 output no longer working

Engaged ,
Apr 02, 2020

Copy link to clipboard

Copied

Hi all,

I am testing the update 12 for RH 2019 new UI on a virtual machine. For most of my projects, the responsive HTML5 output is working. However, it is NOT working for my parent project and also not for new projects.

What I did:

I created a new project. I just use the existing default topic. I did not add any css, master pages or the like. I used the output path Documents\My Robohelp Projects\ (this path is working for the other projects). 

When I start the HTML5 output (I also created several of them, not always using the same one), it says "Starting generation" and this is it. This message is displayed for hours. If I try to dismiss the output, the message to the bottom left disappears, but the output is still trying to generate. The log is offered in the context menu, but cannot be opened.

 

Does anyone have similar issues? Any ideas where I might search for the problem? 

Thanks and best regards
Karin

Yes, German will have issue. Please do the following

Go to the Output tab

  • On left side toolbar, last button is for Synonyms, click that
  • In the Synonyms panel, click + button and select German language
  • Synomyms editor will open on right hand side
  • For both Words and synonyms, enter "a" or something and press enter (+ button is not working here)
  • You will see entry added in the next line
  • Save the file
  • After that you can delete the synonyms entry if you want and save again.
  • Generate should work fine after that.

 

If you have more than one project then you can manually copy de_DE.syn file to publish\languages\synonyms subdirectory in all the projects. You can avoid all the steps above.

Views

340

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

RH2019.0.12 new UI Responsive HTML5 output no longer working

Engaged ,
Apr 02, 2020

Copy link to clipboard

Copied

Hi all,

I am testing the update 12 for RH 2019 new UI on a virtual machine. For most of my projects, the responsive HTML5 output is working. However, it is NOT working for my parent project and also not for new projects.

What I did:

I created a new project. I just use the existing default topic. I did not add any css, master pages or the like. I used the output path Documents\My Robohelp Projects\ (this path is working for the other projects). 

When I start the HTML5 output (I also created several of them, not always using the same one), it says "Starting generation" and this is it. This message is displayed for hours. If I try to dismiss the output, the message to the bottom left disappears, but the output is still trying to generate. The log is offered in the context menu, but cannot be opened.

 

Does anyone have similar issues? Any ideas where I might search for the problem? 

Thanks and best regards
Karin

Yes, German will have issue. Please do the following

Go to the Output tab

  • On left side toolbar, last button is for Synonyms, click that
  • In the Synonyms panel, click + button and select German language
  • Synomyms editor will open on right hand side
  • For both Words and synonyms, enter "a" or something and press enter (+ button is not working here)
  • You will see entry added in the next line
  • Save the file
  • After that you can delete the synonyms entry if you want and save again.
  • Generate should work fine after that.

 

If you have more than one project then you can manually copy de_DE.syn file to publish\languages\synonyms subdirectory in all the projects. You can avoid all the steps above.

Views

341

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 02, 2020 3
Adobe Community Professional ,
Apr 03, 2020

Copy link to clipboard

Copied

I am not inclined to blame working on a virtual machine but I think I would create a new project not on a virtual machine to prove that.

 

Any issues with other programs?

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2020 0
Adobe Employee ,
Apr 03, 2020

Copy link to clipboard

Copied

Karin,

 

What is the language of the Project? There is one issue with non-english project in update 12 which is blocking generation of Frameless and Resposive HTML5 outputs. Workaround is to create a Synonyms entry for that language.

 

Thanks,

Vivek

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2020 0
Engaged ,
Apr 03, 2020

Copy link to clipboard

Copied

Hm, I know that the VM is pretty slow. However, due to several bugs and problems with previous RH2019 updates, I decided to test each update on a VM before updating my real working area to ensure that all functions that I need are still working as expected.

Do you mean it would be better to create the project on my normal computer and copy it to the VM? Or do you mean you would not recommend working with a VM at all?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2020 0
Engaged ,
Apr 03, 2020

Copy link to clipboard

Copied

Vivek, language is German. I have a meeting now and will run another test with English language setting. Thanks for the hint.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2020 0
Adobe Employee ,
Apr 03, 2020

Copy link to clipboard

Copied

Yes, German will have issue. Please do the following

Go to the Output tab

  • On left side toolbar, last button is for Synonyms, click that
  • In the Synonyms panel, click + button and select German language
  • Synomyms editor will open on right hand side
  • For both Words and synonyms, enter "a" or something and press enter (+ button is not working here)
  • You will see entry added in the next line
  • Save the file
  • After that you can delete the synonyms entry if you want and save again.
  • Generate should work fine after that.

 

If you have more than one project then you can manually copy de_DE.syn file to publish\languages\synonyms subdirectory in all the projects. You can avoid all the steps above.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2020 1
Adobe Community Professional ,
Apr 03, 2020

Copy link to clipboard

Copied

No I didn't mean to suggest using a VM is not an acceptable way of working. What I suggested was simply the start of some troubleshooting.

 

Go with Vivek on this. I would be happy if I knew 10% of what he does about RoboHelp. 🙂

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2020 0