RH2020: Include all words in search results = 0 results for merged/combined help

Engaged ,
Jan 24, 2021

Copy link to clipboard

Copied

Upgraded from RH 2020.1 to RH 2020.3 (skipped over the .2 update and went straight to .3).

Generating Responsive HTML5 output with Azure_Blue.

Output is merged help, consisting of 1 parent and 11 child projects.

 

In RH 2020.1, end users could enter 2 or more search terms, select Include all words in search, and the search function would return results.

 

After upgrading to RH2020.3, if end users enter 2 or more search terms and select Include all words in search, they receive 0 results. Note that these are searches that returned results in the output generated in RH2020.1. End users only get results if the Include all words in search is NOT selected.

 

brokensearch.jpg

Note that curiously, the one match from my glossary is correctly (I have it intentionally enabled in our build settings) returned and displayed (I cropped out the definition in the attached image, but it displays correctly in the live system).

 

I generated a standalone (altogether different output preset) Responsive HTML5 Azure_Blue output for one of the child projects and the Include all words in search results function worked correctly. I tried creating a brand new output preset for my parent project, but still got the 0 results issue.  

 

I exhausted a number of different tests - created new skins, created new build definitions, changed Search settings to try to get it to work, but no luck.

 

Thoughts?

TOPICS
New UI, Output presets

Views

92

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 25, 2021

Copy link to clipboard

Copied

Is that setting applied in all the projects?

 

Assuming it is, I will check a merge later but meantime I think it worth either trying Support or reporting it as a bug.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
RoboFan AUTHOR
Engaged ,
Jan 25, 2021

Copy link to clipboard

Copied

Build settings (Search, for example) are identical (minus the obvious stuff) for all projects that are part of the merged help. Even the skins are identical, although I know they don't need to be - we just do it to remove one more potential variable from the equation, and it makes things simpler.

 

I generated the same output in RH2020.1 immediately prior to upgrading every project to RH2020.3. And there were no changes in RH2020.3 - to content, build settings or otherwise. It just doesn't work.

 

I've rolled back to RH2020.1 - both my local app install and our projects. I'll be testing the build there again. If everything works, I'll likely run a test against RH2020.2 

 

Logging a bug against RH2020.3 in the meantime.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 25, 2021

Copy link to clipboard

Copied

Seeing the same in Azure Blue. Without the check box selected it returns three instances. Select that check box and it gives 0 results.

 

Log a bug and post the link here.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
RoboFan AUTHOR LATEST
Engaged ,
Jan 25, 2021

Copy link to clipboard

Copied

Thank you for verifying, Peter. 

 

Bug logged here: https://tracker.adobe.com/#/view/RH-8549 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more