Highlighted

RHCL with Indigo Layout does not include Filter button and pane

Explorer ,
Sep 28, 2018

Copy link to clipboard

Copied

Hi,

I'm currently working on getting our RoboHelp 2017 (Update 2) project to compile properly via RHCL. In our project, we use a heavily customized version of the Indigo layout. I noticed that, when I use RHCL to compile the project via the command line, the Filter buttons and panes (on Start and Topic pages) are not included in the output, even though dynamic content filters are activated in the used Output Setup and Layout.

At first I suspected that it has something to do with our customizings to the Indigo layout, so I tried the same thing with a completely new project with only 2 topics and no CSS or layout customizings. The topics have two conditional tags "casual" and "power" assigned (on topic-level) and the TOC shows them in hierarchical order Topic 1 (causual) >> Topic 2 (power). The dynamic content filter is set up to either include or exclude the topic with "power" tag (via conditional expression). This is the project which I then tried to compile manually and with RHCL.

When compiling the project manually from the RoboHelp GUI, the Filter button is correctly included and I can switch the content in the filter pane.

When compiling the project via RHCL, the Filter button is hidden both on the Homepage and on the Topic pages. I cannot use the filter.

Below, you can see the output topic pages for manual and rhcl:

  • Manual output - You can see the filter button

manual_filter_button.png

  • Manual output --> The Filter pane opens and works

manual_filter_pane.png

  • RHCL output --> No Filter button

rhcl_filter_no_button.png

Our new product documentation depends heavily on filters working, does anyone have an idea why RHCL does not produce the Filter pane?

Thanks in advance,

Birgit

Adobe Community Professional
Correct answer by Jeff_Coatsworth | Adobe Community Professional

Congrats - I think you've found a bug. Please log a bug in the Tracker to get it on Adobe's radar.

Topics

HTML5 layout

Views

314

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

RHCL with Indigo Layout does not include Filter button and pane

Explorer ,
Sep 28, 2018

Copy link to clipboard

Copied

Hi,

I'm currently working on getting our RoboHelp 2017 (Update 2) project to compile properly via RHCL. In our project, we use a heavily customized version of the Indigo layout. I noticed that, when I use RHCL to compile the project via the command line, the Filter buttons and panes (on Start and Topic pages) are not included in the output, even though dynamic content filters are activated in the used Output Setup and Layout.

At first I suspected that it has something to do with our customizings to the Indigo layout, so I tried the same thing with a completely new project with only 2 topics and no CSS or layout customizings. The topics have two conditional tags "casual" and "power" assigned (on topic-level) and the TOC shows them in hierarchical order Topic 1 (causual) >> Topic 2 (power). The dynamic content filter is set up to either include or exclude the topic with "power" tag (via conditional expression). This is the project which I then tried to compile manually and with RHCL.

When compiling the project manually from the RoboHelp GUI, the Filter button is correctly included and I can switch the content in the filter pane.

When compiling the project via RHCL, the Filter button is hidden both on the Homepage and on the Topic pages. I cannot use the filter.

Below, you can see the output topic pages for manual and rhcl:

  • Manual output - You can see the filter button

manual_filter_button.png

  • Manual output --> The Filter pane opens and works

manual_filter_pane.png

  • RHCL output --> No Filter button

rhcl_filter_no_button.png

Our new product documentation depends heavily on filters working, does anyone have an idea why RHCL does not produce the Filter pane?

Thanks in advance,

Birgit

Adobe Community Professional
Correct answer by Jeff_Coatsworth | Adobe Community Professional

Congrats - I think you've found a bug. Please log a bug in the Tracker to get it on Adobe's radar.

Topics

HTML5 layout

Views

315

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Sep 28, 2018

Copy link to clipboard

Copied

Congrats - I think you've found a bug. Please log a bug in the Tracker to get it on Adobe's radar.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Sep 30, 2018

Copy link to clipboard

Copied

Hi Jeff,

I opened a bug with Adobe: Tracker  (RH-2851)

Too bad, the RHCL would be great to integrate the help with our automated build environment - but not if it isn't fully working.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Oct 01, 2018

Copy link to clipboard

Copied

Might be worth contacting Adobe Support to see if they can confirm it is a known issue or have a soluiton.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Oct 01, 2018

Copy link to clipboard

Copied

I'm currently in contact with Adobe Support for this issue.

I have also found out that the problem isn't restricted to the Indigo layout. It also happens with Charcoal Grey and Azure Blue. Basically, the Filter button and panel is not included in the RHCL-compiled output for all available HTML5 layouts.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Oct 01, 2018

Copy link to clipboard

Copied

Sorry we couldn't help here. Please post the response you get as that will help others.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Oct 02, 2018

Copy link to clipboard

Copied

Hi all,

Adobe has confirmed that this behavior is a bug. They can't offer a solution at this point, I'll have to wait for a future Update of RoboHelp.

Just FYI.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Faeneth LATEST
Explorer ,
Oct 02, 2018

Copy link to clipboard

Copied

Please everybody vote on the bug I opened so this issue will be fixed in the foreseeable future .

Tracker

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...