Highlighted

RoboHelp 11 crashes when trying to export DOCX

New Here ,
Aug 18, 2015

Copy link to clipboard

Copied

Hi,

This may be a generic topic but I just need to get clues as to what is causing Robohelp to crash when simply trying to generate a DOCX file from my project. The log file compiles the topics and gets to the saving docx part then crashes.

Any info would be greatly appreciated.

Jaime

Topics

Documentation

Views

339

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

RoboHelp 11 crashes when trying to export DOCX

New Here ,
Aug 18, 2015

Copy link to clipboard

Copied

Hi,

This may be a generic topic but I just need to get clues as to what is causing Robohelp to crash when simply trying to generate a DOCX file from my project. The log file compiles the topics and gets to the saving docx part then crashes.

Any info would be greatly appreciated.

Jaime

Topics

Documentation

Views

340

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 18, 2015 0
Adobe Community Professional ,
Aug 20, 2015

Copy link to clipboard

Copied

Does it also crash if you try to generate one of the sample projects?

Click Open on the RoboHelp Starter page and then click Samples in the ribbon on the left.

Please try as that will help pinpoint the next step to solving the problem.

Also try generating to DOC only.

Post back how you get on.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2015 0
Explorer ,
Jul 12, 2018

Copy link to clipboard

Copied

I am having the same problem.  When I tried to generate a sample project, it did generate, but aside from one horizontal line on the first page, the document came out completely blank.  Word's information readout in the bottom left corner seemed to think the document included ~900 words, but I couldn't see anything, nor could I select anything.

I'm trying to generate individual documents now, and the generation scroll is throwing an error:  "Warning:  Word document became corrupt when trying to append a malformed topic [$Topic_Name]"  What does that mean?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 12, 2018 0
Adobe Community Professional ,
Jul 12, 2018

Copy link to clipboard

Copied

See Print Issues on my site. See if it helps and post back if not.

Peter Grainge

www.grainge.org

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 12, 2018 1
Explorer ,
Jul 12, 2018

Copy link to clipboard

Copied

Hi, Peter,

I spent all day removing "mso" crap from the source, split the file into multiple documents, and changed the output to .doc iteratively, and now the file generates, but the pages are still all blank.  Word recognizes that there is data there, because it still says e.g. "Page 1 of 44, contains 44 928 characters," but the output appears completely blank.  I need to have this to my supervisor ASAP (like yesterday) and I'm stumped.

If you have any idea, please let me know.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 12, 2018 0
Adobe Community Professional ,
Jul 12, 2018

Copy link to clipboard

Copied

Could the text have somehow been set to white in your word document? Although you should still be able to select the document in that case.

I'd try pressing Ctrl+A to select the whole document, then select black for the font colour.

Oh wait, I think I just replicated the problem with not being able to select anything - I set all my text to be hidden and turned off the display of hidden text (although that then shows a zero word count...). So another thing to try. Go into Word settings (File > Options > Display, assuming Word 2013), and make sure Hidden text is selected.

If it works, it might point you to what's causing the issue from RH.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 12, 2018 0
Adobe Community Professional ,
Jul 13, 2018

Copy link to clipboard

Copied

If Amber's suggestion does not help, when you generate are you selecting a CSS file or mapping to a Word template?

Try setting the option to CSS File but not the one used in your topics or the one currently used, if applicable. Use any CSS file. The output may look rubbish but at least if you see the text we would be getting somewhere.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 13, 2018 0
Explorer ,
Jul 13, 2018

Copy link to clipboard

Copied

Hi, Amber, I couldn't select any text at all, and tried turning on the "Show Code" option (looks like a Paragraph tag), and got nothing.

S.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 13, 2018 0
Explorer ,
Jul 13, 2018

Copy link to clipboard

Copied

Hi, Peter Grainge

I tried setting the CSS to a different file, and deleted a topic that was cruft, but now it's throwing the error "Unable to generate printed documentation," and I'm completely lost.  My boss is getting frustrated with this, and it's wearing on me.

I am compiling HTML Help right now as a test with BugHunter enabled.

Anything else you can think of for me to try?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 13, 2018 0
Explorer ,
Jul 13, 2018

Copy link to clipboard

Copied

CHM compile works fine.  No idea what's plaguing the Word/PDF.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 13, 2018 0
Adobe Community Professional ,
Jul 13, 2018

Copy link to clipboard

Copied

Create two copies of your print layout. In the second page of one, delete half the topics and in the other copy, delete the other half.

Does one of those layouts now work?

If not, can you share the project? See the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

I'll try to look at it over the weekend.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 13, 2018 0
Explorer ,
Jul 13, 2018

Copy link to clipboard

Copied

Hi, Peter Grainge​, I apparently had some kind of issue with my installation of MS Office. I now have a help file, even if it's kind of ugly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 13, 2018 0
Adobe Community Professional ,
Jul 13, 2018

Copy link to clipboard

Copied

Something you can resolve?

Peter Grainge

www.grainge.org

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 13, 2018 0
Amebr LATEST
Adobe Community Professional ,
Jul 13, 2018

Copy link to clipboard

Copied

Hmm, I think I had the paragraph button selected but the hidden text still didn't show, so maybe if the setting is turned off in Options it's off-off. Might be worth checking next week for future reference.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 13, 2018 0