Highlighted

Robohelp 2015 - Anchors showing up as topics in the TOC

Explorer ,
Feb 12, 2019

Copy link to clipboard

Copied

Hi,

Does anyone have a solution to this predicament?  All of a sudden Robohelp 2015 decided to display anchors in topics as topics and topics containing the anchors as books when you move the topics/folders from the Project Manager tab to the TOC side.

If I move the topic on its own it looks fine but the anchor call doesn't work from Chrome, Edge and/or Firefox.  The page loads but it does not bring you to the anchor.  It only works under IE...  This is true no matter how the topic is moved over to the TOC.

The project is being compiled as Responsive HTML5.

Thanks,

John

TOPICS
Classic

Views

407

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Robohelp 2015 - Anchors showing up as topics in the TOC

Explorer ,
Feb 12, 2019

Copy link to clipboard

Copied

Hi,

Does anyone have a solution to this predicament?  All of a sudden Robohelp 2015 decided to display anchors in topics as topics and topics containing the anchors as books when you move the topics/folders from the Project Manager tab to the TOC side.

If I move the topic on its own it looks fine but the anchor call doesn't work from Chrome, Edge and/or Firefox.  The page loads but it does not bring you to the anchor.  It only works under IE...  This is true no matter how the topic is moved over to the TOC.

The project is being compiled as Responsive HTML5.

Thanks,

John

TOPICS
Classic

Views

408

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 12, 2019 0
Adobe Community Professional ,
Feb 13, 2019

Copy link to clipboard

Copied

Are you talking about source or output. A screenshot would help.

I have not seen this reported before. Have you tried deleting the CPD file and reopening the project? Perhaps even a machine reboot.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0
Explorer ,
Feb 13, 2019

Copy link to clipboard

Copied

Hi Peter,

I deleted the cpd file, rebooted the machine and it still shows up as previously mentioned...  Note that what you see in the TOC is what you see in the browsers.

Capture1.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0
Adobe Community Professional ,
Feb 13, 2019

Copy link to clipboard

Copied

Bookmarks in topics do show with the topic icon in the TOC editor and in the output.

toc.png

The TOC you see was auto-created when bookmarks get indented from the topic within a book. I manually created another TOC with the three topics and the bookmark inline and they stayed as a straight list.

So using auto-create, what you are seeing is what I would expect. You can delete the book and the bookmark and then insert them manually so that there are two entries rather than a book which will open the topic and also show the bookmark.

Also in Firefox, the link to the bookmark worked fine.

Can you show us a screenshot of how it used to be from a backup?


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0
Explorer ,
Feb 13, 2019

Copy link to clipboard

Copied

I never use the Auto-Create feature.  As you can see below, the Ledger folder was manually moved over to the TOC on a previous date and the topics within work fine.  I've also deleted the Company's book and bookmark and manually moved the topic back to the TOC and it still doesn't go to the bookmark when using Firefox.  I have also checked that the Unison Spreadsheet topic's properties is structured the same as the Company one, meaning that the bookmark shows up the same way.

Capture1.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0
Adobe Community Professional ,
Feb 13, 2019

Copy link to clipboard

Copied

Your TOC is created by dragging a folder from Project Manager to the TOC, correct? I haven't tested that but would expect it to work in the same way as Auto Create, for this purpose. It's a bit difficult to see whether Ledger is right or not without knowing the project.

So when you create the way I suggested, it looks as required but has the other issue, it doesn't work. Correct?

I don't have 2015 installed any more so I tested in 2017. I am wondering if this is one of those issues caused by browser updates. I assume you have applied all the 2015 updates.

Can you share the project with me? I can then test in 2017. See the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0
Explorer ,
Feb 13, 2019

Copy link to clipboard

Copied

"Your TOC is created by dragging a folder from Project Manager to the TOC, correct?"

     Yes sir.

"So when you create the way I suggested, it looks as required but has the other issue, it doesn't work. Correct?"

     That is correct.

The project has been sent.

Thanks Peter.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0
Adobe Community Professional ,
Feb 13, 2019

Copy link to clipboard

Copied

What you have sent is incomplete. It contains the root folder and all its files but the sub-folders are empty. That results in broken links galore and the TOC is going to be pointing to content you haven't sent. I need the whole project to test for you.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0
Explorer ,
Feb 13, 2019

Copy link to clipboard

Copied

I just sent it a gain as a zip file.  Does this work?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0
Adobe Community Professional ,
Feb 13, 2019

Copy link to clipboard

Copied

Sorry to butt in here, by chance were the original topics part of a Word Import? I recall that odd things can happen when you import a Word document that happens to have an automatic TOC based upon heading styles and you tick the Import option to include the Word-created TOC into the RoboHelp project TOC.

My experience is that the Word doc's heading 1 appears as bookmark icon in the RH Project Manager. Heading 2 shows as a bookmark. However, in RoboHelp the "parent" heading 1 based topic becomes a "Book" and the Heading 2 topics become nested inside the parent book. So the screenshot shows the topic Absences, but the auto-TOC creates a Book and two heading 2-based topics nested inside.

When making an AutoTOC in RH you might also check what you want to do with this tick mark on mid-topic links.

My scenario is not exactly the same as poster JCCS3 so I hope I'm not sending you down a rabbit hole. Still thought I'd pass this odd "as designed" behavior along as a place to look.

John

John Daigle

Adobe Certified RoboHelp and Captivate Instructor

Evergreen, Colorado

www.showmethedemo.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0
Adobe Community Professional ,
Feb 13, 2019

Copy link to clipboard

Copied

Yes that unzips OK.

Could you please let me have an example with specific steps of something in Project Manager that is coming across to the TOC incorrectly and the output you are seeing this in.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0
Explorer ,
Feb 13, 2019

Copy link to clipboard

Copied

Thanks for your reply John but none of the topics have been imported.  They all have been hand bombed and I always drag and drop the files from Project Files to TOC.

Peter,

If you delete the Payable book and all its sub topics from the TOC and drag and drop the Payable folder from the Project Manager to the TOC, you will notice the previously mentioned results.  You can then open the project in Firefox, navigate to the Payable, Maintenance and Supplier page.  Within the Supplier page you'll see the Company Discount Account link.  This will bring up the Company topic and it should scroll down to Discount Account.  Again this works in IE but not in other browsers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0
Adobe Community Professional ,
Feb 14, 2019

Copy link to clipboard

Copied

First let's look at the layout of the TOC.

If you drag the Payable folder across, you will get a TOC that looks like this.

toc4.png

Why? Expand the Project Manager and this is what you will see. No topics visible at this stage, just a subfolder.

toc1.png

When you go to the TOC and click Payable, this is what you will see. Effectively exactly the same.

toc2.png

Now go back to Project Manager and expand Maintenance. You will see the topics all under Maintenance. Also Company has a + sign to indicate there are bookmarks.

toc3.png

Look again at the first image and you are seeing exactly the same thing in both. Folders get converted to Books, also Topics with bookmarks get converted to Books. Doing it that way has, as far as I can recall, always worked that way.

I can't see that anything is wrong at that point but your original post seems to suggest you think it is a change.

Now looking at how links to bookmarks work, I can see the problem here. In the Company page, scroll to the bottom and create a bookmark against Sample. Now go to the Supplier page and create a link to that. Generate and I think you will find the page scrolls down.

What seems to be happening is that if the bookmark is visible, the browser is not scrolling the page so that the bookmark is at the top. It's visible so job done seems to be what is happening. I can only suggest you report that as a bug.

Please follow this link to report bugs and request features. The more people who do so, the higher it gets prioritised.

https://tracker.adobe.com

Post the link to that bug/feature in this thread and others can vote for it.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2019 0
Explorer ,
Feb 14, 2019

Copy link to clipboard

Copied

Thanks for help Peter.  I hope they fix this bug soon.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2019 0
Adobe Community Professional ,
Feb 14, 2019

Copy link to clipboard

Copied

Only if you report it. I haven't seen anyone else pick up on it.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2019 0