Highlighted

Robohelp 2017 Books in TOC Not Expanding to Show Topics

New Here ,
Jan 24, 2018

Copy link to clipboard

Copied

I looked at older threads (12/2016) on this issue and it seems that there hasn't been a fix for this. I have a RH 2017 project with books in the table of contents. There are topics within each book. When the project initially is displayed in the browser, and I click on a book, it opens. As I start to click on other books, nothing happens. This is happening in Google Chrome (v 63.3239.132), but works fine in Firefox and IE. Any suggestions or work-arounds to fix this?

Thanks,

Andrea

Views

676

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Robohelp 2017 Books in TOC Not Expanding to Show Topics

New Here ,
Jan 24, 2018

Copy link to clipboard

Copied

I looked at older threads (12/2016) on this issue and it seems that there hasn't been a fix for this. I have a RH 2017 project with books in the table of contents. There are topics within each book. When the project initially is displayed in the browser, and I click on a book, it opens. As I start to click on other books, nothing happens. This is happening in Google Chrome (v 63.3239.132), but works fine in Firefox and IE. Any suggestions or work-arounds to fix this?

Thanks,

Andrea

Views

677

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 24, 2018

Copy link to clipboard

Copied

Have you tried the steps listed in the answer post on this thread? (Post 68 by Peter Grainge)

ToC books not opening in Chrome

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 29, 2018

Copy link to clipboard

Copied

Yes, I tried all the suggested in the thread you posted and nothing helps. Any other suggestions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 29, 2018

Copy link to clipboard

Copied

Specifically Post 68 as that has worked for everyone else?

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 29, 2018

Copy link to clipboard

Copied

Yessss! I tried editing the file in Notepad ++ instead of Notepad and it worked. Thanks so much for this fix Peter. Hopefully they will make it permanent so I don't have to update the file everything time I publish. Thanks again!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 30, 2018

Copy link to clipboard

Copied

If you edited the file I specified, you will not need to update every time you generate and publish. What file did you edit work on that is making you apply the edit each time?


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 30, 2018

Copy link to clipboard

Copied

Hi Peter, I edited the whthost.js file. I assumed that this would have to be edited every time the project is published as with other temporary fixes. If this is not the case, even better. I'm up and running now. Thanks again Peter!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 30, 2018

Copy link to clipboard

Copied

Yes but which one, the one I specified in the files in Program Files or the one that gets copied into the output?

Temporary fixes can often be applied to either, there's no hard and fast rule. Provided you edited the one in Post 68, it will not need editing again.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 30, 2018

Copy link to clipboard

Copied

Ok. I made the edits to the whthost.js file in this folder in Program files:

\RoboHTML\WebHelp5Ext\template_stock.

I published and then uploaded to the web. It's working fine now, but I haven't had to make any edits to the source files and republish again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 31, 2018

Copy link to clipboard

Copied

Next time you generate, it should work without any further editing.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
andreamw LATEST
New Here ,
Jan 31, 2018

Copy link to clipboard

Copied

Ok great. Thanks so much Peter!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...