Highlighted

Robohelp 2017 Predictive Search Does Not Work

Participant ,
Nov 06, 2018

Copy link to clipboard

Copied

We just upgraded from RoboHelp2015 to 2017. We opened our 2015 responsive HTML project in 2017. Is this all that needs to be done to "upgrade" the project? I was able to create the RHTML5 output, but the predictive search doesn't work. Is there a different way to "upgrade" the project other than opening the project file (after deleting the CPD file)? Is there a setting in RH that "turns on" the predictive search capability that we need to do? We are still using the Charcoal_Grey screen layout. I saw another team within our company that upgrade a similar project using the Charcoal Grey screen layout and their predictive search works in 2017 output.

Topics

HTML

Views

325

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Robohelp 2017 Predictive Search Does Not Work

Participant ,
Nov 06, 2018

Copy link to clipboard

Copied

We just upgraded from RoboHelp2015 to 2017. We opened our 2015 responsive HTML project in 2017. Is this all that needs to be done to "upgrade" the project? I was able to create the RHTML5 output, but the predictive search doesn't work. Is there a different way to "upgrade" the project other than opening the project file (after deleting the CPD file)? Is there a setting in RH that "turns on" the predictive search capability that we need to do? We are still using the Charcoal_Grey screen layout. I saw another team within our company that upgrade a similar project using the Charcoal Grey screen layout and their predictive search works in 2017 output.

Topics

HTML

Views

326

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Nov 06, 2018

Copy link to clipboard

Copied

Did you also apply the updates to 2017 before you upgraded?

Peter Grainge

www.grainge.org

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Nov 06, 2018

Copy link to clipboard

Copied

We have both 2017 updates applied before upgrading our project.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 06, 2018

Copy link to clipboard

Copied

Next try selecting the layout afresh from the Gallery button.

Peter Grainge

www.grainge.org

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Nov 06, 2018

Copy link to clipboard

Copied

I am assuming you are referring to the Gallery button when generating the Responsive HTML5. If so, my screen layout is listed in the Select drop-down list under the Manage Layout section, but is not listed in the Gallery. Even though I have various layouts in my project the only layouts listed in the Gallery are those I imported from Adobe (that is, charcoal_grey, indigo, and azure_blue). It seems like the gallery does not contain any of the layouts I created. I don't know why that would be. Just as an FYI we are using RoboHelp source control if that makes any difference.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 06, 2018

Copy link to clipboard

Copied

It's late here and I will explain the logic of my questions tomorrow. For now please just use one of the layouts you can see in the gallery to see if that fixes the problem you posted about.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 07, 2018

Copy link to clipboard

Copied

The logic. Update 2 fixed a problem with search not working. That's not the same thing and I believe there were problems also reported with predictive search not working. Not sure offhand if it was the same solution. To fix the "not working" issue it wasn't sufficient to just apply Update 2. You also have to take a fresh copy of whatever layout was in use, giving it a slightly different name because you can't use the name of an existing layout and you will want to keep the old one for reference if customisations have been applied. The new layout will not pick up your changes.

Thus you need to try a supplied layout to see if that fixes the problem. If it does, then at least you know the problem is with your layout.

I am reading your posts as saying you created your own layout. Was that entirely from scratch or by modifying a supplied layout? If the latter, then you will need to repeat the changes. If it was from scratch, then you will need to modify that but I can't help there.

There is another thread about adding home brewed layouts to the Gallery button. Re: RH 11 Imported Screen Layout Not Displaying in Gallery

Let us know if using a supplied layout without modifications fixes the issue.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Nov 07, 2018

Copy link to clipboard

Copied

I tried to generate the RHTML5 output using the Charcoal_Grey screen layout which is what I based my custom layout from. I still don't get predictive search in my output. I'm starting to wonder if we don't have the upgrades installed. If I go to "About RoboHelp" how can you tell if the upgrades have been applied? Our version says 13.0.2.334. I also wonder if I should delete the Charcoal_Grey layout and import it again into my project and see if that works. What do you think? I really appreciate all your help Peter.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Nov 07, 2018

Copy link to clipboard

Copied

One other thing I forgot to mention is I did install the Indigo layout and the predictive search worked. We just cannot update our screen layout to Indigo quite yet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 07, 2018

Copy link to clipboard

Copied

The fact that a new Indigo layout works is a good sign. Don't delete your existing layout at the moment.

You do have the updates installed but was the Charcoal Grey you used in the post numbered 7 selected from the gallery after the updates. If in doubt, just import again and call it CharcoalGrey2 or suchlike. Also it is an older layout so I am beginning to wonder if it includes predictive search.

If that doesn't work, try Azure Blue as well.

Based on your answers I will make run some tests and make enquiries.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Nov 07, 2018

Copy link to clipboard

Copied

Here is what I got so far. I tried the Azure Blue and did not get predictive search to work. I tried to import a new version of Charcoal_Grey2 (C_G2)  but in the Output setup pod there are no files under it like there are for the other layouts. I tried to go in a modify the layout C_G2 but it crashes my system. I tried to generate output using C_G2 and it crashes my system. I'm doing some additional testing but wanted to get this info to you for now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 07, 2018

Copy link to clipboard

Copied

I haven't heard that before. When you say "import" do you mean by using the

Gallery button.

Where is project located and are you generating to the same drive?

Peter Grainge

www.grainge.org

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Nov 07, 2018

Copy link to clipboard

Copied

I imported the .slz file from the adobe website (had to rename it from.zip). I didn't know whether the layouts on the adobe site were ever updated and wanted to get the latest files. That obviously didn't work. Now I'm choosing the C_G layout from the Gallery and calling it C_G2. Is this what you wanted me to do? If so I misunderstood. I just tried this and generated the output using the new C_G2 and the predictive search works. Now that I got C-G2 to work will I have to apply all my customization to this layout in order to have predictive searching? Are there any other options to make this work that you know of?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 07, 2018

Copy link to clipboard

Copied

Yes and yes.

The site is out of date and I have advised Adobe again.

Sorry but yes you have to apply your customisation again. That's why I said

to keep the original so that you can reference the settings.

Peter Grainge

www.grainge.org

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
lisabj4 LATEST
Participant ,
Nov 07, 2018

Copy link to clipboard

Copied

Applying all my settings now. I'm guessing others just upgraded to a new layout when they upgraded to RH2017 and didn't have this problem. I didn't find anything on the forum about it. I appreciate your help. All is well now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...