Highlighted

RoboHelp 2017 Responsive HTML5 Indigo layout (Favorites)

Explorer ,
Mar 20, 2017

Copy link to clipboard

Copied

Is anyone else encountering this regarding the Favorites feature in this layout?

  • 'Favorites' button name is not appearing in the output on the Homepage; only an empty button.
  • After a couple favorites have been tagged, the title 'Favorites' also does not appear in the Favorites menu.

Windows 10, IE11

Thanks

I think this problem has to do with the language file. On the front page of the Indigo Layout, do you see the welcome text? Or do you immediately get the search form?

In this case, can you try:

  1. Close RoboHelp.
  2. Backup the !Language! folder
  3. Remove the contents of the !Language! folder.
  4. Trash the CPD.
  5. Reopen RoboHelp and generate again.

When you do this, the language file gets recreated and you should now see the text show up. (Not on the button though, that's a different issue.)

IF this fails, you can also create a new project and copy the !Language! folder over to your existing project. That should also update the language resource.

TOPICS
HTML5 layout

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

RoboHelp 2017 Responsive HTML5 Indigo layout (Favorites)

Explorer ,
Mar 20, 2017

Copy link to clipboard

Copied

Is anyone else encountering this regarding the Favorites feature in this layout?

  • 'Favorites' button name is not appearing in the output on the Homepage; only an empty button.
  • After a couple favorites have been tagged, the title 'Favorites' also does not appear in the Favorites menu.

Windows 10, IE11

Thanks

I think this problem has to do with the language file. On the front page of the Indigo Layout, do you see the welcome text? Or do you immediately get the search form?

In this case, can you try:

  1. Close RoboHelp.
  2. Backup the !Language! folder
  3. Remove the contents of the !Language! folder.
  4. Trash the CPD.
  5. Reopen RoboHelp and generate again.

When you do this, the language file gets recreated and you should now see the text show up. (Not on the button though, that's a different issue.)

IF this fails, you can also create a new project and copy the !Language! folder over to your existing project. That should also update the language resource.

TOPICS
HTML5 layout

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 20, 2017 0
Adobe Community Professional ,
Mar 20, 2017

Copy link to clipboard

Copied

Does the same behaviour happen if you use one of the other layouts?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2017 0
Explorer ,
Mar 20, 2017

Copy link to clipboard

Copied

If I understand the new layouts correctly, the 'Favorites' feature is only in the new Indigo layout. Still learning...I could be wrong.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2017 0
Explorer ,
Mar 20, 2017

Copy link to clipboard

Copied

Here is something worth understanding from the HTML code. Why does it say aria-hidden for the favoritesLabel?:

<div class="header-nav">

  <div class="header-align">

   <div class="favorites sidebar-button" id="favorites-toggle-button-header"

     data-if="@KEY_SCREEN_DESKTOP">

    <a data-attr="aria-label: @KEY_LNG.favoritesLabel, aria-hidden: !@KEY_SCREEN_DESKTOP"

      href="javascript:rh.model.publish(rh.consts('SIDEBAR_STATE'), 'favorites');"

      tabindex="4">&#160;<span aria-hidden="true" data-html="@KEY_LNG.favoritesLabel"

             style="display: none;">&#160;</span></a>

    

   </div>

  </div>

</div>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2017 1
Adobe Community Professional ,
Mar 20, 2017

Copy link to clipboard

Copied

According to Google – the aria-hidden bit just hides it from screen-readers, not browsers

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2017 0
Explorer ,
Mar 20, 2017

Copy link to clipboard

Copied

Thanks for that Google research, Jeff! Any idea why the 'Favorites' labels aren't showing up in either of the places mentioned in the original thread?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2017 0
Adobe Community Professional ,
Mar 20, 2017

Copy link to clipboard

Copied

Sorry, nope - think you need to ping @Willam van Weeldon on that part. The fact that it appears & then disappears after using it a bit leads me to suspect some bug in the JavaScript coding.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2017 0
Explorer ,
Mar 20, 2017

Copy link to clipboard

Copied

Hi Willam van Weelden, Can you confirm that this issue is due to a JavaScript code bug as Jeff_Coatsworth suspects? (You helped me with a Favorites widget a year or so ago.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2017 0
Adobe Community Professional ,
Mar 20, 2017

Copy link to clipboard

Copied

I have already asked Willam to take a look but I do know he is very busy at

the moment.

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2017 0
LEGEND ,
Mar 21, 2017

Copy link to clipboard

Copied

The title of the Favorites button is indeed a problem in the JavaScript. Adobe is aware of this issues and I'm hoping they'll fix this in the upcoming patch. As a workaround, you could set the title of the button manually in the HTML code of the layout. Nothing much to be done otherwise at this point.

As for the second issue: What is the behaviour that you see? Does the title get obscured by links? How many favorites did you add for the problem to show?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 21, 2017 1
Explorer ,
Mar 21, 2017

Copy link to clipboard

Copied

Thanks Willam, for replying in the midst of an especially tight schedule!

Regarding the second issue: The issue occurs with two or three tagged favs or with none. The behavior is that the Favorites title itself does not appear--it's as if the color of the Favorites heading is the same as the background. Individual titles of favorite topics appear as you would expect (see below).

adobe Indigo bug.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 21, 2017 0
LEGEND ,
Mar 22, 2017

Copy link to clipboard

Copied

I think this problem has to do with the language file. On the front page of the Indigo Layout, do you see the welcome text? Or do you immediately get the search form?

In this case, can you try:

  1. Close RoboHelp.
  2. Backup the !Language! folder
  3. Remove the contents of the !Language! folder.
  4. Trash the CPD.
  5. Reopen RoboHelp and generate again.

When you do this, the language file gets recreated and you should now see the text show up. (Not on the button though, that's a different issue.)

IF this fails, you can also create a new project and copy the !Language! folder over to your existing project. That should also update the language resource.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2017 0
Explorer ,
Mar 22, 2017

Copy link to clipboard

Copied

THANK YOU WvanW!!!

The steps you outlined did the trick to resolve issue #2. And your confirmation in your Mar 21 comment identifies issue #1 as a bug, which is reported to Adobe.

I have a few other issues with this new layout, but will log them separately after I have an orderly list.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2017 0
New Here ,
Mar 07, 2018

Copy link to clipboard

Copied

Hi William,

When you say" you could set the title of the button manually in the HTML code of the layout," do you mean the layout's Javascript file? If so, what exactly would you modify?

Any specific guidance that you can offer would be greatly appreciated!

Best,

Christina

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2018 1
LEGEND ,
Mar 12, 2018

Copy link to clipboard

Copied

Hi Christina,

You should not have to modify the HTML.

But if you want to, there are two .SLP files. If you open them with Notepad++ or another text editor, you can find the menu and manually add text. But I believe this is fixed if you remove the language files and let RoboHelp restore them.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 12, 2018 0
Community Beginner ,
Apr 04, 2018

Copy link to clipboard

Copied

I am using a trial of RH 2017 and experiencing the same Favorites issues noted in this thread. I want to try the answer noted in William's post (11 in this thread), but I don't understand what the 'CPD' is in Step 4. What is the 'CPD'?

  1. Close RoboHelp.
  2. Backup the !Language! folder
  3. Remove the contents of the !Language! folder.
  4. Trash the CPD.
  5. Reopen RoboHelp and generate again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 04, 2018 0
Adobe Community Professional ,
Apr 04, 2018

Copy link to clipboard

Copied

It refers to the your_project_name.cpd file in the project folder. It's safe to delete it because RH recreates it again if it's missing when you load the project.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 04, 2018 1
Community Beginner ,
Apr 04, 2018

Copy link to clipboard

Copied

Thanks Jeff. I tried out the solution and the results look good. It also fixed something I hadn't realized was missing. On the main/home page of help, there's now a 'Welcome to our Help Center' header and 'What can we help you with today?' sub-header above the Search field. That text wasn't showing up in output that I had generated before trying out the fix noted in this thread. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 04, 2018 0
Adobe Community Professional ,
Apr 05, 2018

Copy link to clipboard

Copied

@Farrelly You said you are using the trial version. Many people think they will have downloaded the latest version with updates applied. It doesn't work that way so to File > Help and check you have 13.0.2.334. If not, apply the Updates.

Delete any layouts you have already tried and reselect them from the Gallery when you generate the responsive layout. You can leave the old ones if you have some reason. Just select the layout again and give it a slightly different name.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 05, 2018 1
Viky_T LATEST
Explorer ,
Jul 03, 2018

Copy link to clipboard

Copied

I just figured out how to resolve this one.

  1. Open the Project Settings.
  2. Click Advanced Language button.
  3. Select the Labels tab.
  4. Click Reset to Default.
  5. Scroll down to the [ResponsiveHelp] section. There is now a FavoriteBox Title=Favorites field.

This is where you can name it to what every you want. Hope this helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 03, 2018 0