Highlighted

Robohelp 2017 - Webhelp - Calling topic with URL not working in IE 11

New Here ,
Aug 10, 2018

Copy link to clipboard

Copied

Converting projects from Robohelp 10 to 2017. Discovered using this type of URL eg: X:/helpfolder/startpage.htm#path/target_topic_1.htm (reference to this info http://www.grainge.org/pages/authoring/calling_webhelp/using_urls.htm )  does not work properly in IE 11 but does in Google Chrome.

In IE 11, the full topic page displays with the Show link - but without the TOC/Search panes.  The Show link returns the default home page along with the TOC/Search pane - not the topic page.

Any help out there would be appreciated.

Topics

WebHelp

Views

286

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Robohelp 2017 - Webhelp - Calling topic with URL not working in IE 11

New Here ,
Aug 10, 2018

Copy link to clipboard

Copied

Converting projects from Robohelp 10 to 2017. Discovered using this type of URL eg: X:/helpfolder/startpage.htm#path/target_topic_1.htm (reference to this info http://www.grainge.org/pages/authoring/calling_webhelp/using_urls.htm )  does not work properly in IE 11 but does in Google Chrome.

In IE 11, the full topic page displays with the Show link - but without the TOC/Search panes.  The Show link returns the default home page along with the TOC/Search pane - not the topic page.

Any help out there would be appreciated.

Topics

WebHelp

Views

287

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 10, 2018

Copy link to clipboard

Copied

You've applied all the RH2017 patches and regenerated?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 10, 2018

Copy link to clipboard

Copied

Yes, I have applied all the updates and regenerated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 10, 2018

Copy link to clipboard

Copied

Sounds like something flakey in IE - does it make any difference when the output is on a web server vs local machine/LAN server? Is JavaScript enabled?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 10, 2018

Copy link to clipboard

Copied

No difference local vs web server and yes JavaScript is enabled.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 10, 2018

Copy link to clipboard

Copied

I'd suggest contacting Adobe Support - IE may have tightened up their security settings again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 10, 2018

Copy link to clipboard

Copied

Thanks, I will contact Adobe - thought I would find a quick answer on the forum Thanks for your quick responses!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 12, 2018

Copy link to clipboard

Copied

I would be interested to learn what Adobe told you.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 20, 2018

Copy link to clipboard

Copied

I will let you know. Just back from vacation today and will contact Adobe about this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 20, 2018

Copy link to clipboard

Copied

Holidays as well, nice job.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 20, 2018

Copy link to clipboard

Copied

This resolved the issue: RoboHelp output issues | IE 11

Thanks you Adobe Support!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 20, 2018

Copy link to clipboard

Copied

Egh? That fix is for RoboHelp 10 and you indicated you had upgraded to 2017.

Peter Grainge

www.grainge.org

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 20, 2018

Copy link to clipboard

Copied

It worked after I copied over the .js files. Although, now that I think about this, maybe something changed in our corporate environment over the past week...they sneak in changes! I will check with our folks here to see what I can find out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 21, 2018

Copy link to clipboard

Copied

Hi Peter, I was able to test and determined that replacing the .js files did resolve the issue (RoboHelp 2017).  I opened previous webhelp output that was generated prior to the .js fix, in IE 11, and the problem still exists.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 22, 2018

Copy link to clipboard

Copied

Are you doing this in the output or the source? I would not be happy replacing source files in a version other than the one intended.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 24, 2018

Copy link to clipboard

Copied

The .js files were replaced in the install files: <RHnstallFolder>\RoboHTML\WebHelp5Ext\template_stock> here

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 24, 2018

Copy link to clipboard

Copied

In that case, if you see other problems, do keep in mind that from what I understand you are not using the versions of those files intended for your new version of RoboHelp.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...