RoboHelp 2019 Not allowing upgraded project topics to be updated.

Participant ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

I just "Upgraded Project RoboHelp Classic project" 

I went to the first topic I needed to update and the some of the bulleted items have an extra bullet.

 

Extra bullet.jpg

I removed the extra bullet but it removed them all. Now when I try to reinsert the bullets and tab to place the words where I want them, the tab key does not work. I tried using Properties/Alignment/Increase Indent but that does nothing. I went to the bottom of the topic to see if the tab key or Increase/Decrease Incdent works, but nothing happens. 

 

No Indent.jpg

I am afraid to do anything else for fear of really messing up the guide I am working on. I've never experience issues when upgrading a project to a new version in the past. 

I really hope I don't have to recreate this project from scratch as it very large. 

Thank you.

Views

152

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

This is 2019 New UI, not 2019 Classic, correct?

 

First of all it is a CSS3 / HMTL5 issue so you will not be having to recreate the project.

 

Create a zipped copy of your project now so that anything that goes wrong is not catastrophic.

 

Open a topic that has a list and look in two places.

  1. In Properties > Styles select All and then click in a list. See what style is highlighted on the right. That should be what needs fixing.
  2. Also select a whole list item and then switch to source view. Copy what you find there and paste it into a reply here.

 

That should let us get some idea of what is going on. 

 

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

Hi Peter.

Yes, this is version 2019 New UI. 

This is my finding. 

I am seeing the bulleting issue throughout my project, not just one one topic.

Some of the lists are set as None, while others are set as p (paragraph). 

 

Here is the first one that is set to None along with source code:

 

Paragraph None.jpgParagraph None Source Code.jpg

 

Here is a sample of a list that is set to paragraph:

 

Paragraph Paragraph.jpgParagraph Paragraph Source Code.jpg

I also zipped a copy of the project. 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

I think I see the problem and will give some suggestions in the morning. Late here.

 

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

Thank you so much. 

Not sure where you are but I'm in Ohio. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

UK. 

 

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

I cringed as soon as I saw MsoNormal as that comes with content imported or pasted in from Word.

 

Go to a topic that has the double bullet problem and select the list. In the General tab of the Properties you will see an icon for Clear Formatting. Try that.

 

Also look in the CSS for a class MsoNormal and delete it. It's not really the right way of fixing things as it will leave the code in the topics but right now we are just looking for causes and this is a copy of the project.

 

If that doesn't work, then create a new project and import the CSS files in it and a few of the rogue topics. See the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

 

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

Peter,

I cleared the formatting. I'm not sure what I should have seen, the the extra bullet did not go away. I went in the source code and I don't see the MSONormal for the bulleting I'm trying to change.

 

I don't know what to look at in the CSS. Maybe you're talking about something other than what I'm thinking.

 

I did create a new project to send you. I've never imported before. I tried it but I'm not sure what you mean by importing the CSS files. Here is what I see when I try to import:

Initiate Import

Begin Import.jpg

I navigate to the files:

Navigate to files.jpg

I open the folders and there is nothing in them. 

Can you give me more information on what I should be doing? 

Thank you,

Michele

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

If it's easier you can send the whole project but make sure you give me the names of a few topics with the problem. 

 

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

I cleared the formatting. I'm not sure what I should have seen, the the extra bullet did not go away. I went in the source code and I don't see the MSONormal for the bulleting I'm trying to change.

In the first screenshots there is some content showing MSONormal. You need to locate that paragraph and then in author view click in the same paragraph and then click Clear Formatting. It may do nothing but I'm hoping it will help.

 

I don't know what to look at in the CSS. Maybe you're talking about something other than what I'm thinking.

Go to Assets > CSS in RoboHelp and open the CSS used in the topic. You should find something like p.MSONormal.

 

I did create a new project to send you. I've never imported before. I tried it but I'm not sure what you mean by importing the CSS files. Here is what I see when I try to import:

The import dialog is defaulting to HTML files and you are trying.

 

****************************************

 

If my last post didn't make sense, it's because this one didn't get sent. Doh!

 

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 21, 2020 Sep 21, 2020

Copy link to clipboard

Copied

Hi Peter. 

I have not forgotten about you and this thread. My company requires my request to upload files to you to go through our Information Security Office. It is currently under review.

Michele

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 25, 2020 Sep 25, 2020

Copy link to clipboard

Copied

Hi Peter. 

You won't have to try to figure this one out. The Information Security Office in my corporation did not approve my uploading files on your site. Looks like I'll be recreating my project. Yeah, it's only 465 printed pages; 161 topics. 

 

I think the issue has to do with how HTML forward RoboHelp 2019 is. I've never had issues in the past when upgtrading a project. I assume the way I inserted images and did bulleting may have something to do with the bulleting issue I have. I expect this to continue in other projects that I upgrade. The one this thread is about is small in comparison to some others I have. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 25, 2020 Sep 25, 2020

Copy link to clipboard

Copied

There's quite of lot of cleaning up potentially so they really are creating a lot of work for you. The communication between us would not be direct to or from my site but via wetransfer.com. Maybe that will change their view?

 

Basically I am being asked to fix the car without being able to look under the hood/bonnet. 

 

What I can't see is how you are going to rebuild the projects in a way that fixes the problem. Importing a topic with a lot of issues ain't gonna fix them.

 

It's up to you how much you and your line manager want to discuss this with them but do they really think I would build a site such as mine on the offchance I might get the opportunity to get hold of one of your projects? 

 

If your rebuild does get the project working, that's great. If not you're going to need someone's help. 

 

Hey ho, the offer is there.

 

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 25, 2020 Sep 25, 2020

Copy link to clipboard

Copied

Unfortunately, the critical part is missing in the code screenshot (that is, the beginning of the list where the list starts):

 

StefanGentz-Adobe_0-1601051002192.jpeg

Without the full code snippets, it’s hard to debug.

But looking at the breadcrumbs:

StefanGentz-Adobe_1-1601051002198.png

 

My hunch is, that there is a construction like this:

 

<ul>
	<li> <!-- creates the outer bullet point -->
		<ul>
			<li> <!-- creates the second bullet point -->
				<p>Click Save ...</p>
			</li>
		</ul>
	</li>
</ul>

 The outer bullet point is probalby (again, just a hunch without seeing the full code), coming from an empty list item that contains anouther unsorted list (ul).

But it might also be a CSS issue.

What ever it might be, as Peter already said, it's just HTML5 and CSS3 and therefore pretty much everything can get fixed without (re)creating the whole project 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 25, 2020 Sep 25, 2020

Copy link to clipboard

Copied

LATEST

The problem here is that it is the code in your topics that is giving RoboHelp a problem upgrading. Because your security people will not let us see that code we simply cannot help.

 

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation