Highlighted

Robohelp 2019 "classic" conditional build expression not sticking for printed output

Community Beginner ,
Aug 03, 2020

Copy link to clipboard

Copied

Hi,

Until recently I havne't had an issue, but when using 2019 (classic edition), I have found that all of a sudden the conditional build expression is not sticking in the Printed Documentation output.

 

I can create conditional build expressions, and they remain in the drop down list, but once I generate the output and go back into it the conditional build expression is no longer selected, and worse-- the output isn't retaining that information at all. So if I reopen the output, and generate, there are no conditional build expressions applied and the output shows everything. 

 

We have a lot of country specific tags that would turn the help into gibberish if this isn't working.

 

  • I'm on Windows 10, Office 365, generating PDF and Word (not that that appears to matter).
  • Responsive HTML help is not affected.
  • I've created brand new projects, and the issue remains.
  • This affects multiple projects
  • This only appears to have become an issue in the last few weeks.
  • My collegue also had this issue, but before we could investigate he "left" 

 

Thankfully most of the help is now online, with just release notes affected. 

 

I'm assuming this is some kind of environmental change, as I don't think RH 2019 has done an update for a while. A Windows update? Office 365 update??

 

If anyone has a simple fix, I'd be glad to hear it, I'm going to download 2020 in the faint hope that it isn't as buggy or awful as 2019-- each time I've tried to use 2019 I've come across a project-breaking issue that forces me back to the classic version. I don't have time to deal with the issues that RH has created with this new version.

 

Nicola

Topics

Classic, Output presets

Views

71

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Robohelp 2019 "classic" conditional build expression not sticking for printed output

Community Beginner ,
Aug 03, 2020

Copy link to clipboard

Copied

Hi,

Until recently I havne't had an issue, but when using 2019 (classic edition), I have found that all of a sudden the conditional build expression is not sticking in the Printed Documentation output.

 

I can create conditional build expressions, and they remain in the drop down list, but once I generate the output and go back into it the conditional build expression is no longer selected, and worse-- the output isn't retaining that information at all. So if I reopen the output, and generate, there are no conditional build expressions applied and the output shows everything. 

 

We have a lot of country specific tags that would turn the help into gibberish if this isn't working.

 

  • I'm on Windows 10, Office 365, generating PDF and Word (not that that appears to matter).
  • Responsive HTML help is not affected.
  • I've created brand new projects, and the issue remains.
  • This affects multiple projects
  • This only appears to have become an issue in the last few weeks.
  • My collegue also had this issue, but before we could investigate he "left" 

 

Thankfully most of the help is now online, with just release notes affected. 

 

I'm assuming this is some kind of environmental change, as I don't think RH 2019 has done an update for a while. A Windows update? Office 365 update??

 

If anyone has a simple fix, I'd be glad to hear it, I'm going to download 2020 in the faint hope that it isn't as buggy or awful as 2019-- each time I've tried to use 2019 I've come across a project-breaking issue that forces me back to the classic version. I don't have time to deal with the issues that RH has created with this new version.

 

Nicola

Topics

Classic, Output presets

Views

72

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 03, 2020

Copy link to clipboard

Copied

Hi Nicola

 

I hope that other than this, all is well with you.

 

I just tested and got the same result. What is the version number? If it is 2019.0.14 I am wondering if uninstalling and then installing Update 12 would fix it? That might explain why you have only seen this recently?

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 03, 2020

Copy link to clipboard

Copied

Hi Peter,

I'm actully on version 12, I didn't even know there was another version, and I thought I'd looked recently.

How do you remove updates? And specific updates at that? 

Or do you mean to remove the whole thing then reinstall and apply updates?

Or should I try v14?

Right now, I'm happy to try both in case it works!

Thanks,

 

Nicola

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 03, 2020

Copy link to clipboard

Copied

Nicola

 

Please email me via my site.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 03, 2020

Copy link to clipboard

Copied

You can go back to any version from this page. https://www.adobe.com/support/robohelp/downloads.html

 

I'm on Update 14 so that is not going to help you.

 

I am wary of suggesting any particular update as most didn't have Classic changes. Update 1 did for sure.

 

My other concern is about going backwards anyway. Try Update 1 but do make sure you have a zipped copy of the project before you start. 

 

I am trying to find out more but that may take a while.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 03, 2020

Copy link to clipboard

Copied

Thanks, I'll give it a go, and try 2020 as well.

Although I'm assuing there is no classic in 202, so that would be the new version. 

Joy.

 

Nicola

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 03, 2020

Copy link to clipboard

Copied

Just for clarity, I installed update14 and the issue isn't fixed. I didn't think it would be, but I figured it was worth a go, and it could do it while I downloaded the rest.

 

Now to install 2020 and the 2019 update prior to update 12!

Nicola

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 03, 2020

Copy link to clipboard

Copied

Hi,

I downgraded 2019 classic to update 11, and the issue is still happening.

I will try 2020 next.

Nicola

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...