RoboHelp 2019: WebHelp output hangs on "Indexing references"

New Here ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

This post also relates to:
RoboHelp 2019 New UI: WebHelp output hangs on "Indexing references" 

RH 2019 (Full) - Upgraded RoboHelp Project Fails to Generate - Indexing References 


I start a new thread here bacause I do not think I have problems with any TOC or Map Images
I have tested output with a very small amount of TOC (also hanging output)
and all images used in the project are png-files.

 

And I also found that our complete project outputs works fine in version 2019.0.11 but if you upgrade to 2019.0.14 it will hang as it describes in the other posts. So it seems to have with changes in robohelp between these versions? What are the changes between these versions?


In 2019.0.14 it seems to have to do with the amount of topics or with the cache in some way?  I have tested to start a new project and import topics and folders and it works fine up to a certain number.  It might be a some problems with some of the topics (but I doubts it) I can not find out what if so.


Is it a bug in 2019.0.14 that cause this? Or what is the problem with our project?

I have ziped our project and put it on this url for downloading:
http://www.listen2music.se/uploads/filer/PengVinHelp_rh2019.zip 
(560 MB)

Kind Regards

Kristoffer Kajler-Wård

Views

175

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , May 11, 2021 May 11, 2021
First of all the problem in 2019 is not content related. I removed all content from the topics in New TOC and just added a single word. It still failed to generate. I then upgraded the project to 2020 and there it generates without any problem. If you have a subscription licence, the upgrade is free. Beyond that I don't know why you are having this issue. If 2020 is not an option, then I think you will have to try Support. See https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp...

Likes

Translate

Translate
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

You didn't find any issue when you used Peter's technique of adding topics to the TOC a little bit at a time & testing the compile process each time more was added?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

No I din not. The output process hangs regardless on how many topics I have in the TOC

I have tried a small amout (1-3) and bigger amunt (20-30) always hanging on Indexing references.


As I said the same project always works to compile in 2019.0.11 without any changes in TOC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

I think you're going to have to add topics one by one and test each time to find the offending topic.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

The list of fixes can be found at Issues fixed in Adobe RoboHelp (2019 release)

 

I will have a quick look at your project but I can't do more because of other commitments.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

First of all the problem in 2019 is not content related. I removed all content from the topics in New TOC and just added a single word. It still failed to generate.

 

I then upgraded the project to 2020 and there it generates without any problem. If you have a subscription licence, the upgrade is free.

 

Beyond that I don't know why you are having this issue. If 2020 is not an option, then I think you will have to try Support. See https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp for your support contact options.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

 

 

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

LATEST

Thanks for your fast response!

 

We have actually recently purchased a subscription license.
So we have now upgrade robohelp to 2020
And it seems to work fine!


Kind Regards
Kristoffer Kajler-Wård

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation