Highlighted

Robohelp 7 WebHelp navigation pane blank

Community Beginner ,
Oct 25, 2016

Copy link to clipboard

Copied

I am using RoboHelp 7 (for Word), producing WinHelp output.

In many situations, the Navigation Pane appears blank in the browser.

Here are a few situations:

Internet Explorer 11:

  - Open file on local c drive with URL

       file://localhost/B:/MoT/CIS/Doc/Help/RoboHelpProject/!SSL!/WebHelp/helpfile.htm

     - I get message:

       "Internet Explorer restricted this webpage from runing scripts or ActiveX controls"

       but the navigation pane appears and works fine.

      

     - If I click the "Allow blocked content" button, the navigation pane goes blank!

    

  - Open a web url http:// ...

     - the navigation pane is blank. 

     - adding the site to the "Trusted Sites" does not help.

    

If I open the web url in Chrome or Opera, I get the blank navigation pane.

If I open the web url in Firefox, the navigation pane works fine!

I guess this might be due to security enhancements added to browsers in recent years, because when I initially delivered this help system this was not a problem.

Can anyone suggest how to adjust the help file or the browser settings to fix it?

Topics

RH for Word

Views

643

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Robohelp 7 WebHelp navigation pane blank

Community Beginner ,
Oct 25, 2016

Copy link to clipboard

Copied

I am using RoboHelp 7 (for Word), producing WinHelp output.

In many situations, the Navigation Pane appears blank in the browser.

Here are a few situations:

Internet Explorer 11:

  - Open file on local c drive with URL

       file://localhost/B:/MoT/CIS/Doc/Help/RoboHelpProject/!SSL!/WebHelp/helpfile.htm

     - I get message:

       "Internet Explorer restricted this webpage from runing scripts or ActiveX controls"

       but the navigation pane appears and works fine.

      

     - If I click the "Allow blocked content" button, the navigation pane goes blank!

    

  - Open a web url http:// ...

     - the navigation pane is blank. 

     - adding the site to the "Trusted Sites" does not help.

    

If I open the web url in Chrome or Opera, I get the blank navigation pane.

If I open the web url in Firefox, the navigation pane works fine!

I guess this might be due to security enhancements added to browsers in recent years, because when I initially delivered this help system this was not a problem.

Can anyone suggest how to adjust the help file or the browser settings to fix it?

Topics

RH for Word

Views

644

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Oct 26, 2016

Copy link to clipboard

Copied

Hi there

You really aren't going to want to hear this, but it has to be said anyway. Your only real option is to upgrade RoboHelp. The main drivers that force upgrades are (or were) changes in browsers and changes in Microsoft Word versions. Your RoboHelp version is quite long in the tooth. Since that version there was RoboHelp 8, 9, 10, 11 and now (2015 Release).

Another "shocking" aspect for you will also be that RoboHelp for Word is no more. There is only RoboHelp HTML.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
mnicoll LATEST
Community Beginner ,
Oct 26, 2016

Copy link to clipboard

Copied

Thanks Rick.  Shocking indeed!  Actually I'm not too surprised.

I'll have to contemplate a RoboHelp upgrade some time soon.

Does it have tools to help migrating the MS-Word source files to HTML?

I created a CHM file from RoboHelp 7 (instead of WebHelp). 

The CHM navigation pane works for Index and Contents, but not for Search!

For the short term, if anyone knows how to tweak web browsers so that the RoboHelp 7 WebHelp navigation pane works, I'd be delighted.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...