Highlighted

RoboHelp HTML5 output not working on current iPhones, iPads, Macs

Community Beginner ,
Oct 21, 2016

Copy link to clipboard

Copied

I recently noticed that my HTML5 output wasn't working on iPhone, iPad, and macOS Safari.

First I thought something was wrong with my own scripts, but after some digging, I found that it's a bug in the native RH JS files.

That means that none of your HTML5 RoboHelp projects will work properly on current iPhones, iPads, and Macs (= devices running iOS 10 or macOS Sierra).

This is a major bug that should be addressed as soon as possible. The bug has already been filed by Alexandra Duffy one month ago, but it is still "Unverified": Bug#4192629 - Safari 10 update has caused HTML5 Help from RH to stop working​.

Luckily enough, Edward Doris has already posted a bugfix in the above bug report. It seems to solve the problem on all devices. However, implementing the bugfix requires advanced JS knowledge.

Please provide an official bugfix as soon as possible.

TOPICS
HTML5 layout

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

RoboHelp HTML5 output not working on current iPhones, iPads, Macs

Community Beginner ,
Oct 21, 2016

Copy link to clipboard

Copied

I recently noticed that my HTML5 output wasn't working on iPhone, iPad, and macOS Safari.

First I thought something was wrong with my own scripts, but after some digging, I found that it's a bug in the native RH JS files.

That means that none of your HTML5 RoboHelp projects will work properly on current iPhones, iPads, and Macs (= devices running iOS 10 or macOS Sierra).

This is a major bug that should be addressed as soon as possible. The bug has already been filed by Alexandra Duffy one month ago, but it is still "Unverified": Bug#4192629 - Safari 10 update has caused HTML5 Help from RH to stop working​.

Luckily enough, Edward Doris has already posted a bugfix in the above bug report. It seems to solve the problem on all devices. However, implementing the bugfix requires advanced JS knowledge.

Please provide an official bugfix as soon as possible.

TOPICS
HTML5 layout

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 21, 2016 0
Adobe Community Professional ,
Oct 21, 2016

Copy link to clipboard

Copied

Use the Bugbase to log it as a bug yourself - that gets it on Adobe's official radar.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 21, 2016 0
LEGEND ,
Oct 21, 2016

Copy link to clipboard

Copied

I think what Jeff may be hinting at here is that if you add another report of the bug you noted, it will aid in stressing to Adobe that it's a higher priority bug than one that may simply be some cosmetic issue or other issue that doesn't manifest often or easily.

And in the event you are unaware of how to file such a bug, you click the link below and complete the form:

Click here

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 21, 2016 0
Community Beginner ,
Oct 21, 2016

Copy link to clipboard

Copied

It's already logged there. I think it's better to use the "vote" feature on the existing bug report than to create duplicate entries.

I only posted this here to let the community know, as it affects all HTML5 projects. Might save you time – I spent several hours in search for a solution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 21, 2016 1
LEGEND ,
Oct 21, 2016

Copy link to clipboard

Copied

Out of curiosity, when you say ALL HTML5 projects (assuming you meant outputs here) are you meaning both the Responsive HTML 5 as well as the Multiscreen HTML 5?

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 21, 2016 0
Community Beginner ,
Oct 23, 2016

Copy link to clipboard

Copied

Yes, I meant outputs. To me, the whole thing is a project, but you're right, we should stick to RoboHelp terminology 🙂

I didn't test Multiscreen HTML5. But I think it's very likely that Multiscreen is broken as well. If you want to know for sure, it's very easy to find out – simply create a dummy project, upload it to a server, open it on a Mac (running macOS Sierra) or an iPhone/iPad (running iOS 10) and check if the topic content is displayed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2016 0
Community Beginner ,
Oct 31, 2016

Copy link to clipboard

Copied

Bug is still "Unverified", so I guess it will not be fixed anytime soon.

I created a modified version of rh.min.js that you can use as a workaround. It includes the bugfix posted by Edward.

1. Download the file​​

2. Copy it to the \template\scripts subdirectory of your RoboHelp output directory (not the project directory).

Note that the file will be overwritten every time you re-generate your content.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2016 0
Contributor ,
Nov 01, 2016

Copy link to clipboard

Copied

I just had this reported to me about 2 hours ago.

When using Safari 10.0.1 to view a Resp. HTML 5 help system, the help opens but no content displays until you refresh the browser.

Yes, I added a vote to the bug reported by Alexandra Duffy that is cited above.

Paul

Update: I recompiled the project, then copied the updated .js file into a network directory, my co-worker tried it out and reported it didn't work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 01, 2016 0
New Here ,
Nov 02, 2016

Copy link to clipboard

Copied

Same here. Cannot get responsive HTML5 to work in Safari 10.0.1. I have tried Edward Doris' fix (in original post) but cannot find the code he is referring to. Has anyone found a fix for this until Adobe fixes it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2016 0
Adobe Employee ,
Nov 03, 2016

Copy link to clipboard

Copied

We are working on a fix with utmost priority. Patch will be available shortly.

Thanks!

Abhishek

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2016 1
Adobe Employee ,
Nov 04, 2016

Copy link to clipboard

Copied

This issue is fixed now.

The update is available through Adobe Update Manager (AUM): Please check for the updates in RoboHelp’s menu > File > Updates.

Thanks!

Abhishek

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2016 0
Contributor ,
Nov 04, 2016

Copy link to clipboard

Copied

I don't have a File > Updates option. Can you provide a direct link?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2016 0
Adobe Community Professional ,
Nov 04, 2016

Copy link to clipboard

Copied

Try Help > Updates

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2016 0
Contributor ,
Nov 04, 2016

Copy link to clipboard

Copied

Per Help > About RoboHelp, I'm on version 12.0.4.454. When I ran the Updates option, it said I was up-to-date, but I've not been prompted to go through any installation this AM.

Update: I just looked here: Search Results for “RoboHelp (2015 Release)” – TechComm Central by Adobe  and it's not listed yet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2016 0
Adobe Community Professional ,
Nov 04, 2016

Copy link to clipboard

Copied

Looks like they rolled back the 2015.0.4 patch - I suspect they're trying to reformulate the .0.4 patch to include this fix before they repost it again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2016 0
Adobe Employee ,
Nov 04, 2016

Copy link to clipboard

Copied

Hi,

The fix for this issue is now available in the latest update. Please download and install the latest update.

Thanks!

Abhishek

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2016 0
Contributor ,
Nov 04, 2016

Copy link to clipboard

Copied

I went to lunch, came back, and using Help > Updates doesn't trigger the automatic update. I checked this page - Search Results for “RoboHelp (2015 Release)” – TechComm Central by Adobe  - and didn't see it - is that not where I should be looking?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2016 0
Adobe Community Professional ,
Nov 04, 2016

Copy link to clipboard

Copied

Nope - you want Adobe - Support : RoboHelp Support Center : Service Releases but 2015.0.4 release isn't back up

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2016 0
Adobe Community Professional ,
Nov 04, 2016

Copy link to clipboard

Copied

Try File > Help > Updates - that seems to be the RH2015 spot within the software.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2016 0
Contributor ,
Nov 04, 2016

Copy link to clipboard

Copied

This is frustrating me.

From here - RoboHelp (2015 Release) Update 4 released – TechComm Central by Adobe - which is where I ended up when I searched for "Robohelp 2015" - there is information about 2015.0.4. Within that page, there is a link to Adobe - Support : RoboHelp Support Center : Service Releases​ - which is the page Jeff linked to above but, like Jeff said, 2015.0.4 isn't listed.

I wouldn't be as frustrated if there were two posts by Adobe Support in this thread saying that the update is available when, clearly from central Iowa, the update is not available... Sigh.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2016 0
Adobe Community Professional ,
Nov 04, 2016

Copy link to clipboard

Copied

Post #9 over on this thread - Filter icon is displayed without using filters  - seems to imply that the updater is working today; but I have seen posts in the forums complaining about disabled Updaters due to corporate firewalls (which is why I maintain a bookmark to the downloads page).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2016 0
Contributor ,
Nov 04, 2016

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2016 0
Adobe Employee ,
Nov 04, 2016

Copy link to clipboard

Copied

Hi,

Apologies for the inconvenience caused.

The update is available through Update manager for now. Website update usually takes time. Since this issue was critical and an immediate fix was required, we communicated it's availability through update manager. Please go to FIle > Help > Updates.

Please let us know in case you see issues.

Thanks!

Abhishek

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 04, 2016 0
Contributor ,
Nov 07, 2016

Copy link to clipboard

Copied

Is this the updated version?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2016 0
Adobe Community Professional ,
Nov 07, 2016

Copy link to clipboard

Copied

Not sure if 12.0.4.454 sets the newest one - that level was reported by Adobe TCS as being for the 12.0.4 patch & I'm not sure if the release level changed with this new 12.0.4.1 fix.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2016 0
New Here ,
Nov 07, 2016

Copy link to clipboard

Copied

The last version I have is: 12.0.4.460 ​So it seems you have an older build.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2016 0
LEGEND ,
Nov 07, 2016

Copy link to clipboard

Copied

Mine seems to be showing this:

tmp2.png

So it would appear you need to update.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2016 0
LEGEND ,
Nov 07, 2016

Copy link to clipboard

Copied

Oops.. Didn't see you pop in there!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2016 0
LEGEND ,
Nov 07, 2016

Copy link to clipboard

Copied

LOL. Better two answers than none, right? 😉

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2016 0
Contributor ,
Nov 07, 2016

Copy link to clipboard

Copied

Rats. When I went to Help > Updates, I see this:2016-11-07_9-43-30.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2016 0
Adobe Community Professional ,
Nov 07, 2016

Copy link to clipboard

Copied

Do you get anything happening if you go via Files > Help > Updates or is just the same screen (I can't tell since I haven't got RH2015 installed yet).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2016 0
Contributor ,
Nov 07, 2016

Copy link to clipboard

Copied

I see the same screen using that navigation path…

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2016 0
Adobe Community Professional ,
Nov 07, 2016

Copy link to clipboard

Copied

rats - any corporate IT things in place blocking you? Anti-virus, firewalls, etc.?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2016 0
Contributor ,
Nov 07, 2016

Copy link to clipboard

Copied

I just discussed this situation with the Security dude that sits near me. While we don't see anything that would visually tell us the update is being blocked, he is going to check the logs in a few minutes to be certain.

Is there another place where I can download the update? I just checked  Adobe - Support : RoboHelp Support Center : Service Releases  and it is still not showing the update. I'm not certain that is where I should be looking as that site has a lot of broken links:

2016-11-07_10-31-15.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2016 0
Community Beginner ,
Nov 08, 2016

Copy link to clipboard

Copied

Thank you, Abishek. Would be great if you could update the downloadable original JS files (js-files.zip) as well.

(It might be helpful to include a version number for that file, e.g. js-files-v2.zip, so users can easily check if the files have been updated.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2016 0
Community Beginner ,
Nov 08, 2016

Copy link to clipboard

Copied

Hi Rick,

I need this update to fix the iOS device problem, but I do not want to lose control over shutting off TOC, Index and Glossary panes. I had to roll back to Rel. 3 to remedy that problem.

( Bug#4196415 - Cannot turn off index, glossary, filter in RH 2015 rel 4 , Bug#4196414 - Unable to turn off icons , Bug#4196174 - Cant hide Glossary, Index, and Filter icons )

Is this also fixed in 12.0.4.460? I do not want to install the update only to find that I need to repeat the whole rollback process.

Thanks, Jeanne

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2016 0
Contributor ,
Nov 09, 2016

Copy link to clipboard

Copied

Just as a wrap-up to this (from my POV), I came in to work yesterday (Tuesday, 11/8) and checked File > Help > Updates and the update was available. I installed it, recompiled, reviewed each page, and then told the Dev who had reported the issue to me on 11/1, that I had recompiled the help and to view the help system on Safari 10.0.1. He reported back that it did not have the same issue so from my perspective, the update resolved the issue.

Have a good day.

Paul

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2016 0