Robohelp topics have been removed from version control

New Here ,
Jul 20, 2017 Jul 20, 2017

Copy link to clipboard

Copied

We are using RH 2017 version control with three users. This morning one of the users noticed that all the topics he has created have been removed from version control. The folders are still there but they are empty (except for a .css file) and it is the same for the project on our local machines (all three). Has anyone else experience this? What would cause the files to be deleted w/o any of us specifically deleting them? We are currently working with IT to retrieve the files from our daily backup and hopefully that will be successful, but knowing the cause would be extremely useful.

TOPICS
Source control

Views

246

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 20, 2017 Jul 20, 2017

Copy link to clipboard

Copied

Don't think that's a RH problem - sounds like an issue with your source control...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 20, 2017 Jul 20, 2017

Copy link to clipboard

Copied

Hmmm, seems odd that they would have been removed.

Knowing how version control works, the actual content is typically in the Source Control database on the server. And there are copies on the local PC. And the copies are generally manipulated by using the read only flag.

Have you tried using the "Get Latest Version"? I think that's what it's called. I may be remembering Microsoft Visual Source Safe. But I would think RoboSource Control would offer an identical feature but maybe named slightly different.

The Get Latest Version should copy things from the Server database to the local machine. Assuming, of course, that the topics haven't been actually deleted.

Cheers... Rick

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 08, 2017 Nov 08, 2017

Copy link to clipboard

Copied

Not only do I have the same problem, I am having problems where a project is pulled from the Robo Source Control server and opened fine.  Close, reboot the printer and reopen the same exact project and it says it has been removed from source control, do you want to discontinue looking for the project.  So far, it seems to be happening mostly with one project in particular but we are getting quite frustrated.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation