Highlighted

Search Anomalies

New Here ,
Apr 09, 2020

Copy link to clipboard

Copied

Hi Folks, 

Forgive me if this is brief in detail, but as is often the case, I have inherited a project I know very little about.  
My organization is in the process of moving a help system for an enterprise level proprietary computer system from RoboHelp Classic to RoboHelp 2019.
The content and structure of the help topics is virtually identical in both systems. However searching is producing markedly different results. 
In the old system (RoboHelp Classic), I can search for a help entry by title and it is the first item returned. When I perform the exact same search in RoboHelp 2019, the results are wildly different, and not at all helpful, and almost never contain the entry that I searched for. 

Can anyone point me in the right direction? Is this an indexing issue? Or are there search settings in RH 2019 that I need to tweak? Any assistance would be appreciated as I am stumbling around in the dark at the moment.
Thanks, 
Steve

Views

210

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Search Anomalies

New Here ,
Apr 09, 2020

Copy link to clipboard

Copied

Hi Folks, 

Forgive me if this is brief in detail, but as is often the case, I have inherited a project I know very little about.  
My organization is in the process of moving a help system for an enterprise level proprietary computer system from RoboHelp Classic to RoboHelp 2019.
The content and structure of the help topics is virtually identical in both systems. However searching is producing markedly different results. 
In the old system (RoboHelp Classic), I can search for a help entry by title and it is the first item returned. When I perform the exact same search in RoboHelp 2019, the results are wildly different, and not at all helpful, and almost never contain the entry that I searched for. 

Can anyone point me in the right direction? Is this an indexing issue? Or are there search settings in RH 2019 that I need to tweak? Any assistance would be appreciated as I am stumbling around in the dark at the moment.
Thanks, 
Steve

Views

211

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Apr 10, 2020

Copy link to clipboard

Copied

I assume you mean 2019 New UI.

 

I just tried the RoboHelp Reimagined sample project using the frameless Orange skin and the responsive Azure Blue skin. As soon as I typed "bit" the predictive search gave me Bits and Pieces and if I ignored that and just pressed Enter, I got the correct result.

 

When I first saw your post I was surprised as by now someone else would have reported this. Then it occurred to me I wonder if you are aware of the difference in how the output content is created.

 

  • In Classic you had to specifically exclude topics from a build.
  • In 2019 you have to specifically include topics.

 

Is it possible the topic you are searching for is not getting generated? Check in the output folder.

 

If it is not there, look in the RoboHelp Reimagined sample project where this is all explained. Basically you have to include everything in the TOC. For items you don't want the user to see in the TOC but do want in the build, you tick the Hide in Output check box.

 

Let us know if that is the answer. If not we'll dig deeper.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 10, 2020

Copy link to clipboard

Copied

Thanks for the reply Peter, I do not think this is the issue, I have been assured the topics are getting generated. 

Perhaps rather than trying to describe the problem with my limited understanding it would be easier to show it. Note the differing results in the links below when searching the string of text "Court-Ordered Obligations" (without the quotations)

This is the old system with the desired search functionality:

https://staging.pdp.albany.edu/RoboHelp/CCFS/CCFS_LR/newproject.htm

And this is the newer one where the searches are not returned as desired:

http://robohelp.pdp.albany.edu/CCFS-LR/index.htm#t=Overview_of_CCFS_CCFS2.htm  

Though in both cases the same help entry exists (You could navigate to it through the Table o Contents by following the path Home > Safety Assessments > Interviewer: Respond to a Safety Assessment > Enter Interview Results > Court-Ordered Obligations

Does this help clarify the problem?




Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Apr 10, 2020

Copy link to clipboard

Copied

I'll look in the morning but try this meantime. In one topic enter a term such as redzebra in the title of one topic and in the body of another. Generate and see what happens in the search.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Apr 10, 2020

Copy link to clipboard

Copied

I thought you were saying the topic was not returned. It is in the results I got albeit not the first topic, which, like you, I would expect.

 

image.png

 

Is the issue you not finding it or the priority? Do you have Update 12 applied?

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 13, 2020

Copy link to clipboard

Copied

Right, apologies if I was unclear.  We ideally want results that are returned in the same priority as the older version, as that is the search behavior users are familiar with/expecting, and we are not certain what is causing the difference search priority in the new version of RoboHelp.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...