Highlighted

Search does not display results.

New Here ,
Jan 20, 2016

Copy link to clipboard

Copied

Hi Folks,

I have successfully generated a .chm file but when I opened I found the search tab does not display results. Not sure if it's a defect or my own inexperience setting up the index links properly but if you could point me in the right direction it would be much appreciated.

William Hazen

Topics

HTML help

Views

666

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Search does not display results.

New Here ,
Jan 20, 2016

Copy link to clipboard

Copied

Hi Folks,

I have successfully generated a .chm file but when I opened I found the search tab does not display results. Not sure if it's a defect or my own inexperience setting up the index links properly but if you could point me in the right direction it would be much appreciated.

William Hazen

Topics

HTML help

Views

667

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Jan 21, 2016

Copy link to clipboard

Copied

If you try one of the sample products, does it work as expected in that situation?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 22, 2016

Copy link to clipboard

Copied

Yes it does....

This RoboHelp Project File is set up so badly I might just start over from scratch and rebuild it. The master page is mislabeled and there is a ton of broken links and I am not sure how to fix them. Is there a setting when running the Microsoft HTML Help- File Generation wizard for the *.CHM search tab that I might have missed?

V/R

William Hazen

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jan 22, 2016

Copy link to clipboard

Copied

There really aren't any options that you can enable or disable as far as Search goes. The only place I'm aware of that you can configure anything related to search for CHM file is in the Window settings. There you can turn it off or on and enable "Advanced Search". But nothing that really affects how well it may work.

tmp2.png

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 22, 2016

Copy link to clipboard

Copied

I will check that Rick. I overlooked those settings. I will let you know if that worked.

V/R

William Hazen

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 22, 2016

Copy link to clipboard

Copied

Forgive me in Advance Rick I can't see to find the "Window Properties" feature in RoboHelp 2015. Can you please point me to it?

Like I said. I am still a bit of a novice.

V/R

William Hazen

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jan 22, 2016

Copy link to clipboard

Copied

Click the Project tab, then the Pods drop down. Choose the Output Setup option.

tmp1.png

Then in the Output Setup pod, expand the Windows section.

tmp2.png

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 25, 2016

Copy link to clipboard

Copied

Thanks Rick,

I will have some feedback in about an hour or two.

V/R

William Hazen

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 26, 2016

Copy link to clipboard

Copied

Update:

I just trashed the Project File and decided to start over with a clean baseline... When I generate a new .CHM file and load it into the application, I will post the results.

V/R

William Hazen

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Feb 03, 2016

Copy link to clipboard

Copied

Update: After Generating a new .CHM file the Search feature does still does not work properly ( i.e. It does not list the results in the "display results" window but does highlight the search term(s) in the CHM document)

My two best guesses are:

1.This CHM is hosted inside a larger set of CHM files under the Help heading. Using CHM search in the larger Help file produces results across the entire spectrum EXCEPT for my file. SO I am thinking that maybe there is a missing .DLL?

2. I somehow have the index setup inside the CHM file to display results on the CHM page instead of in the display results window. Did I miss a setup index step somewhere?

(Note this CHM is based entirely on am imported Word 2010 (.docx) Document with no sub-HTML pages.

Let me know if you good folks need any further details and thanks again in advance.

V/R

William Hazen

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...