Search in Reponsive HTML5 does not always work

Enthusiast ,
Feb 23, 2018 Feb 23, 2018

Copy link to clipboard

Copied

RoboHelp 2017 (13.0.2.334) on Windows 10 64-bit
Responsive HTML5 layout.

The Search functionality in this layout doesn't always work. I tested it across three browsers locally and remotely, with our own project and with Travel the Whirls sample project. Here are my test results:

Firefox (58.0.2 64-bit)Internet Explorer (11.248.1699.0)
MS Edge (41.16299.248.0)
Chrome (64.0.3282.186)
Our Project (locally)GoodBad (no search)
GoodGood
Our Project (webserver)Bad (no search)Bad (no search)
GoodGood
Travel the Whirls (locally)GoodReally Bad (no contents*)
GoodGood
Travel the Whirls (webserver)GoodReally Bad (no contents*)GoodGood

* You only get the shell of the layout. Nothing loads if you're using just Index.htm in the URL. If you directly type a full pathway to a specific .htm topic, you do see contents.

We'd obviously like this to work across as many browsers as possible. Does anyone know the fix? I've seen that others have had similar issues.

Is all this related to this bug? The bug mentions some possibly updated .js content there that fixes it. How do I apply the fixes there to test?
https://tracker.adobe.com/#/view/RH-960

TOPICS
HTML

Views

388

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Feb 23, 2018 Feb 23, 2018
Perhaps it's linked. Adobe's own fix will be released soon but meantime it is in Using RoboHelp 2017 on my site Item 13.There's a download with instructions. Make sure you retain existing files in case you want to backout.

Likes

translate

Translate

Translate
Adobe Community Professional ,
Feb 23, 2018 Feb 23, 2018

Copy link to clipboard

Copied

Perhaps it's linked. Adobe's own fix will be released soon but meantime it

is in Using RoboHelp 2017 on my site Item 13.

There's a download with instructions. Make sure you retain existing files

in case you want to backout.

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 24, 2018 Feb 24, 2018

Copy link to clipboard

Copied

From another thread Re: Responsive HTML5 Layouts TOC Not Synching you will likely find that the TOC no longer syncs with the fix applied.

I have reported that and you might agree that is the lesser of two evils.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Feb 27, 2018 Feb 27, 2018

Copy link to clipboard

Copied

Thanks for the quick response Peter. I tried this today and it seems to have fixed this for us.
If anyone needs instructions on how to do this, see my related post here.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation