Search Results Not Displaying URL/Breadcrumbs for All Topics

Engaged ,
Nov 10, 2020

Copy link to clipboard

Copied

RH2020.1 

 

Output is Responsive HTML5 using Azure Blue skin. When I perform a search, the results panel displays the breadcrumbs/URL for some topics, but not all. It's odd. Thoughts?

Apparently resolved. In RH2020.1 no less.

 

I made the following changes to each preset in all 12 merged projects (1 parent, 11 children) - and yes, all 12 build presets used to generate the merged output were identical before this. Not sure which of these changes triggered the fix, but it was something:

 

  • General>Use lowercase file names: Removed checkmark; was previously selected.
  • Search>Use topic description as search context: Removed checkmark; was previously selected.
  • Search>Set search context character limit: Changed from 100 to 150.
  • Search>Number of results on a page: Changed from 20 to 10000 (merge consists of over 6.5k topics; audience can use included filters if they want).
  • Search>Generate XML sitemap: Removed checkmark.

 

Was any of those actually causing the issue? Or did changing and saving one of those settings just insert a setting that was missing or corrupt (perhaps introduced at some point while upgrading the projects from 2017 to 2019c to 2019n to 2020)? Who knows? However, all search results now include a breadcrumb/URL below the preview.

 

Note: The changes above also resolved an issue (much smaller scale, but present nonetheless) I had with search result preview text not respecting the configured character limit (e.g., set to 100 but had one topic display 1397 characters for its preview).

 

Appreciate the feedback from the community. 

Views

66

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Search Results Not Displaying URL/Breadcrumbs for All Topics

Engaged ,
Nov 10, 2020

Copy link to clipboard

Copied

RH2020.1 

 

Output is Responsive HTML5 using Azure Blue skin. When I perform a search, the results panel displays the breadcrumbs/URL for some topics, but not all. It's odd. Thoughts?

Apparently resolved. In RH2020.1 no less.

 

I made the following changes to each preset in all 12 merged projects (1 parent, 11 children) - and yes, all 12 build presets used to generate the merged output were identical before this. Not sure which of these changes triggered the fix, but it was something:

 

  • General>Use lowercase file names: Removed checkmark; was previously selected.
  • Search>Use topic description as search context: Removed checkmark; was previously selected.
  • Search>Set search context character limit: Changed from 100 to 150.
  • Search>Number of results on a page: Changed from 20 to 10000 (merge consists of over 6.5k topics; audience can use included filters if they want).
  • Search>Generate XML sitemap: Removed checkmark.

 

Was any of those actually causing the issue? Or did changing and saving one of those settings just insert a setting that was missing or corrupt (perhaps introduced at some point while upgrading the projects from 2017 to 2019c to 2019n to 2020)? Who knows? However, all search results now include a breadcrumb/URL below the preview.

 

Note: The changes above also resolved an issue (much smaller scale, but present nonetheless) I had with search result preview text not respecting the configured character limit (e.g., set to 100 but had one topic display 1397 characters for its preview).

 

Appreciate the feedback from the community. 

Views

67

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 10, 2020 0
Engaged ,
Nov 10, 2020

Copy link to clipboard

Copied

I am just fiddling with the same issue. It seems that breadcrumbs for search results are not displayed in 2020, if it is a "one-project" output. They seem to be displayed if it is a merged output.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 0
Adobe Community Professional ,
Nov 10, 2020

Copy link to clipboard

Copied

Have either of you tried Update 2? Don't if you also have PDFs linked to the TOC but otherwise see if that fixes it. Doubtful but needs to be tried.

 

I will run a test tomorrow.

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 0
Engaged ,
Nov 10, 2020

Copy link to clipboard

Copied

This project is part of a combined output. However, the issue is visible/occurs whether I run the child project output as "standalone" output or part of the overall "multi-project combined" output.

 

The project originated in RoboHelp 2017 (frankly, it originated long before that). It was upgraded to RH2019 classic, then to RH2019 new, and finally to RH2020. 

 

I read on here under another post how to turn off ALL search result URLs using CSS. I'm not ready for that. I'm also leery of update 2, because if I have to rollback, it won't be fun. Longer term, I hope to procure a test VM machine where I can install and test/approve future updates on project copies before deploying to the rest of our team. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 0
Adobe Community Professional ,
Nov 10, 2020

Copy link to clipboard

Copied

In 2020 you cannot generate a project as a child and then run it standalone. See Merged Help on my site. 

 

If you want to run a child standalone you must generate again to a different folder. 

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 0
Engaged ,
Nov 10, 2020

Copy link to clipboard

Copied

Apparently resolved. In RH2020.1 no less.

 

I made the following changes to each preset in all 12 merged projects (1 parent, 11 children) - and yes, all 12 build presets used to generate the merged output were identical before this. Not sure which of these changes triggered the fix, but it was something:

 

  • General>Use lowercase file names: Removed checkmark; was previously selected.
  • Search>Use topic description as search context: Removed checkmark; was previously selected.
  • Search>Set search context character limit: Changed from 100 to 150.
  • Search>Number of results on a page: Changed from 20 to 10000 (merge consists of over 6.5k topics; audience can use included filters if they want).
  • Search>Generate XML sitemap: Removed checkmark.

 

Was any of those actually causing the issue? Or did changing and saving one of those settings just insert a setting that was missing or corrupt (perhaps introduced at some point while upgrading the projects from 2017 to 2019c to 2019n to 2020)? Who knows? However, all search results now include a breadcrumb/URL below the preview.

 

Note: The changes above also resolved an issue (much smaller scale, but present nonetheless) I had with search result preview text not respecting the configured character limit (e.g., set to 100 but had one topic display 1397 characters for its preview).

 

Appreciate the feedback from the community. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 0