Snippets not included in Responsive help output Robohelp 2020

Community Beginner ,
Jan 26, 2021

Copy link to clipboard

Copied

Hi,

I've been converting a large set of projects that have three flavours to them.

Two of them have directly competing words, Outlay is used instead of Disbursment, and so on.

To correct this, Snippets were used in topics so that the titles would be correct. Variables were used to then change the text so that when you look at a Disbursment topic, you see the word Disbursment by using Conditional Text within the variables.

When I changed to 2020, it seems to have stopped working. 

This topic:

Image1.jpg

Becomes this in output:

Image2.png

There isn't even any formatting of a header and footer.

I had noticed that the variables had lost a lot of the conditional text when I imported them, but they seem to work ok in normal topics. Is this because of the combination of Snippet with Variables that themselves have conditional text? Or another bug?

 

It worked in Classic with no problems.

 

Thanks,

Nicola

TOPICS
New UI

Views

114

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 26, 2021

Copy link to clipboard

Copied

What version of 2020 are you running? Make sure you're running the 3rd patch.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 26, 2021

Copy link to clipboard

Copied

Sorry, forgot to say that. I am up-to-date and on patch 3.

Thanks,

Nicola

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 26, 2021

Copy link to clipboard

Copied

If you are up to date that looks more like the whole snippet has been tagged out, there's nothing there.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 26, 2021

Copy link to clipboard

Copied

Sorry Peter, "tagged out"???

I'm not sure what you mean. Too many tags????

Here's the source code:

Image1.png

It's compiled as Country_EWNI. The empty screen showed the output, by the way, not the source in RH.

 

Nicola

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 26, 2021

Copy link to clipboard

Copied

I mean you have applied an expression in your preset that is excluding the topic. Try generating without any expression applied.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 26, 2021

Copy link to clipboard

Copied

Didn't this sort of thing use to get handled in prior RH versions with a user-defined variable set instead of snippets? Like using "Product_name" - where depending on the CBT chosen, you got Product A or Product B, etc. in your output?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 26, 2021

Copy link to clipboard

Copied

It still gives the same result even having no Conditional Expression selected at all. 

And it's not the only topic, every single one that has been built in the same way isn't working.

 

Image1.png

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 26, 2021

Copy link to clipboard

Copied

It worked in RH Classic 2019. I've only just converted this huge set of projects to 2020, and found this out by accident.

The conditional text is inside variables, which are used inside snippets to give me the output I need. 

Because of the limitations with the TOC where conditional text doens't work, this was the only way to get the titles and contents to match without having duplicate topics (and the issues that come with that)

 

Nicola

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 26, 2021

Copy link to clipboard

Copied

If you create a new snippet with text only and no variables or tags, does that work?

 

TOC titles can include variables. That might be worth looking into later.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 26, 2021

Copy link to clipboard

Copied

"Variables were used to then change the text so that when you look at a Disbursment topic, you see the word Disbursment by using Conditional Text within the variables."

 

Create a variable in 2020 and there is no option to apply tags to the content. As Jeff has said Variable Sets seems to be what is required. You would create the variable with one value and then create Variable Sets to change that for each customer/scenario.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 26, 2021

Copy link to clipboard

Copied

Hey, make sure you have the correct version and you are using the correct batch the 3rd batch. Thanks

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 27, 2021

Copy link to clipboard

Copied

Thanks, looks like I have to remove the variable all together. I'll look into how they now work though!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 29, 2021

Copy link to clipboard

Copied

Hi,

I removed all of the variables that I thought was creating the issue with snippets not appearing in the output.

However, it seems that wasn't the issue. It seems that my snippets are not being added at all, even simple ones that contain just a link are being ignored, never mind huge, complex ones. 

Even brand new snippets dont work, nor does inserting old ones back in.

Suggestions?

Snippet...

Image1.png

No snippet...

Image2.png

Nicola

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 29, 2021

Copy link to clipboard

Copied

I'm still caught by company's non-disclosure from my time there. Want to share the project? See the Contact page on my site.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Feb 01, 2021

Copy link to clipboard

Copied

Thanks, files on their way!

Nicola

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Feb 01, 2021

Copy link to clipboard

Copied

I'm finding the same with a new topic and a new snippet. I am liaising with Adobe.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Feb 01, 2021

Copy link to clipboard

Copied

Fantastic! Thanks, hopefully they can get to the bottom of it. 

 

Nicola

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
HelpDragoncity AUTHOR LATEST
Community Beginner ,
Feb 04, 2021

Copy link to clipboard

Copied

Hi,

Thanks to Peter Grainge it seems the issue is with one rogue topic stopping all snippets from showing. Simply deleting it from the TOC didn't work for me, I had to fully delete the topic to stop it from blocking the snippets.

(RoboHelp 101-- when you have an issue, start deleting sections in the TOC to find the issue-- then delete the topics themselves!)

Why? Well, we don't know that yet 🙂 But deleting it has solved the issue, I'll recreate the topic anew without using the original code, and that should do the trick.

Once again, thanks Peter!

Nicola

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more