Highlighted

Styles not applying in Responsive HTML5 output (RH 2019)

New Here ,
Oct 01, 2019

Copy link to clipboard

Copied

I converted one of our large RH 2015 projects to RH 2019. Everything went smoothly up until I tried to generate the Responsive HTML5 output. For some odd reason, the styles aren't applying in the output. I checked the topics to ensure they're linking to the correct CSS file, and they are. Has anyone run into this issue before and resolved it?

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

Open the master page and remove the CSS that is linked to it.

You can leave it like that and the CSS linked to topics will then apply. That's useful if different topics have different CSS linked. Alternatively link the one you want so that if a topic somehow gets the wrong CSS, this will fix it.

 

Topics

HTML5 layout, New UI

Views

171

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Styles not applying in Responsive HTML5 output (RH 2019)

New Here ,
Oct 01, 2019

Copy link to clipboard

Copied

I converted one of our large RH 2015 projects to RH 2019. Everything went smoothly up until I tried to generate the Responsive HTML5 output. For some odd reason, the styles aren't applying in the output. I checked the topics to ensure they're linking to the correct CSS file, and they are. Has anyone run into this issue before and resolved it?

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

Open the master page and remove the CSS that is linked to it.

You can leave it like that and the CSS linked to topics will then apply. That's useful if different topics have different CSS linked. Alternatively link the one you want so that if a topic somehow gets the wrong CSS, this will fix it.

 

Topics

HTML5 layout, New UI

Views

172

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Oct 01, 2019

Copy link to clipboard

Copied

New UI or Classic? All up to date with patch 9?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 02, 2019

Copy link to clipboard

Copied

New UI and yup, I have the latest patch 9. In the UI, the styles look correct within the topics. The styles go away after I generate the output. It's almost like it can't find the CSS files, which is odd because the topics are linking to the correct ones. I even tried moving the CSS files to be in the same folder as the htm files and that didn't do the trick.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 02, 2019

Copy link to clipboard

Copied

Well, after a little more investigation, it looks like the Responsive HTML5 output didn't include any of the CSS files. No wonder the styles aren't correct. Any ideas on how to fix this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Oct 02, 2019

Copy link to clipboard

Copied

Have you got a master page specified in the preset? The CSS applied to that could be overriding your topic CSS.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 02, 2019

Copy link to clipboard

Copied

Wow, that did the trick! I removed the master page and sure enough, all the styles are working as they should. Is there a way to include the master page? We need one in order to include a copyright on every topic. Otherwise, I'll have to manually go into each topic and add the copyright.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Oct 02, 2019

Copy link to clipboard

Copied

Open the master page and remove the CSS that is linked to it.

You can leave it like that and the CSS linked to topics will then apply. That's useful if different topics have different CSS linked. Alternatively link the one you want so that if a topic somehow gets the wrong CSS, this will fix it.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
mnx2 LATEST
New Here ,
Oct 02, 2019

Copy link to clipboard

Copied

Thanks for all the help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...