Highlighted

Table of Contents' Sub-Items Don't Expand after Translation

Community Beginner ,
Dec 14, 2016

Copy link to clipboard

Copied

So in short I have RoboHelp HTML 9.0.1.262. I'm generating WebHelp with new translations but the translated table of contents doesn't work.

So here are the details. I tried generating the source (English) webhelp with the language set to the target language (French). No problem. I opened the project with Help & Manual 2 GO as my server, and everything looked fine. The TOC worked fine.

Then I copied over the translated documents (only .htm, .hhc, and .hhk files, no others) from my translation tool (memoQ) into the RoboHelp project folders, replacing the English files. I then recompiled the webhelp, but the TOC sub-items will no longer expand. The Index and Search still work fine.

I tried some experiments. I tried replacing only the .htm files with the newly translated files but not replacing the .hhc and .hhk files. That worked fine. The content all appeared as French except for the TOC, and the TOC worked as normal. The only problem was that it gave me a warning in RoboHelp that said, "Configuration Error." Other than that everything seemed to work fine.

I tried another experiment. I tried compiling the parent project with some of the child projects in English and one of them in French. When I opened this parent project, the French child project's TOC didn't work. However, after I clicked on an English project's TOC and opened a sub-item, the French TOC suddenly started working. Even though it was working, it still felt a little buggy because sometimes the sub-items didn't want to close again or you had to click twice on them to open them.

I have not manually altered any .js files. I also used Beyond Compare to compare the source .hhc and .hhk files with the translated files. As best as I can tell, none of the xml code had been corrupted in the translation process. Only the strings were changed. The xml tags were all identical.

What is causing this TOC bug? Any ideas? How can I fix this?

(P.S. I'm viewing the output in Chrome. I don't think that has anything to do with it.)

Topics

WebHelp

Views

459

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Table of Contents' Sub-Items Don't Expand after Translation

Community Beginner ,
Dec 14, 2016

Copy link to clipboard

Copied

So in short I have RoboHelp HTML 9.0.1.262. I'm generating WebHelp with new translations but the translated table of contents doesn't work.

So here are the details. I tried generating the source (English) webhelp with the language set to the target language (French). No problem. I opened the project with Help & Manual 2 GO as my server, and everything looked fine. The TOC worked fine.

Then I copied over the translated documents (only .htm, .hhc, and .hhk files, no others) from my translation tool (memoQ) into the RoboHelp project folders, replacing the English files. I then recompiled the webhelp, but the TOC sub-items will no longer expand. The Index and Search still work fine.

I tried some experiments. I tried replacing only the .htm files with the newly translated files but not replacing the .hhc and .hhk files. That worked fine. The content all appeared as French except for the TOC, and the TOC worked as normal. The only problem was that it gave me a warning in RoboHelp that said, "Configuration Error." Other than that everything seemed to work fine.

I tried another experiment. I tried compiling the parent project with some of the child projects in English and one of them in French. When I opened this parent project, the French child project's TOC didn't work. However, after I clicked on an English project's TOC and opened a sub-item, the French TOC suddenly started working. Even though it was working, it still felt a little buggy because sometimes the sub-items didn't want to close again or you had to click twice on them to open them.

I have not manually altered any .js files. I also used Beyond Compare to compare the source .hhc and .hhk files with the translated files. As best as I can tell, none of the xml code had been corrupted in the translation process. Only the strings were changed. The xml tags were all identical.

What is causing this TOC bug? Any ideas? How can I fix this?

(P.S. I'm viewing the output in Chrome. I don't think that has anything to do with it.)

Topics

WebHelp

Views

460

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Dec 14, 2016

Copy link to clipboard

Copied

Did this ever work? Frankly, with RH9 and Chrome, I'd be surprised that any WebHelp displayed properly (what with all the browser security changes that have taken place). Is it behaving with any other browsers?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 14, 2016

Copy link to clipboard

Copied

I'm not supposed to use Chrome?

The TOC works a tiny bit better perhaps on Firefox 50.0.2, but it's still buggy.

The TOC won't appear at all on IE11.

What should I use?

Is the problem with RH9? Is that version obsolete or something?

Thanks Jeff!

P.S. Note: I'm not just opening it up off my desktop. I'm using HM2GO for a server.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Dec 14, 2016

Copy link to clipboard

Copied

Way obsolete - 3 versions back now (sorry to break the news to you) - RH10, RH11 and now RH2015 is the current one.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 14, 2016

Copy link to clipboard

Copied

Wow. Good to know. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Dec 14, 2016

Copy link to clipboard

Copied

Was this translation process ever working for you? Or is this the first time doing it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 14, 2016

Copy link to clipboard

Copied

I just got word back from our client that they also use RH9, so I don't think this is the problem in this case. Any other ideas?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Dec 14, 2016

Copy link to clipboard

Copied

Well, you didn't answer my question of whether this worked before (& now something's changed - if so, what?) or this is the first time trying this process...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 14, 2016

Copy link to clipboard

Copied

Oh, sorry didn't see that response. I have done this successfully with German, Portuguese, Japanese, Polish, & Chinese.

Only French (France) and French (Canada) are giving me this problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Dec 14, 2016

Copy link to clipboard

Copied

So there must be something different or changed for those 2 languages vs. the others.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Dec 14, 2016

Copy link to clipboard

Copied

I believe French uses some accented characters. I think I'd open the file in Windows Notepad or equivalent and ensure that certain things aren't using any accented characters. My gut says that this is what's happening.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 15, 2016

Copy link to clipboard

Copied

Thanks Jeff and Rick,

Turns out that in those two languages 1 out of the 7 child projects actually works. Strange. We're going to try retranslating those .hhc and .hhk files to see if that changes anything.

Thanks for the feedback. I wasn't sure if there was some known issue that was causing this or some setting that needed to be changed.

Darren

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Dec 15, 2016

Copy link to clipboard

Copied

I believe that what you will find is there are essentially two ways to translate that information.

1. Open an instance of RoboHelp and gain access to the file. Then translate it using RoboHelp.

2. Open the raw HHC file and translate it using Notepad or some other app.

Because things broke, my guess is that option 2 was used and some of the surrounding XML code was munged in the process.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 15, 2016

Copy link to clipboard

Copied

Well, I took an English .hhc file and copied French into it line-by-line for about 350 lines. The resulting .hhc file worked.

Then I used Beyond Compare to compare the .hhc file I made to a non-working .hhc file. There was only one difference . . .

A single non-breaking space.

So it looks like my problem was caused by a single non-breaking space.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...