Highlighted

Team Foundation Server 2018.3 - connection issue

New Here ,
Mar 18, 2019

Copy link to clipboard

Copied

Hi,

Using Robohelp 2019.5 version, i got an error trying to connect my TFS server (on premise).

The collection used is not the "DefaultCollection" and has a "space" in it's name.

Visual Studio Team explorer 2017 installed on same machine and TF.exe folder added to global path variables.

Error message (in french) :

-

Impossible de trouver le fichier TF exécutable. Assurez-vous que TF est installé et que le chemin spécifié contient le nom du fichier.

-

Does anyone have any help or used to connect Robohelp to TFS ?

Thanks

Hi,

Can you please share the TFS Client and Server version with us. Please share the details in email to vsingla@adobe.com.

Regards,

Vikas Singla

TOPICS
New UI

Views

376

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Team Foundation Server 2018.3 - connection issue

New Here ,
Mar 18, 2019

Copy link to clipboard

Copied

Hi,

Using Robohelp 2019.5 version, i got an error trying to connect my TFS server (on premise).

The collection used is not the "DefaultCollection" and has a "space" in it's name.

Visual Studio Team explorer 2017 installed on same machine and TF.exe folder added to global path variables.

Error message (in french) :

-

Impossible de trouver le fichier TF exécutable. Assurez-vous que TF est installé et que le chemin spécifié contient le nom du fichier.

-

Does anyone have any help or used to connect Robohelp to TFS ?

Thanks

Hi,

Can you please share the TFS Client and Server version with us. Please share the details in email to vsingla@adobe.com.

Regards,

Vikas Singla

TOPICS
New UI

Views

377

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 18, 2019 0
Adobe Employee ,
Mar 18, 2019

Copy link to clipboard

Copied

Hi,

I guess you have already followed this step-by-step guide?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 18, 2019 0
New Here ,
Mar 18, 2019

Copy link to clipboard

Copied

Hi,

Yes, i followed it to add my new connection (no error when adding it).

Team project has to be filled like "$/MyProject", right ? Then we'll navigate to open ?

But when i try to "Collaborate > Open Connection" i just created, i got the error with the "TF" file not found.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 18, 2019 0
Adobe Employee ,
Mar 18, 2019

Copy link to clipboard

Copied

Hi,

Can you please try running "TF.exe" from Command Prompt on your machine, just to verify the path to TF Exe is correct. And after adding the path of TF.exe, you restarted the RoboHelp, right?

Regards,

Vikas Singla

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 18, 2019 0
New Here ,
Mar 18, 2019

Copy link to clipboard

Copied

That's what i did to test it, i rebooted the machine. Then restarted Robohelp.

From Command Prompt i got "TF.exe" working when i launch it from the default prompt (c:\users\...).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 18, 2019 0
Adobe Employee ,
Mar 18, 2019

Copy link to clipboard

Copied

Hi,

Can you please check that tf.exe path is saved in dialog of application setting after restarting RoboHelp like:

If this path is saved, tf.exe commands should run from inside RH like they run from command prompt which you are able to run successfully.

If this setting is saved and still you are facing this issue, we can have a quick call to resolve this asap. Please let us know.

Thanks and Regards,
Surbhi Maheshwari

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 18, 2019 0
New Here ,
Mar 19, 2019

Copy link to clipboard

Copied

Hi,

I setted the path to my "TF.exe" file as you showed and checked the box above. Then restarted Robohelp.

I don't have the previous error when i "Open connection" with the connection profile i created.

I got the cloning progress, as below.

But still no files on local folder mapped and i see the open project dialog.

I see the mapping into Visual Studio Team Explorer with the good name and folder.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 19, 2019 0
Adobe Employee ,
Mar 20, 2019

Copy link to clipboard

Copied

Hi,

Can you please share the TFS Client and Server version with us. Please share the details in email to vsingla@adobe.com.

Regards,

Vikas Singla

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 20, 2019 0