Highlighted

Text in my drop down link does not appear in the Design view. The drop-down text editor is empty.

New Here ,
Sep 28, 2017

Copy link to clipboard

Copied

I am working in RoboHelp 2015 on a legacy help project so this is not a new help topic.  For some reason, when I click on the drop down link nothing appears, but when I preview the topic, or compile it there is text present.  I can see the HTML also.  How can I get the text to display again.

Topics

HTML help

Views

873

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Text in my drop down link does not appear in the Design view. The drop-down text editor is empty.

New Here ,
Sep 28, 2017

Copy link to clipboard

Copied

I am working in RoboHelp 2015 on a legacy help project so this is not a new help topic.  For some reason, when I click on the drop down link nothing appears, but when I preview the topic, or compile it there is text present.  I can see the HTML also.  How can I get the text to display again.

Topics

HTML help

Views

874

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Sep 28, 2017

Copy link to clipboard

Copied

If you create a totally new drop-down and add text, does it work then?

Is this an upgraded project? If so, perhaps you want to try clicking the Tools tab and choosing Update DHTML.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 26, 2018

Copy link to clipboard

Copied

I know that this thread was started some time ago but we have just upgraded to RoboHelp 2017 after many years of running RoboHelp 5 and after the upgrade I too have lost the drop down text capability after the project was upgraded.

New drop down text works fine.

I have tried the update DHTML and also coping the dhtml javascript file from the samples but nothing seems to work.

We do not have time to replace every single drop down we have so hopefully some one can suggest something to put this right.

Thanks,

Splodge

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Apr 27, 2018

Copy link to clipboard

Copied

I doubt it is relevant but any port in a storm. Do you have the updates applied? If not, apply them and and try upgrading again.

If that fails, it might be worth contacting Adobe Support, it's free.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 30, 2018

Copy link to clipboard

Copied

Thanks Peter,

I did install both updates that I could find on the Adobe Site all to no avail. I raised a ticket with adobe support before coming to the forum as I did look to see if there had been any answers in the forum already.

They have yet to get back to me.

Regards,

Roger

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Apr 30, 2018

Copy link to clipboard

Copied

Between your previous and current versions, there were many other versions that changed the coding and how dropdowns work. I don't know if there is a solution but I'm happy to take a look if you can share the project. If you can, see the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

It may be a few days before I can but I'll do my best.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Apr 30, 2018

Copy link to clipboard

Copied

Two other things I'd suggest, if they're relevant.

Make sure your project is on your c: drive. Preferably something like C:\RH, as sometimes "My Documents" etc is actually on a network drive in corporate environments. I know Adobe has made improvements to working on a network drive, but having it local for the upgrade will remove any issues with network glitches or slowness that might break something.

If you have source control, manually check out the entire project through the source control tool. This will make sure everything is writable; sometimes I've found RH doesn't check out a file it needs to update.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 01, 2018

Copy link to clipboard

Copied

Amber makes a good point on the location of the project. Storing projects on a network (other than source control) was introduced in RoboHelp 10 and it is essential that the first upgrade to RoboHelp 10 or later is done locally.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 01, 2018

Copy link to clipboard

Copied

Thanks Guys,

I was working on a external hard drive which was local to my computer so this should not be the issue. We use TFS for our version control. I went back to the last full release of the product and copied it to my C Drive and tried again with exactly the same result.

Talking with he project manager here we have decided to take the hit and redo the drop downs.

The version we were using was so out of data that the fact that this is the only bit that was broken was good.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 01, 2018

Copy link to clipboard

Copied

Hold up, the toolbox is not empty. Back in the days of X5 I had a problem

and the senior RoboHelp engineer advised me to move the project to the c

drive. It fixed the issue. Like you I used external drives but for this

issue that was the fix.

Dig out the X5 copy and put it on your c drive, then upgrade. You may need

to run the dhtml update but it is worth a try.

Peter Grainge

www.grainge.org

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...