Highlighted

The Design view of my table is un-editable but looks just fine in View Topic.

Explorer ,
Jul 16, 2015

Copy link to clipboard

Copied

Because the Design view shows only part of the table heading row and the rest of the table disappears, I cannot edit the table in Design view. I've pasted the CSS and HTML below. Can anyone offer guidance?

CSS

table {

border-collapse: collapse;

}

th {

background-color: #e6e6e6;

border: solid #009DD9 1.0px;

color: #009dd9;

font-family: Arial, sans-serif;

font-size: .8em;

margin: 6px 4px 8px 0px;

text-align: center;

vertical-align: top;

}

td{

border: solid #009dd9 1.0px;

border-collapse: collapse;

color: #000000;

font-family: Arial, sans-serif;

font-size: .8em;

margin: 1.5em .5em 1.5em .5em;

text-align: left;

}

HTML

<table class="center">

<col />

<col />

<col width="372" />

<tr style="page-break-inside: avoid;">

  <th><p class="NTableHeading">Number</p></th>

  <th><p class="NTableHeading">Number</p></th>

  <th><p class="NTableHeading">Number</p></th>

</tr>

<tr style="page-break-inside: avoid;">

  <td>Cell</td>

  <td>Cell</td>

  <td>Cell</td>

</tr>

<tr style="page-break-inside: avoid;">

  <td>Cell</td>

  <td>Cell</td>

  <td>Cell</td>

</tr>

<tr style="page-break-inside: avoid;">

  <td>Cell</td>

  <td>Cell</td>

  <td>Cell</td>

</tr>

<tr style="page-break-inside: avoid;">

  <td>Cell</td>

  <td>Cell</td>

  <td>Cell</td>

</tr>

</table>

To add to Amebr; change the margin into padding. That will make sure the content isn't squeezed to the cell borders.

Topics

HTML

Views

123

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

The Design view of my table is un-editable but looks just fine in View Topic.

Explorer ,
Jul 16, 2015

Copy link to clipboard

Copied

Because the Design view shows only part of the table heading row and the rest of the table disappears, I cannot edit the table in Design view. I've pasted the CSS and HTML below. Can anyone offer guidance?

CSS

table {

border-collapse: collapse;

}

th {

background-color: #e6e6e6;

border: solid #009DD9 1.0px;

color: #009dd9;

font-family: Arial, sans-serif;

font-size: .8em;

margin: 6px 4px 8px 0px;

text-align: center;

vertical-align: top;

}

td{

border: solid #009dd9 1.0px;

border-collapse: collapse;

color: #000000;

font-family: Arial, sans-serif;

font-size: .8em;

margin: 1.5em .5em 1.5em .5em;

text-align: left;

}

HTML

<table class="center">

<col />

<col />

<col width="372" />

<tr style="page-break-inside: avoid;">

  <th><p class="NTableHeading">Number</p></th>

  <th><p class="NTableHeading">Number</p></th>

  <th><p class="NTableHeading">Number</p></th>

</tr>

<tr style="page-break-inside: avoid;">

  <td>Cell</td>

  <td>Cell</td>

  <td>Cell</td>

</tr>

<tr style="page-break-inside: avoid;">

  <td>Cell</td>

  <td>Cell</td>

  <td>Cell</td>

</tr>

<tr style="page-break-inside: avoid;">

  <td>Cell</td>

  <td>Cell</td>

  <td>Cell</td>

</tr>

<tr style="page-break-inside: avoid;">

  <td>Cell</td>

  <td>Cell</td>

  <td>Cell</td>

</tr>

</table>

To add to Amebr; change the margin into padding. That will make sure the content isn't squeezed to the cell borders.

Topics

HTML

Views

124

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jul 16, 2015

Copy link to clipboard

Copied

Remove the margin settings on the th and the td. You can't actually apply margins to these elements in css, so I think it's a bug that RH tries to render it and fails dismally .

Tables

"Internal table elements do not have margins "

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jul 17, 2015

Copy link to clipboard

Copied

To add to Amebr; change the margin into padding. That will make sure the content isn't squeezed to the cell borders.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jul 17, 2015

Copy link to clipboard

Copied

Thanks to each of you for replying so quickly! Yes, changing "margin" to "padding" solved my problems.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...