Highlighted

Topics in specific RH10 HTML project folder not included in compiled Help

Explorer ,
Aug 07, 2018

Copy link to clipboard

Copied

Hi All,

I am updating topics in an RH10 HTML project that I have worked on for many years. The project includes about 500 topics divided among 8 folders. One of the folders contains what we call "PageHelp" topics. I have noticed that the topics in this folder are not being included in my recent compiles of the project. I compile the project as WebHelp. I have unmarked the "Exclude unreferenced topics from Output" box in my WebHelp settings, as the PageHelp topics are not, in fact, referenced by other topics or the TOC or Index. This has not helped.

I notice that the icon for my PageHelp folder containing all the topics missing from my compiles appears in the Project Manager pod as shown below. I suspect the red triangle is telling me something, but I'm not sure what or what to do to make it go away. I have not been able to find any info about this in RoboHelp help. The triangle does not appear in any of the other folder icons listed by the Project Manager.

I would greatly appreciated suggestions on how to resolve my problem.  Thanks in advance!

Bill

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

It's telling you a tag is applied to content in that folder. Is that excluding those topics because of the build expression?

These are topics referenced from other topics and the links fail, correct?


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

TOPICS
HTML

Views

168

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Topics in specific RH10 HTML project folder not included in compiled Help

Explorer ,
Aug 07, 2018

Copy link to clipboard

Copied

Hi All,

I am updating topics in an RH10 HTML project that I have worked on for many years. The project includes about 500 topics divided among 8 folders. One of the folders contains what we call "PageHelp" topics. I have noticed that the topics in this folder are not being included in my recent compiles of the project. I compile the project as WebHelp. I have unmarked the "Exclude unreferenced topics from Output" box in my WebHelp settings, as the PageHelp topics are not, in fact, referenced by other topics or the TOC or Index. This has not helped.

I notice that the icon for my PageHelp folder containing all the topics missing from my compiles appears in the Project Manager pod as shown below. I suspect the red triangle is telling me something, but I'm not sure what or what to do to make it go away. I have not been able to find any info about this in RoboHelp help. The triangle does not appear in any of the other folder icons listed by the Project Manager.

I would greatly appreciated suggestions on how to resolve my problem.  Thanks in advance!

Bill

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

It's telling you a tag is applied to content in that folder. Is that excluding those topics because of the build expression?

These are topics referenced from other topics and the links fail, correct?


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

TOPICS
HTML

Views

169

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 07, 2018 0
Adobe Community Professional ,
Aug 07, 2018

Copy link to clipboard

Copied

It's telling you a tag is applied to content in that folder. Is that excluding those topics because of the build expression?

These are topics referenced from other topics and the links fail, correct?


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2018 1
pgcalc LATEST
Explorer ,
Aug 07, 2018

Copy link to clipboard

Copied

Firstly, thank you for your lightning-quick reply.

Yes, there is one topic in that folder to which I've applied a topic level tag. That explains the red triangle.

I just tried compiling Help again and now the PageHelp folder appears in my compile and appears to contain all the topics I would expect. I can't explain it, but I'll take it.

Thanks for clearing up the meaning of the red triangle.

Bill

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2018 0
Adobe Community Professional ,
Aug 07, 2018

Copy link to clipboard

Copied

Check your Conditional Build Tags - you may have a mix of different conditions applied to topics in that folder.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2018 1