Topics not available from TOC in CHM after upgrade from RH 2019 Classic to RH 2020

Nov 10, 2020

Copy link to clipboard

Copied

I am looking for suggestions for troubleshooting. I tried searching the forum, but couldn't find anything similar.

 

I have a project that I have upgraded from RH 2019 Classic to RH 2020 update 2. The project compiled OK in RH 2019 Classic. When I compile using the same TOC in RH 2020, no topics are visible in the TOC, except the default topic and a topic almost at the bottom of the structure. I can see some books, but not all, and the structure is incorrect.

 

When I search the project, it seems that all topics are in there, just not available from the TOC.

 

I checked the log, and there are a couple of missing images, and there are also some broken links, but that should not cause such issues.

 

I have tried using the same TOC to create a PDF and that worked OK.

 

Would the easiest workaround be to create another TOC? The structure is pretty long, so it would be quite time consuming.

 

Regards,

Rannveig

I think the problem here is Classic versions did not enforce strict adherence to CSS3 and HTML5 standards whereas the new versions do. I expect the standards to not allow national characters.

 

On that basis it is not a bug and your solution is correct.

 

Views

44

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Topics not available from TOC in CHM after upgrade from RH 2019 Classic to RH 2020

Nov 10, 2020

Copy link to clipboard

Copied

I am looking for suggestions for troubleshooting. I tried searching the forum, but couldn't find anything similar.

 

I have a project that I have upgraded from RH 2019 Classic to RH 2020 update 2. The project compiled OK in RH 2019 Classic. When I compile using the same TOC in RH 2020, no topics are visible in the TOC, except the default topic and a topic almost at the bottom of the structure. I can see some books, but not all, and the structure is incorrect.

 

When I search the project, it seems that all topics are in there, just not available from the TOC.

 

I checked the log, and there are a couple of missing images, and there are also some broken links, but that should not cause such issues.

 

I have tried using the same TOC to create a PDF and that worked OK.

 

Would the easiest workaround be to create another TOC? The structure is pretty long, so it would be quite time consuming.

 

Regards,

Rannveig

I think the problem here is Classic versions did not enforce strict adherence to CSS3 and HTML5 standards whereas the new versions do. I expect the standards to not allow national characters.

 

On that basis it is not a bug and your solution is correct.

 

Views

45

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 10, 2020 0
Nov 10, 2020

Copy link to clipboard

Copied

My first step would be to leave your existing TOC alone and create a second one. Just drag all the topics from the Contents Panel into the TOC. The order will be wrong but the object here is to see what ends up in the CHM.

 

Are you viewing the CHM locally? I'm guessing you are as otherwise the CHM shouldn't work at all.

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 0
Nov 10, 2020

Copy link to clipboard

Copied

Yes, everything is local.

 

Thx for the suggestion. That worked OK - of course only a flat structure. Which I assume means that there must be something wrong with the book structure. The best option would perhaps be to recreate the structure in a new TOC to be sure everything is OK.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 0
Nov 10, 2020

Copy link to clipboard

Copied

As all the topics are in the CHM you can rule out any expressions causing the problem.

 

In 2020 there are two types of TOC. See https://www.grainge.org/pages/authoring/rh_tour/rh2020/toc_index_glossary/toc.htm

 

In theory it is OK to have one TOC and it will work for both online and print purposes. Right click the TOC and check its properties. If it is set to Book, change it to online and try again. As I said, it shouldn't matter but it's worth a try.

 

Have you tried generating again anyway just to see if it was a one-off glitch?

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 0
Nov 10, 2020

Copy link to clipboard

Copied

This was an online TOC, so it should be OK.

The generation failed both on my colleague's and my computer independently, so it is obviously a generic problem.

I still think the best option is to rebuild the structure in a new TOC, although I am curious which changes from RH 2019 to RH 2020 could have caused this problem.

Anyway - thanks a lot for your suggestions 😊

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 0
Nov 10, 2020

Copy link to clipboard

Copied

What's bothering me here is that no one else has posted about this scenario. Is the project local and are you generating to a local folder?

 

When you start rebuilding the TOC, test it a few times on the way.

 

Please come back and post the outcome. If the new TOC does fix it, that sounds like an upgrade issue that should be reported.

 

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 10, 2020 0