Highlighted

Trouble creating and importing Robohelp Skin

New Here ,
Mar 01, 2016

Copy link to clipboard

Copied

Robohelp 2015, using source control

I can not create a custom skin or import a skin. I also can not even choose a skin from Robohelp's gallery. It appears to work but I can never get a new skin to appear in my Robohelp project.

This has worked before 2015. Any suggestions?

Views

359

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Trouble creating and importing Robohelp Skin

New Here ,
Mar 01, 2016

Copy link to clipboard

Copied

Robohelp 2015, using source control

I can not create a custom skin or import a skin. I also can not even choose a skin from Robohelp's gallery. It appears to work but I can never get a new skin to appear in my Robohelp project.

This has worked before 2015. Any suggestions?

Views

360

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 01, 2016 0
LEGEND ,
Mar 02, 2016

Copy link to clipboard

Copied

If you look on disk, is there a folder for the skin in the !SkinSubFolder!? If it is there, try removing the CPD.

Can you add a skin to a dummy project or one of the sample projects? It shouldn't be connected to source control, but you never know.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 02, 2016 0
New Here ,
Mar 09, 2016

Copy link to clipboard

Copied

Thank you William for your response. And, sorry for the delay in getting back to you! The folder is there with my new skin (both in Source Control and in my local workspace) and the project believes the skin is there but it does not appear in RoboHelp's Output Setup panel (Skins folder). It is probably a RoboHelp/Source Control issue. Very annoying. Will ignore the issue for now but if you have any other suggestions let me know.

Thank you!

Lynn

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 09, 2016 0
LEGEND ,
Mar 19, 2016

Copy link to clipboard

Copied

If the skin is available on disk, but not in the project, the project is out of sync. There are two ways to fix this:

  • Remove the skin from source control and disk and add it again.
  • Update the file rhscreenlayout.apj in notepad.

For the second option, you have to add the following to the APJ file:

<ScreenLayout name="Folder_name_of_screen_layout">

  <ScreenLayoutPages>

  <ScreenLayoutPage default="1" name="Topic.slp" type="1"/>

  </ScreenLayoutPages>

  </ScreenLayout>

Save, trash the CPD and open RoboHelp again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 19, 2016 0