Trouble importing a RoboHelp 2015 into RoboHelp 2019 (non-classic)

Explorer ,
Sep 18, 2018 Sep 18, 2018

Copy link to clipboard

Copied

We have a help project that was generated with RoboHelp 2015.  I have downloaded the trial of RoboHelp 2019.  I tried importing our existing project into RH2019 (non-classic).  Only a few (10 or 15 out of a couple of thousand) messages show up in the help (WebHelp).  I imported the same project into the classic RH2019 and it works fine.  Any ideas why the new one wouldn't work?

Phil

TOPICS
HTML

Views

977

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Explorer , Sep 20, 2018 Sep 20, 2018
Just got off the phone with RH tech support.  It ended up being a corrupt TOC.  We created a new one and it was fine.  Some missing files (we were working with a copy).

Likes

translate

Translate

Translate
Explorer ,
Sep 20, 2018 Sep 20, 2018

Copy link to clipboard

Copied

I am trying to import the 2015 project to 2019 new. I haven't tried

importing it into 2019 classic and then importing that into 2019 new.

The project is big - 423 MB.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 20, 2018 Sep 20, 2018

Copy link to clipboard

Copied

No worries re the size. Send it as above.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 20, 2018 Sep 20, 2018

Copy link to clipboard

Copied

I just sent it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 20, 2018 Sep 20, 2018

Copy link to clipboard

Copied

Works fine here.

I opened the project you sent me and, as you said, there is no responsive layout. In Outputs in the project sent, I selected the responsive layout and in the dialog I selected the Azure Blue layout and generated an output that looks complete. The only thing that is different is that I had to do it in 2017 as I don't currently have 2015 installed. That machine is on its way back to Microsoft.

Then I upgraded the project and its still OK.

Try those steps in your 2015 project. Open it, select the Responsive Layout, select Azure Blue and generate. What happens there?

If that looks OK, open 2019, click Upgrade RoboHelp project and browse to the XPJ file in 2015.

Let me know what happens.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 20, 2018 Sep 20, 2018

Copy link to clipboard

Copied

Just got off the phone with RH tech support.  It ended up being a corrupt TOC.  We created a new one and it was fine.  Some missing files (we were working with a copy).

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 20, 2018 Sep 20, 2018

Copy link to clipboard

Copied

Corrupt in which version? The TOC in what you sent me was not corrupt or I

would have had the same issue.

Peter Grainge

www.grainge.org

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 21, 2018 Sep 21, 2018

Copy link to clipboard

Copied

When we imported my 2015 source into 2019 non-classic the TOC was corrupt (in 2019 non-classic).

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 21, 2018 Sep 21, 2018

Copy link to clipboard

Copied

When I did the same via 2017, it worked and didn't corrupt the TOC in 2019.

1. Have you recreated the full TOC in 2019? If not, I can save you the

trouble by sending the one from my upgrade.

2. I have a hunch as to what went wrong. OK to share the project you sent

me with Adobe? It could save others hitting this problem.

Peter Grainge

www.grainge.org

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 21, 2018 Sep 21, 2018

Copy link to clipboard

Copied

1.  The TOC was fully recreated by 'inserting' a TOC

2.  OK.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 25, 2018 Sep 25, 2018

Copy link to clipboard

Copied

Hi,

I tried upgrading your project in RH 2019 and toc is getting correctly upgraded.

Can you please try upgrading the project once again and see if issue persists?

If yes, Please share the toc of RH 2015 project for which bad upgrade is happening.

Thanks and Regards,
Surbhi Maheshwari

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 26, 2018 Sep 26, 2018

Copy link to clipboard

Copied

I'm not sure what you are asking for. If you upgraded the 2015 project,

then you already have the 2015 TOC. Do you want the failed 2019 TOC? I

don't know how to isolate the TOC. Attached is the help system that is

generated once I import from 2015 to 2019. There should be 16 top-level

folders in the TOC. There are only 3 in the 2019 build.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 26, 2018 Sep 26, 2018

Copy link to clipboard

Copied

In Surbhi's time zone it's late now.

I know she has upgraded your project from 2015 to 2019 without a problem. I have too, albeit a glitch the first time.

I believe the thinking is you hit a one time glitch. It would help if you could try a direct upgrade from 2015 to 2019 again.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 26, 2018 Sep 26, 2018

Copy link to clipboard

Copied

I have done that many times. The most recent was about an hour ago. Same

results.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 26, 2018 Sep 26, 2018

Copy link to clipboard

Copied

The email thing apart, it's odd that you continue to see this when two others do not. Let's hope Surbhi can throw some light on it.

Is there anything about your environment you can think of? Is the project on a local drive?


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 26, 2018 Sep 26, 2018

Copy link to clipboard

Copied

Yes. Everything is on my local drive.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Sep 28, 2018 Sep 28, 2018

Copy link to clipboard

Copied

@epsobolik and PeterGrainge

I have upgraded from RoboHelp 2015 to RoboHelp 2019. There is a RoboHelp 2019 Classic and non-Classic? What is the difference?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 28, 2018 Sep 28, 2018

Copy link to clipboard

Copied

RoboHelp "Classic" is essentially a continuation of the RoboHelp HTML we have all known and loved for many years. "Non-Classic" is a totally new version built from the ground up using different tools. It was released as a "work in progress" as it doesn't have all the features the "Classic" version has. Adobe engineers are continuing to work to hopefully bring it into parity with what was possible in the former version. At what point that will happen is anyone's guess. But if you are still relying on certain features that 2019 doesn't offer, you should stick with Classic until 2019 offers that feature.

Cheers... Rick

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Sep 28, 2018 Sep 28, 2018

Copy link to clipboard

Copied

Thank you Captiv8r​ !

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 29, 2018 Sep 29, 2018

Copy link to clipboard

Copied

You can see what the new version looks like in The RoboHelp Tour on my site.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation