Highlighted

Two table of contents display for generated webhelp

Community Beginner ,
Mar 29, 2017

Copy link to clipboard

Copied

I am using RH v11.0.4

This is what displays when webhelp for this project is opened. Notice that the left TOC is outdated (Release Notes for 2015); the right TOC is as it should be.

This issue is specific to one project. Other webhelp projects generate and display the TOC correctly.

I contacted RoboHelp support and gave them access to my desktop and a copy of the problem project. The support analyst couldn't identify why this issue occurred. His solution was to open Project Set-up pod and create a new window. Although I watched closely and took notes, I cannot recreate his result in my actual project.

Does anyone know what caused this issue?

Thanks

Jackie

Well, see, the thing is, there's no way to accomplish what you are suggesting. It's an impossibility.

Yes, it's possible to have more than one TOC in a SSL recipe, but that only applies to WebHelp and using the DUCC feature. And even then, only one TOC would be visible at any given time.

What this looks like is that maybe one WebHelp output has managed to be oddly combined with another. And the default topic for the the outer output is actually the WebHelp start page for a second output. (Kind of like the movie "Inception".)

Personally, I suspect a corrupt project rife with all manner of output files having been copied or imported back in and used as source. But one step at a time.

Cheers... Rick

Topics

WebHelp

Views

374

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Two table of contents display for generated webhelp

Community Beginner ,
Mar 29, 2017

Copy link to clipboard

Copied

I am using RH v11.0.4

This is what displays when webhelp for this project is opened. Notice that the left TOC is outdated (Release Notes for 2015); the right TOC is as it should be.

This issue is specific to one project. Other webhelp projects generate and display the TOC correctly.

I contacted RoboHelp support and gave them access to my desktop and a copy of the problem project. The support analyst couldn't identify why this issue occurred. His solution was to open Project Set-up pod and create a new window. Although I watched closely and took notes, I cannot recreate his result in my actual project.

Does anyone know what caused this issue?

Thanks

Jackie

Well, see, the thing is, there's no way to accomplish what you are suggesting. It's an impossibility.

Yes, it's possible to have more than one TOC in a SSL recipe, but that only applies to WebHelp and using the DUCC feature. And even then, only one TOC would be visible at any given time.

What this looks like is that maybe one WebHelp output has managed to be oddly combined with another. And the default topic for the the outer output is actually the WebHelp start page for a second output. (Kind of like the movie "Inception".)

Personally, I suspect a corrupt project rife with all manner of output files having been copied or imported back in and used as source. But one step at a time.

Cheers... Rick

Topics

WebHelp

Views

375

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Mar 29, 2017

Copy link to clipboard

Copied

Is this view all within a single WebHelp output? Looks like you've somehow told it to use 2 TOCs - can you give us a screenshot of the RH SSL recipe?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 29, 2017

Copy link to clipboard

Copied

Yes, single output. By recipe do you mean SSL file list?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Mar 29, 2017

Copy link to clipboard

Copied

Not the files, the Single Source Layout properties - there's a Content choice in the tree layout where you select what TOC(s) to include.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Mar 29, 2017

Copy link to clipboard

Copied

What this appears to be is a nested webhelp output.

Something is definitely amiss here. I'd begin by looking at the location where this is being viewed. Just delete all the content that is there, and generate WebHelp again and copy the output to the location.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Mar 29, 2017

Copy link to clipboard

Copied

@Rick - that was going to be my next suggestion if they hadn't put 2 TOCs inside their SSL ;>)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Mar 29, 2017

Copy link to clipboard

Copied

Well, see, the thing is, there's no way to accomplish what you are suggesting. It's an impossibility.

Yes, it's possible to have more than one TOC in a SSL recipe, but that only applies to WebHelp and using the DUCC feature. And even then, only one TOC would be visible at any given time.

What this looks like is that maybe one WebHelp output has managed to be oddly combined with another. And the default topic for the the outer output is actually the WebHelp start page for a second output. (Kind of like the movie "Inception".)

Personally, I suspect a corrupt project rife with all manner of output files having been copied or imported back in and used as source. But one step at a time.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
brickerd LATEST
Community Beginner ,
Mar 30, 2017

Copy link to clipboard

Copied

Thank you both for your thoughts and suggestions, which as usual prompted me to look at project settings a little more critically. I found that the path to the output folder and start page had changed. I noticed it in the compile URL. The folder containing the start topic was inserted after the intended output folder. I corrected the path and the output generates as it should.

I'm still not sure why the path changed because I'm the only one working on this project and had not touched it.

Regards

Jackie

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...