Unable to generate files with unique names

New Here ,
Jul 24, 2015 Jul 24, 2015

Copy link to clipboard

Copied

When generating files I am unable to manually key in the names so that they match their respective entry in the contents of my help document. The reason why I am trying to do this manually is because every time I generate these files Robohelp 9 assigns generic names to the files rather than having the names match the topic names. I someone has a solution to either of these problems I would appreciate hearing about it. Thanks

Views

172

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 24, 2015 Jul 24, 2015

Copy link to clipboard

Copied

Hi there

I think we will be needing a wee bit more information in order to provide a meaningful suggestion.

What would be helpful is if you could reply and tell us the exact steps you are following and where things appear to be failing.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 24, 2015 Jul 24, 2015

Copy link to clipboard

Copied

Hey Rick,

Thanks for the response.

So here are the steps:

1. Import Word document into a new project on Robohelp

2. In the Content Settings popup check all three boxes (Content, Index, Glossary)

3. Import Completes

4. File>Generate>Primary Layout(WebHelp)

5. Push the Save and Generate button

6. In the Project Set-Up box Context-Sensitive Help>Map Files, double click All Map ID's

7. In the right hand box under Topic I can view a drop-down list containing folder options, beneath that I see the files I have just generated.

My problem is that the names of the files do not match the topic and sub-topic names in the table of contents of my document. They approximately coincide and in some cases match but in other cases they list the same topic name over and over with numbering e.g. <Topic Name>1, <Topic Name>2, etc...

I need the file names to match the entries in the table of contents exactly and more importantly I need the Map ID's I will create using these files to match the table of contents names exactly.

Is there some setting I can manipulate to get the desired result?

Thanks again,

Sean

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 24, 2015 Jul 24, 2015

Copy link to clipboard

Copied

Ahhh, okay, It all makes sense now.

Question here. Are you performing simple importing? Or are you using the feature where you link and have that ongoing relationship with the Word document?

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 27, 2015 Jul 27, 2015

Copy link to clipboard

Copied

I am performing simple importing. I made changes to the word document and imported those changes into a new project each time I had and update to make. I went back and forth editing and importing about 5 or 6 times before I got everything formatted the way I wanted it to be.

So far the extent of my trying to resolve the problem I am having with the naming of the files being generated (and thus the Map IDs) has been playing around with the setting on the various steps between importing and mapping.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2015 Aug 02, 2015

Copy link to clipboard

Copied

LATEST

The file names are the headings in your Word document. You cannot change that so the solution is that all else has to match or you have to change them after import.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation