Highlighted

Unable to open links to other projects in Chrome, FireFox and MS Edge - RoboHelp 2019 Classic

Community Beginner ,
Aug 12, 2020

Copy link to clipboard

Copied

I have a number of links to windchillhelp KB so I only have to update in one place. I cannot open links to windchillhelp with the setting: Display in frame: Page Default (none). This works in Internet Explorer without issue, but does not work for Chrome, FireFox and MS Edge. Any idea what's going on??? 
I also just just tried "Display in Same Frame" with same result.

Note - if I say "Display in a new page" it works, but that is not what I want, they will spawn too many windows 😞

 

Additional Information: Is it possible it has to do with too many dashes, it's not underscores, I have links without underscores.

 

  1. Click on link to open in main frame - reference is: http://windchillhelp.mot-mobility.com/Loadsheet/Request_Sales_Model.htm
    Links.png
  2. A white page is displayed with rotating messages, "waiting for windchillhelp.mot-mobility.com..." "waiting for cache" and "Connecting". 
    message.jpg
  3. If I right click the same link and select Open in a new tab, it works perfectly.
    new tab.jpg

Topics

Classic

Views

51

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Unable to open links to other projects in Chrome, FireFox and MS Edge - RoboHelp 2019 Classic

Community Beginner ,
Aug 12, 2020

Copy link to clipboard

Copied

I have a number of links to windchillhelp KB so I only have to update in one place. I cannot open links to windchillhelp with the setting: Display in frame: Page Default (none). This works in Internet Explorer without issue, but does not work for Chrome, FireFox and MS Edge. Any idea what's going on??? 
I also just just tried "Display in Same Frame" with same result.

Note - if I say "Display in a new page" it works, but that is not what I want, they will spawn too many windows 😞

 

Additional Information: Is it possible it has to do with too many dashes, it's not underscores, I have links without underscores.

 

  1. Click on link to open in main frame - reference is: http://windchillhelp.mot-mobility.com/Loadsheet/Request_Sales_Model.htm
    Links.png
  2. A white page is displayed with rotating messages, "waiting for windchillhelp.mot-mobility.com..." "waiting for cache" and "Connecting". 
    message.jpg
  3. If I right click the same link and select Open in a new tab, it works perfectly.
    new tab.jpg

Topics

Classic

Views

52

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 13, 2020

Copy link to clipboard

Copied

Hyphens are fine in links.

 

The links you have given do not work so I guess they are behind a firewall.

 

Your structure is not clear. Are the links from one project to another project that you want to open in the same browser tab? If they are then I think most modern browsers seem to work the way you are finding no matter what you set. I haven't tested that exhaustively but from my limited tests and what I read, that's what seems to be happening.

 

The start of this was it's about being able to update in one place. Update what? Give us some more information about your whole setup.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 13, 2020

Copy link to clipboard

Copied

Hi Peter - 

 

Hopefully I am answering your questions. Yes - these are behind a firewall. Any Motorola or Lenovo user can access both KBs without issue, and open any links.

Most support staff does not need step-by-step information, but I want to link to it for new members so all the info is in one place.  So step-by-steps are in Windchill KB, and then if I have to refer to it in support documentation, I just put a link so they can view it. This morning, one page opens, another doesn't. Here is a link to video - https://photos.app.goo.gl/8oVBudwx646owENj7

The only change I made is yesterday afternoon I renamed the link that opens today:

While waiting I can try doing that to a few more, but it would make zero sense that renaming worked. These pages were created in RoboHelp 2019 Classic, they were not imported. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 13, 2020

Copy link to clipboard

Copied

The video is either too small or when you go full screen too fuzzy. 

 

  1. Are these separate projects?
  2. Do they have to be that way?
  3. This is responsive help, correct?
  4. In one project you are linking to what in the other? Specific topics or just opening the target help

 

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 13, 2020

Copy link to clipboard

Copied

Sorry the video is poor 😞 trying again with a closeup, I can see it clearly on my screen - https://photos.app.goo.gl/gibY2FyGMKJWKQSh8. In the video, the link that opens is the one I changed the hyperlink to open in a new window. I prefer it to open it as "page default", and display in the main frame of the the current project. It gets too cluttered with all the open pages. If I have to do that to make it work, I will.

 

  1. Are these separate projects? Yes they are
  2. Do they have to be that way? I believe so, they need to have separate URLs
  3. This is responsive help, correct? Yes - it is
  4. In one project you are linking to what in the other? Specific topics or just opening the target help
    I can open a project home page, but I am linking to specific topics in a different project. That is what does not work. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 14, 2020

Copy link to clipboard

Copied

I now get the problem. You are wanting to open a topic from one project within the first project. I was reading the problem as wanting to open it in the same browser tab. Display in New Frame threw me as that is an instruction to the browser.

 

The only way I think you could do that is to create an inline frame and in Project 1 you would have a topic that has the inline frame pointing to the topic in Project 2. It's not a way I would do it.

 

I'm thinking merged help would be better here. Broadly here's how it would be set up.

 

  • You create a parent project with no content.
  • You add Project 1 and Project 2 as child projects.
  • When you generate them the user will see it all as one project. There will be a TOC that will show the TOCs from both projects.
  • The TOC can be set up how you want. It could simply be a single book for Project 1 that would expand to what you now have and the same for Project 2.

 

Merged Help is fully explained on my site and there are some demo projects set that you could play with to see if it would suit your requirements.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...