Highlighted

Unable to solve broken link

Explorer ,
Oct 15, 2019

Copy link to clipboard

Copied

I am using Adobe RoboHelp 2019 version 2019.0.8. I have solved all the broken links except 1. The broken links report appears as follows:Broken Links1.jpg

I have cleared out all other broken links. I am unable to find More_Menu.htm# (above).

I have done a search in RoboHelp 2019 in More_Menu.htm. Nothing.

I clicked on fix broken links (below) and it creates more broken links and does not fix the problem. The tool wants me to replace the broken link with something. I don't know what to replace it with. I would like to find it first.

Broken Links2.jpg

 

I downloaded Ecobyte Replace Text to see if this tool would find the More_Menu.htm#. Again I did not know what to replace the link with. I got the following in the Ecobyte Replace Text log:

***************

Replace Group: New Group

Source: "C:\RoboHelp2019\outputs\Alarms\More_Menu.htm"
Destination: "C:\RoboHelp2019\outputs\Alarms\More_Menu.htm" (1 Changes)
Backup: "C:\RoboHelp2019\outputs\Alarms\More_Menu.htm.backup"

Files Processed: 1
Files Altered: 1

***************

Nothing changed in my More_Menu after processing and there is still a broken link.

Please help

TOPICS
HTML help, HTML5 layout, New UI

Views

177

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Unable to solve broken link

Explorer ,
Oct 15, 2019

Copy link to clipboard

Copied

I am using Adobe RoboHelp 2019 version 2019.0.8. I have solved all the broken links except 1. The broken links report appears as follows:Broken Links1.jpg

I have cleared out all other broken links. I am unable to find More_Menu.htm# (above).

I have done a search in RoboHelp 2019 in More_Menu.htm. Nothing.

I clicked on fix broken links (below) and it creates more broken links and does not fix the problem. The tool wants me to replace the broken link with something. I don't know what to replace it with. I would like to find it first.

Broken Links2.jpg

 

I downloaded Ecobyte Replace Text to see if this tool would find the More_Menu.htm#. Again I did not know what to replace the link with. I got the following in the Ecobyte Replace Text log:

***************

Replace Group: New Group

Source: "C:\RoboHelp2019\outputs\Alarms\More_Menu.htm"
Destination: "C:\RoboHelp2019\outputs\Alarms\More_Menu.htm" (1 Changes)
Backup: "C:\RoboHelp2019\outputs\Alarms\More_Menu.htm.backup"

Files Processed: 1
Files Altered: 1

***************

Nothing changed in my More_Menu after processing and there is still a broken link.

Please help

TOPICS
HTML help, HTML5 layout, New UI

Views

178

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 15, 2019 0
Adobe Community Professional ,
Oct 15, 2019

Copy link to clipboard

Copied

That "#" at the end of the file name seems to imply that it's a bookmark within that topic that's busted. Is this using the new UI or Classic?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2019 0
Explorer ,
Oct 15, 2019

Copy link to clipboard

Copied

New UI Jeff.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2019 0
Explorer ,
Oct 15, 2019

Copy link to clipboard

Copied

I went in to More_Menu.htm and deleted all the bookmarks and re-inserted new bookmarks. I also deleted the old mini TOC at the top of the topic and re-installed a new mini TOC. Still have the same broken link.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2019 0
Engaged ,
Oct 15, 2019

Copy link to clipboard

Copied

Have you done the search in the editor or in the source code? Sometimes, a broken link remains in the source code, but is not visible in the topic. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2019 1
Explorer ,
Oct 16, 2019

Copy link to clipboard

Copied

Karin, you were correct. I ended up creating a new topic and moving everything over to the new topic and then deleting the old topic. It still had a broken link with the new topic name. I looked in the HTML code and found it!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2019 0