Highlighted

Updates to a document made in Robohelp are missing.

New Here ,
Jun 11, 2018

Copy link to clipboard

Copied

Hello,

Some data that I made in a release that we did is missing in my next release.

I'm using RH 2015 and we make 2 release cuts a year and they are in sequence (i.e- release 87, release 88, etc.) It consists of merging 9 separate projects into a parent project. (linking of child projects with a parent and outputting it into Responsive HTML 5). Anyway, for every change in documentation, there is a modification table so we can put the "mod number" and a description of what was changed at the bottom of each child project.

As I make the modification's, I use the outputted parent to do word searches and such. I was looking at my latest release (88) and making changes in our new release (89) and I noticed stuff I did in release 88 is not there anymore in release 89. I doubled back to release 88 and all of the changes are still there in the source itself. I go back to my release 89 projects it is missing certain things.

I was wondering if it is how I copy the data or something? (Though I do not understand how it is missing stuff.) For example, if we have a release 88 folder with the parents and the children in it, I copy the whole folder so there would be a release 88 and a release 88 - copy. I then change the name of the copy to the next release number in line (release 89 for this example) and I quit performing work in the release 88 folder and save it zipped onto our network.(That way I have a way to fall back if my computer crashes.) I then start performing all changes in the release 89 folders on my machine and leave 88 alone on the network.

Any suggestions? This is the first time it has happened and I always make a copy of the stuff and just rename it appropriately.

TOPICS
HTML

Views

94

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Updates to a document made in Robohelp are missing.

New Here ,
Jun 11, 2018

Copy link to clipboard

Copied

Hello,

Some data that I made in a release that we did is missing in my next release.

I'm using RH 2015 and we make 2 release cuts a year and they are in sequence (i.e- release 87, release 88, etc.) It consists of merging 9 separate projects into a parent project. (linking of child projects with a parent and outputting it into Responsive HTML 5). Anyway, for every change in documentation, there is a modification table so we can put the "mod number" and a description of what was changed at the bottom of each child project.

As I make the modification's, I use the outputted parent to do word searches and such. I was looking at my latest release (88) and making changes in our new release (89) and I noticed stuff I did in release 88 is not there anymore in release 89. I doubled back to release 88 and all of the changes are still there in the source itself. I go back to my release 89 projects it is missing certain things.

I was wondering if it is how I copy the data or something? (Though I do not understand how it is missing stuff.) For example, if we have a release 88 folder with the parents and the children in it, I copy the whole folder so there would be a release 88 and a release 88 - copy. I then change the name of the copy to the next release number in line (release 89 for this example) and I quit performing work in the release 88 folder and save it zipped onto our network.(That way I have a way to fall back if my computer crashes.) I then start performing all changes in the release 89 folders on my machine and leave 88 alone on the network.

Any suggestions? This is the first time it has happened and I always make a copy of the stuff and just rename it appropriately.

TOPICS
HTML

Views

95

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 11, 2018 0
Adobe Community Professional ,
Jun 11, 2018

Copy link to clipboard

Copied

Are only whole topics and/or files missing, or also content within topics?

If only whole topics/files are missing, check to see if the topics and files exist in the correct place using Windows Explorer. A problem I've encountered for years is randomly vanishing topics in the Project Manager pane. I don't know why it happens, but it happens when the cpd file is deleted (either manually or when the 'Clear project cache' setting is enabled). The workaround is to create a new folder in Robohelp, it can be anywhere and called anything, and let RH rejigger its database (this can take quite some time for large, complex projects). For some reason this forces a reassessment of files that doesn't happen when the cpd file is initially recreated. You can then delete the folder.

If source control is involved, this can cause a bit of havoc and you may need to manually delete the folder from source control also. But in your case it doesn't sound like this is the case.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 11, 2018 0
New Here ,
Jun 12, 2018

Copy link to clipboard

Copied

No topics or files are missing. It could be something simple such as a 1 liner that changed within the material itself of a topic, and as I said I have modification tables with numbers associated with changes made to our document and dates.

Not so sure this isn't "user error" as I'm not the only documenter.. All the changes happened that were "missing" in my release 89 were done in  mid-April. The cut off date for changes was the first week of April. I copied the release 88 folder when I was supposed to, and renamed it to the proper name (release 89) but I think someone kept making changes after the cut off date and put them within 88 when they were supposed to put the changes after the cut off date in the new release 89 folder.

Me not knowing then created the merged project with the changes made after the fact. I then proceeded to work within the new release 89 folder and just so happened to have noticed some things I changed in release 88 were not there, but were in the parent of release 88 (Responsive HTML5). I went back to release 88 project and everything was there (as expected.) Luckily, we keep a list of all changes done to all project files per release, so I went back and corrected everything that was missing and it was all items after mid-April.

Sadly, before I did this I already posted my question just in case it wasn't user error.

Thus, I believe this was a case of the other documenter putting new release 89 stuff in the release 88 folder when he was supposed to put them in the release 89 folder. If I'd known that,I'd have deleted the 89 folder I created and re-copied 88 and made it the 89 folder so all the changes were accurate. (Sadly, he is on vacation so I can not prove that is what happened till he gets back next week.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2018 0