Highlighted

Webhelp and automatic forwarding

New Here ,
Oct 27, 2015

Copy link to clipboard

Copied

Hi there,

I need help with my Robohelp Webhelp. Our Software, for which I am writing an online help with Robohelp, consists of different modules that contain a variety of sumbodules, e.g. Module A contains the submodules 1 and 2.

I have created a topic that is supposed to give an overview of the entire module A. In that topic I have put Drop-Down-Hotspots for each submodule explaining the purpose of the submodule in short. In each Drop-Down-Hotspot I inserted a bookmark.  My intention: If the user opens submodule 1 in the software and presses F1 he should be forwarded to the overview page and there to the related bookmark while opening the Drop-Down-Hotspot.  Therefore I downloaded this “link to drop down” script. When I generate the webhelp everything seems okay. I go to Submodule 1 and press F1 and I am getting forwarded to the bookmarked Drop-Down.

Now, I want to get information on submodule 2 (which I configured the same way as submodule 1). So, in the navigation pane, I click on “Submodule 2” and expect to get forwarded to the bookmark of the drop-down-hotspot of submodule 2. But nothing happens. Nothing at all. Not until I navigate to a completely different site before clicking “Submodule 2” in the navigation pane again. Then, it will work.

How is that possible? Why wouldn’t Robohelp switch to the other bookmarked Drop-Down-Hotspot?  Can anyone help me?  I hope that my text is not too complicated and you know what I am talking about.

H.Schmidt

Topics

WebHelp

Views

235

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Webhelp and automatic forwarding

New Here ,
Oct 27, 2015

Copy link to clipboard

Copied

Hi there,

I need help with my Robohelp Webhelp. Our Software, for which I am writing an online help with Robohelp, consists of different modules that contain a variety of sumbodules, e.g. Module A contains the submodules 1 and 2.

I have created a topic that is supposed to give an overview of the entire module A. In that topic I have put Drop-Down-Hotspots for each submodule explaining the purpose of the submodule in short. In each Drop-Down-Hotspot I inserted a bookmark.  My intention: If the user opens submodule 1 in the software and presses F1 he should be forwarded to the overview page and there to the related bookmark while opening the Drop-Down-Hotspot.  Therefore I downloaded this “link to drop down” script. When I generate the webhelp everything seems okay. I go to Submodule 1 and press F1 and I am getting forwarded to the bookmarked Drop-Down.

Now, I want to get information on submodule 2 (which I configured the same way as submodule 1). So, in the navigation pane, I click on “Submodule 2” and expect to get forwarded to the bookmark of the drop-down-hotspot of submodule 2. But nothing happens. Nothing at all. Not until I navigate to a completely different site before clicking “Submodule 2” in the navigation pane again. Then, it will work.

How is that possible? Why wouldn’t Robohelp switch to the other bookmarked Drop-Down-Hotspot?  Can anyone help me?  I hope that my text is not too complicated and you know what I am talking about.

H.Schmidt

Topics

WebHelp

Views

236

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 27, 2015

Copy link to clipboard

Copied

Oh I forgot: I am working with Robohelp 11

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 06, 2015

Copy link to clipboard

Copied

I have edited your post to break it into paragraphs to make it easier to read and understand the problem.

Is there just one output that covers both modules or are there two outputs with links?

Does the problem arise with links not trying to open a dropdown?


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...