webhelp: Cannot redirect book after click hyperlink

New Here ,
Aug 25, 2016

Copy link to clipboard

Copied

Dear,

I was using RoboHelp 8.0 for our help file compiling, in the past time, I was using HTML Help for all my applcations. Now I want to create a WebHelp for my apllication, I got a problem while browse the help contents. Here is my problem, in contents, there are many books in there, when I select one page in book "Get Started" and then click a hyperlink in this page, it should go to the page "Creating a blank system" under the book "Creating a System' and it go there indeed, my problem here is that the left pannel the contents, there is no change, it still stay in "Get Started" book, it cannot redirect to book "Creating a System' ->"Creating a blank system". would you please guide me how to fix it, this is very important for me I think.

I need to let you know this works well for HTML help(.chm).

thanks for your help,

NgCC

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

My shot was from RoboHelp 2015 but the same checkbox is in the RoboHelp 8 equivalent when you generate an output. If that is ticked, then it's likely as Rick suggests. Maybe it's not the same in all browsers.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Views

210

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

webhelp: Cannot redirect book after click hyperlink

New Here ,
Aug 25, 2016

Copy link to clipboard

Copied

Dear,

I was using RoboHelp 8.0 for our help file compiling, in the past time, I was using HTML Help for all my applcations. Now I want to create a WebHelp for my apllication, I got a problem while browse the help contents. Here is my problem, in contents, there are many books in there, when I select one page in book "Get Started" and then click a hyperlink in this page, it should go to the page "Creating a blank system" under the book "Creating a System' and it go there indeed, my problem here is that the left pannel the contents, there is no change, it still stay in "Get Started" book, it cannot redirect to book "Creating a System' ->"Creating a blank system". would you please guide me how to fix it, this is very important for me I think.

I need to let you know this works well for HTML help(.chm).

thanks for your help,

NgCC

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

My shot was from RoboHelp 2015 but the same checkbox is in the RoboHelp 8 equivalent when you generate an output. If that is ticked, then it's likely as Rick suggests. Maybe it's not the same in all browsers.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Views

211

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 25, 2016 0
Adobe Community Professional ,
Aug 26, 2016

Copy link to clipboard

Copied

I suspect you need to tick the check box shown below and/or set it to Automatically when you generate the help.

sync_toc.png


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2016 0
New Here ,
Aug 26, 2016

Copy link to clipboard

Copied

Thanks a lot for your reply, Peter

I believe I ticked the synchronize table of contents while generate the help.but still does not work. I would like to attach my project here but have not found a way to do that.

By the way, my version is 8.0, I really have not found the screen you showed above, I only can select while generate the help.

thanks,

Ngcc

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2016 0
LEGEND ,
Aug 26, 2016

Copy link to clipboard

Copied

Hi there

As you are using version 8, it's quite likely that the output simply cannot deal with modern browsers and that's causing the issue you are seeing.

Perhaps try downloading the most recent RoboHelp and testing a backup copy of your project using that. If that fixes the issue, the answer is that you will need to upgrade your RoboHelp version so the output works with today's browsers.

Click here if you need help making a backup copy

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2016 0
Adobe Community Professional ,
Aug 27, 2016

Copy link to clipboard

Copied

My shot was from RoboHelp 2015 but the same checkbox is in the RoboHelp 8 equivalent when you generate an output. If that is ticked, then it's likely as Rick suggests. Maybe it's not the same in all browsers.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 27, 2016 0
New Here ,
Aug 28, 2016

Copy link to clipboard

Copied

Thanks for both of your reply.

Is possible to get a patch to fix the issue due to compatiblity. We do not have a plan to upgrade the license this year.

Ngcc

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 28, 2016 0
Adobe Community Professional ,
Aug 29, 2016

Copy link to clipboard

Copied

Your chance is about the same as the proverbial cat's chance in hell.

Adobe only support the current and last version on matters like this.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 29, 2016 0