Highlighted

WebHelp project won't generate and hangs on "Indexing references"

Explorer ,
May 08, 2020

Copy link to clipboard

Copied

Hi there,

 

On Wednesday I upgraded to the most current version of RH 2019. I believe (not positive) I was using a version two updates back. My issue is that WebHelp never completes. It hangs on "Indexing references" (image attached). I noticed another posted issue (https://community.adobe.com/t5/robohelp/rh-2019-full-upgraded-robohelp-project-fails-to-generate-ind...) that perhaps addresses what I'm experiencing. Problem is, if this is the same issue, I have a TON of image maps in my project that would be exceptionally time consuming to remove. Any thoughts? Many thanks!

indexing-refs.png

Okay, Peter, here's what I found ... 

The old adage, "when all else fails, reboot," is appropriate here. I was basically able to get it working by following your instructions. However, I needed to reboot between making changes (yes, I know it sounds odd). So, here's what I did in case someone else runs into this issue:

1) Edited the Webhelp Output Presets to use a new skin and select all options under "select files to exclude from search."

2) Saved and closed project.
3) Rebooted machine.

4) Updated and saved new skin.

5) Regenerated Webhelp.

I have not yet worked through each option in "select files to exclude from search" yet.

Thanks much for your assistance.

Topics

New UI

Views

496

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

WebHelp project won't generate and hangs on "Indexing references"

Explorer ,
May 08, 2020

Copy link to clipboard

Copied

Hi there,

 

On Wednesday I upgraded to the most current version of RH 2019. I believe (not positive) I was using a version two updates back. My issue is that WebHelp never completes. It hangs on "Indexing references" (image attached). I noticed another posted issue (https://community.adobe.com/t5/robohelp/rh-2019-full-upgraded-robohelp-project-fails-to-generate-ind...) that perhaps addresses what I'm experiencing. Problem is, if this is the same issue, I have a TON of image maps in my project that would be exceptionally time consuming to remove. Any thoughts? Many thanks!

indexing-refs.png

Okay, Peter, here's what I found ... 

The old adage, "when all else fails, reboot," is appropriate here. I was basically able to get it working by following your instructions. However, I needed to reboot between making changes (yes, I know it sounds odd). So, here's what I did in case someone else runs into this issue:

1) Edited the Webhelp Output Presets to use a new skin and select all options under "select files to exclude from search."

2) Saved and closed project.
3) Rebooted machine.

4) Updated and saved new skin.

5) Regenerated Webhelp.

I have not yet worked through each option in "select files to exclude from search" yet.

Thanks much for your assistance.

Topics

New UI

Views

497

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
May 09, 2020

Copy link to clipboard

Copied

Please always indicate New UI or Classic. In this case the image name gave me a clue. Also please use the photo icon to insert images into the body of a post. There are problems with attached images at the moment.

 

Image maps are not the only cause of hanging. In the preset go to the Search options and select all the file types to exclude from search.

 

Does the project then generate?

 

What skin are you using?

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 11, 2020

Copy link to clipboard

Copied

Thanks, Peter. So, yeah, it kind of worked. After excluding file types from search, it didn't work using my custom skin. However, I changed the skin to Azure_Blue_(RTL) and it generates sometimes. I suspect I might find the pattern of misbehavior if I keep trying.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 11, 2020

Copy link to clipboard

Copied

I'm guessing the skin is the issue. With a skin that does work, you could try deselecting the search options again to sort of prove it.

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 12, 2020

Copy link to clipboard

Copied

Peter, the skin does not appear to be the issue. So, I used a different skin and it works the first time or two times I try to generate WebHelp, but then, at some point, after I've added a new topic or updated the TOC and try to regenerate, I get an error. It's quite inconsistent. But as soon as it fails once, it never seems to want to recover--and this is with using RH's prefab skin and excluding those files from my search.

 

Twice now I've copied over older versions of my Help to test and see this occurring. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 12, 2020

Copy link to clipboard

Copied

Next step has to be a new preset. Any joy with that?

 

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...