Highlighted

WebHelp Search Always Returning Substrings

New Here ,
Aug 16, 2017

Copy link to clipboard

Copied

Dear all,

I'm using RH2015 (12.0.4.460).

In my WebHelp outputs, the search feature works as if "Enable Substring Search" was selected, even when it's not.
Using "" or the AND Search option does not change this behavior.
So for instance, I cannot get a list of the topics that mention "finite capacity", because no matter what, the search results include also topics that mention "infinite capacity".

Results are the same with IE11, Chrome, and FF (I'm having issues with WebHelp in Edge, but they're not limited to the search feature, so...).

Search works fine with Responsive HTML5, but for some legacy projects, the output has to be WebHelp. Also, for corporate policy reasons, using an external search engine is not a possibility.

I could not find anything recent on the forums, so I guess this is not an issue everyone using RH2015 is having. What am I missing?
Would greatly appreciate any help or advice from the community...

PS: I checked also with a new project created from scratch. Same problem.

Topics

WebHelp

Views

186

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

WebHelp Search Always Returning Substrings

New Here ,
Aug 16, 2017

Copy link to clipboard

Copied

Dear all,

I'm using RH2015 (12.0.4.460).

In my WebHelp outputs, the search feature works as if "Enable Substring Search" was selected, even when it's not.
Using "" or the AND Search option does not change this behavior.
So for instance, I cannot get a list of the topics that mention "finite capacity", because no matter what, the search results include also topics that mention "infinite capacity".

Results are the same with IE11, Chrome, and FF (I'm having issues with WebHelp in Edge, but they're not limited to the search feature, so...).

Search works fine with Responsive HTML5, but for some legacy projects, the output has to be WebHelp. Also, for corporate policy reasons, using an external search engine is not a possibility.

I could not find anything recent on the forums, so I guess this is not an issue everyone using RH2015 is having. What am I missing?
Would greatly appreciate any help or advice from the community...

PS: I checked also with a new project created from scratch. Same problem.

Topics

WebHelp

Views

187

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 16, 2017

Copy link to clipboard

Copied

I just tested those terms and the answer seems to be to put "finite capacity" in quotes. Then it did not return the topic with "infinite capacity.

Are you saying in your simple test project putting the "finite capacity" brings back topics that only contain "finite capacity"?


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 16, 2017

Copy link to clipboard

Copied

Hello Peter,

Thanks for getting back to me.

Yes, when I search for "finite capacity" (with quotes), the results include all the topics that mention the phrase 'finite capacity', but also those that mention the phrase 'infinite capacity' - only, the 'in' in 'infinite' is not highlighted.

That's true for both legacy and test projects.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 16, 2017

Copy link to clipboard

Copied

Using quotes the list only contains topics with the term "finite capacity". It does not include topics that only have "infinite capacity". When you go to a topic that has both terms, then the search term will be highlighted in both.

To my mind it should only do that if Enable Substring Search is ticked, I don't think it should do it when that option is not selected.

Please follow this link to report bugs and request features. The more people who do so, the higher it gets prioritised.

https://tracker.adobe.com

Post the link to that bug in this thread and others can vote for it.

Are you saying that your list returns topics that only contain "infinite capacity"?


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 16, 2017

Copy link to clipboard

Copied

What you describe is what I get, and you're right: with the quotes, the list does not return topics with only 'infinite capacity'.

So the issue is really with the topics that include both 'finite capacity' and 'infinite capacity', where 'finite capacity' is highlighted also as a substring of 'infinite capacity'.

As advised, I reported that as a bug: https://tracker.adobe.com/#/view/RH-788

Thanks for your help, Peter.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...