What's the best plan for upgrading a RoboHelp for Word 10 project to a RoboHelp HTML 11 project?

New Here ,
Jul 30, 2015

Copy link to clipboard

Copied

Current project: Web Help currently in RoboHelp for Word 10 with a lot of conditional text, many see alsos and related items, and multiple single-source layouts. Upgrading to RH 11 and will use Responsive HTML layout

I thought it might be best to first convert the RH for Word 10 project into a RH HTML 10 project, then upgrade it to 11. Since I haven't found anyone who has actually done the conversion, I thought I'd check here to see what y'all have experienced.

Views

176

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jul 31, 2015

Copy link to clipboard

Copied

Take a look at Item 8 at Snippets (Rh for Word). It covers your scenario albeit based on an older version. I hope it helps.

Come back to the forum with any issues you encounter. Whatever you do, create a backup first so that you can roll back or try again with a clean source. I always prefer to zip backups as you can then extract as many copies as you may need. Also it stops you accidentally opening the wrong copy of your project.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Aug 03, 2015

Copy link to clipboard

Copied

Thanks, Peter. Luckily, I have not problems so far with the styles.

However, Conditional Build Tags and Single Source Layouts that were in my Word (hpj) project do not appear in the HTML (xpj) project after I convert it. Any tips for this issue?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Aug 03, 2015

Copy link to clipboard

Copied

And the TOC links are breaking. Each link looks like it is referencing a chm file. (This project has never been a chm file)

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 04, 2015

Copy link to clipboard

Copied

Try recreating one of the tags and then look at its properties. Does it show the tag as being used in the topics?

Not sure about the layouts. You may just have to recreate them.

Also not understanding why or even how the links can point to a chm. Would recreating it be a massive task?


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Aug 05, 2015

Copy link to clipboard

Copied

Just an update for anyone else who might have these issues.


Conditional Build Tags

When I recreated the tags and looked at their properties, the topics were listed. However, at some point the connection between the topics and tags were lost, so I need to reapply them. Not a small task, but I can't find a workaround.

Layouts

Yes, I will have to recreate them. Luckily, this project only has 2, not 20 like some other projects.

TOC Links

I deleted the original conversion and re-opened the project. In the import/conversion process, I selected Retain for the external links. Then I opened the .hhc file in Notepad ++ and updated all the TOC links from there. Much quicker and easier than using the RoboHelp UI.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 06, 2015

Copy link to clipboard

Copied

Usually when the tags don't appear and you recreate them in the way I suggested, the link is restored. The tag went missing but not the code in the topics, hence when the tag was recreated it knew which topics were associated. Are you saying that even after recreating the tags, if you go to Topic Properties there is no reference to the tag and that no shading appears?


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more