Highlighted

What would cause the look of paragraph point spacing to change

Explorer ,
Mar 16, 2017

Copy link to clipboard

Copied

RoboHelp HTML11
Windows 10

Recently, the point spacing between paragraphs in my RoboHelp project has changed. I'm sure it's something I did, but after days of trying to figure this out, I need help.

In the picture below, I have paragraph spacing set at 0pt Before and 0pt After, with Line spacing at Single. As you can see, the paragraph spacing looks much further apart than what I would expect for 0pt. (The last line of X's is how it looks after a soft return.) The only thing I can do to get the paragraphs closer together is use minus point numbers, and that seems inappropriate.

XXXactivate a deactivated complaint for Robohelp.png

I did notice something different in the HTML: there are a number of places where there is text in green that seems to be repeated over and over:

<!--[if gte mso 9]><xml>

<mso:CustomDocumentProperties>

<mso:_dlc_DocId msdt:dt="string">5E3YEXWMZK7C-131-14408</mso:_dlc_DocId>

<mso:_dlc_DocIdItemGuid msdt:dt="string">0290b6de-b450-483c-bf63-fe1f3c0a5350</mso:_dlc_DocIdItemGuid>

<mso:_dlc_DocIdUrl msdt:dt="string">https://staff.pdp.albany.edu/workgroups/RoboHelp/_layouts/DocIdRedir.aspx?ID=5E3YEXWMZK7C-131-14408, 5E3YEXWMZK7C-131-14408</mso:_dlc_DocIdUrl>

</mso:CustomDocumentProperties>

</xml><![endif]-->

Please note that I have only a very basic understanding of HTML, and this does not follow anything I've seen before. I also noticed that in other projects, where spacing seems fine, this text does not display. I'm afraid to delete this text without knowing what it is and how it might have gotten there. As far as I can tell, my Master Page and Style Sheet seem fine. What did I do to cause this mess.

Can anyone help?

Thanks so much.

Leanne

(Is there a way to add an attachment - if so, I could send a copy of the HTML for the picture above.)

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

Can you send me a topic with Mso and one without plus your CSS?

See the Contact page on my site and let me know the version of RoboHelp.

Topics

HTML

Views

244

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

What would cause the look of paragraph point spacing to change

Explorer ,
Mar 16, 2017

Copy link to clipboard

Copied

RoboHelp HTML11
Windows 10

Recently, the point spacing between paragraphs in my RoboHelp project has changed. I'm sure it's something I did, but after days of trying to figure this out, I need help.

In the picture below, I have paragraph spacing set at 0pt Before and 0pt After, with Line spacing at Single. As you can see, the paragraph spacing looks much further apart than what I would expect for 0pt. (The last line of X's is how it looks after a soft return.) The only thing I can do to get the paragraphs closer together is use minus point numbers, and that seems inappropriate.

XXXactivate a deactivated complaint for Robohelp.png

I did notice something different in the HTML: there are a number of places where there is text in green that seems to be repeated over and over:

<!--[if gte mso 9]><xml>

<mso:CustomDocumentProperties>

<mso:_dlc_DocId msdt:dt="string">5E3YEXWMZK7C-131-14408</mso:_dlc_DocId>

<mso:_dlc_DocIdItemGuid msdt:dt="string">0290b6de-b450-483c-bf63-fe1f3c0a5350</mso:_dlc_DocIdItemGuid>

<mso:_dlc_DocIdUrl msdt:dt="string">https://staff.pdp.albany.edu/workgroups/RoboHelp/_layouts/DocIdRedir.aspx?ID=5E3YEXWMZK7C-131-14408, 5E3YEXWMZK7C-131-14408</mso:_dlc_DocIdUrl>

</mso:CustomDocumentProperties>

</xml><![endif]-->

Please note that I have only a very basic understanding of HTML, and this does not follow anything I've seen before. I also noticed that in other projects, where spacing seems fine, this text does not display. I'm afraid to delete this text without knowing what it is and how it might have gotten there. As far as I can tell, my Master Page and Style Sheet seem fine. What did I do to cause this mess.

Can anyone help?

Thanks so much.

Leanne

(Is there a way to add an attachment - if so, I could send a copy of the HTML for the picture above.)

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

Can you send me a topic with Mso and one without plus your CSS?

See the Contact page on my site and let me know the version of RoboHelp.

Topics

HTML

Views

245

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Mar 16, 2017

Copy link to clipboard

Copied

Hi there

For starters, there is no picture, thus no green to see. Looks like you didn't insert a screen capture but instead copied and pasted code.

This appears to be code from Microsoft Office (likely Word), Hence the "MSO" stuff. This suggests either you copied from Word and pasted into RoboHelp, or that the topic was imported from Word.

If this is seriously mucking things up, you might consider cutting the text from RoboHelp, opening Windows Notepad and pasting into Notepad, then cutting from Notepad and pasting back into RoboHelp. That action should remove all that Word formatting code.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Mar 16, 2017

Copy link to clipboard

Copied

Rick's solution is likely to be the quickest and easiest given your stated level of knowledge.

To understand what is going on if you need to regularly import, rather than this being a one off, see the Importing pages on my site.


See www.grainge.org for RoboHelp and Authoring information

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Mar 16, 2017

Copy link to clipboard

Copied

Thanks, Peter. I'm really quite confused by what's happening. As you can see in my comment above, I removed all the extraneous green text and everything looks the same. Nothing was imported or copied and pasted. Things were looking fine until I began adding new topics recently with a new master page - but I don't know if that has anything to do with it. We also had to change the font from Verdana 11 to Arial 12 (which is working fine). But since then, everything has the extra spacing above and below paragraphs unless I change the paragraph spacing to something like -6 above and below. Any other thoughts?

Thanks again!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Mar 16, 2017

Copy link to clipboard

Copied

Beyond doubt, Ms means it's from Word.

It could also be an inline CSS. See my pages on importing and in particular

the bit about hyperlinks being the wrong colour. I know that is not the

problem but it could be a similar problem.

Is it one topic or many?

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Mar 16, 2017

Copy link to clipboard

Copied

I'll look at your pages - thanks.

I'm going to have to think very carefully about how Word got in there! I wonder if there was something in my clipboard that I entered by mistake. The interesting thing is that even if there is no reference to Ms, the problem remains.

It looks like all topics in this project converted to this odd paragraph spacing, even if they were fine before this happened.

Thanks for your time, Peter.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Mar 16, 2017

Copy link to clipboard

Copied

Can you send me a topic with Mso and one without plus your CSS?

See the Contact page on my site and let me know the version of RoboHelp.

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Mar 16, 2017

Copy link to clipboard

Copied

Hi, Rick -

Thanks for getting back so quickly.

Took out all the green text and the page still looks the same in Design view - lots of extra space above and below the paragraphs.

All the text in was written directly into RoboHelp - nothing was cut and copied - unless it was done by mistake somehow.

Any other thoughts or suggestions?

Thanks again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...