Highlighted

When we upgraded from RH11 to RH2015 the upgraded project didn't have any of the topics in it. Is there a way to get the topics to appear without having to import them after the upgrade?

Explorer ,
Mar 28, 2016

Copy link to clipboard

Copied

When we upgraded from RH11 to RH2015 the upgraded project didn't have any of the topics in it. Is there a way to get the topics to appear without having to import them after the upgrade?

TOPICS
HTML

Views

855

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

When we upgraded from RH11 to RH2015 the upgraded project didn't have any of the topics in it. Is there a way to get the topics to appear without having to import them after the upgrade?

Explorer ,
Mar 28, 2016

Copy link to clipboard

Copied

When we upgraded from RH11 to RH2015 the upgraded project didn't have any of the topics in it. Is there a way to get the topics to appear without having to import them after the upgrade?

TOPICS
HTML

Views

856

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 28, 2016 0
Adobe Community Professional ,
Mar 28, 2016

Copy link to clipboard

Copied

That shouldn’t have happened – is there any source control at work here?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 28, 2016 0
Explorer ,
Mar 29, 2016

Copy link to clipboard

Copied

Hi Jeff,

No, there is no formal source control over these files. They are legacy help files that were originally created when RH wasn't owned by Adobe (and before I started working here in 2006). But, we had no problems migrating from that super old version to the TCS but are seeing problems going from RH11 to RH2015. Go figure. Not sure what could fix this, but we have imported the files for a couple of the projects that had missing Topics, but others are very large and cumbersome so I thought I'd check with the RH community to get some assistance.

Thanks!

Pat

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2016 0
LEGEND ,
Mar 28, 2016

Copy link to clipboard

Copied

HI there

Can you share a screen shot depicting your RoboHelp application?

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 28, 2016 0
Explorer ,
Mar 29, 2016

Copy link to clipboard

Copied

Hi Rick,

Here's a screenshot of my workspace after upgrading a RH11 project to RH2015 showing nothing in the Topic List, all the topics in the broken links folder, and the TOC showing missing files. I also received the error dialog inserted after the workspace screenshot for every project I've upgraded to RH2015. For each project, this is the result I see after the upgrade:

RH_2015 Workspace.gif

Error When Upgrading to RH_2015.gif

Any help would be greatly appreciated!

Thanks!

Pat

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2016 0
LEGEND ,
Mar 29, 2016

Copy link to clipboard

Copied

Hi Pat

Thanks for sharing the images. Most helpful.

Based on what you have shown, it would appear that your project is located on a network resource? I"m basing that off the image showing K:\Design\Help...

I know that RoboHelp has improved in recent versions so as to allow it to work some better in these situations, but I'm wondering if the problem would perform a disappearing act if you were to move the project to a folder on your local C drive.

Are you able to try that?

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2016 0
Explorer ,
Mar 29, 2016

Copy link to clipboard

Copied

Yes, all of our help files reside on our network for backup purposes but I can see if that helps. They've always been on our network so it's strange that would now become an issue with this upgrade. I'll move one of the smaller projects to my local C drive and then upgrade and see what happens. I'll report back shortly.

Thanks,

Pat

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2016 0
Explorer ,
Mar 29, 2016

Copy link to clipboard

Copied

So I moved a copy of my project over to my local C drive and upgraded but ran into the same issue, no topics in the upgraded project. Very strange.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2016 0
LEGEND ,
Mar 29, 2016

Copy link to clipboard

Copied

How odd!

Does the Topic List populate properly if you open one of the sample projects?

Click here for a video on how to open a sample

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2016 0
Explorer ,
Mar 29, 2016

Copy link to clipboard

Copied

Yes, one of the sample files opened and displayed the Topic List properly, but it wasn't upgrading from an earlier version of RH, which seems to be our problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2016 0
Explorer ,
Mar 29, 2016

Copy link to clipboard

Copied

We have Help projects that were created long ago (14+ years ago) and projects that are fairly new (only a few years old), and we're only having problems with the old ones. The newer files, which were based off the same actual project parameters, CSS, and even hijacked xpj files opened fine with the Topic List intact.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2016 0
Adobe Community Professional ,
Mar 29, 2016

Copy link to clipboard

Copied

Projects created before RoboHelp was optimised for working on a network

must be upgraded locally before running them on a network.

Maybe that is the issue.

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2016 0
Adobe Community Professional ,
Mar 29, 2016

Copy link to clipboard

Copied

@PSW – are you completely patched up in your RH2015 version? That may be the issue when upgrading old projects…

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2016 0
Explorer ,
Mar 29, 2016

Copy link to clipboard

Copied

I thought I was since we just installed TCS2015, but looks like there is an updated for RH available. I'll update that and see how it does and let you know if that fixed it. Thanks for the heads up.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2016 0
Adobe Community Professional ,
Mar 29, 2016

Copy link to clipboard

Copied

... and when you upgrade locally, I believe it must be a copy you have not

attempted to open across the network.

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2016 0
Explorer ,
Mar 29, 2016

Copy link to clipboard

Copied

We have always had our RH projects on the network and have upgraded several times, even from RH5 all the way to TCS 4, with no issues. Plus, it's kind of a mix and match with some being okay on upgrade and some not, if RH was only optimized in the last couple of releases. We created the "newer" help files in RH10 (I mistakenly listed RH11 earlier), and they opened fine. Plus, I upgraded a copy of one of the files locally as a test earlier today and had the same results, no topics in the project.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2016 0
Explorer ,
Mar 29, 2016

Copy link to clipboard

Copied

Okay, I updated RH with the latest updates and moved an untouched copy of a project to my local drive and performed the upgrade. Same results, no topics in the Topic List and the Broken Links full of all the topics. Seems like nothing is working. Manual import looks like the surest option, although it's going to be a bit painful for our large projects. It just seems so odd that the last time we upgraded and went to TCS4, everything was fine but now it's not and we've been using the TCS for several years now. Unfortunately, as our organization is looking to consolidate tooling across doc teams (since we were acquired), this isn't looking good for our push to stick with RH. I can't let the MadCap side win!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2016 0
Explorer ,
Mar 30, 2016

Copy link to clipboard

Copied

So, after having upgraded one of my projects yesterday, manually importing all the topics and fixing the broken links, I updated RH2015 with the latest updates/patches (there were also FM and Captivate updates). Well, when i tried opening that "fixed" help file that had previously been updated to RH2015, I was prompted to upgrade again (I'm assuming because I applied the latest updates/patches). So I made a copy of my project on my local drive and upgraded. Well, the same problem happened yet again, no topics in the topic list. So, I'm chalking this up as an issue with RH2015 and I'm not looking forward to any updates to it in the future.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 30, 2016 0
Adobe Community Professional ,
Mar 30, 2016

Copy link to clipboard

Copied

We kinda wanted you to load all the patches & then try upgrading again with a copy of the original RH11 project totally checked out of any source control or network entanglements in a local short-path folder on your c:\ drive. That would be a more accurate test.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 30, 2016 0
Explorer ,
Mar 31, 2016

Copy link to clipboard

Copied

I actually had one of the project folders restored back to pre-upgrade status, so I'm going to move that "fresh" RH10 project to my C: drive and then upgrade it. I'll report back when i'm done. Thanks for your continued assistance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2016 0
Explorer ,
Mar 31, 2016

Copy link to clipboard

Copied

Okay, I completed the upgrade of the RH10 project on my c:\ drive. The topic list again is empty and all the topics are showing as broken links, but one topic is open in the workspace, although it doesn't show in the topic list. Here's a screenshot of my workspace after the upgrade:

Help Project After Upgrade.gif

So, really no difference other than this topic being open. Still so strange. It's hard to believe that the last upgrade we did, which was from RH5 to TCS 4, was farily seamless (over the network), yet this upgrade to RH2015 has been troublesome. And I'm still surprised that when I updated a RH2015 file with patches and then upgraded upon launching the project, the topics were again gone. Oh well, there's workarounds so I'll have to import the topics, hopefully not every time. Thanks for the assistance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2016 0
Explorer ,
Mar 31, 2016

Copy link to clipboard

Copied

Okay, now when I import the .htm topics, I am being told they already exist in the project (yet they're shown as broken links).

Confirm Overwrite dialog.gif

I'm going to see if I can't get those topics to display somehow, if they are truly in the project. Any ideas?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2016 0
Explorer ,
Mar 31, 2016

Copy link to clipboard

Copied

If I right-click each broken link and select Restore, the .htm topic moves to the topic list. Not sure why they're broken though.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2016 0
Adobe Community Professional ,
Mar 31, 2016

Copy link to clipboard

Copied

Have you tried deleting the .CPD file in the project (or have RH set to kill & recreate each time?)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2016 0
Explorer ,
Mar 31, 2016

Copy link to clipboard

Copied

No, I'm not too familiar with .cpd files, although I do remember being told to delete it when I was having problems previewing topics a while back. I deleted it at that time, but it didn't solve my problem. Someone was saying the drop-down text (or expanding text) feature was causing problems.

I have a copy of the RH10 project still. Would I delete the .cpd file prior to upgrading or after?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2016 0
Adobe Community Professional ,
Mar 31, 2016

Copy link to clipboard

Copied

After – the .cpd file is a little Access database of the project – if it’s missing, RH creates it. There’s a setting that will clear it each time RH starts and opens the project, but if your project is really large, this adds a lag to regaining control, so it’s usually not used with ones like that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2016 0
Explorer ,
Mar 31, 2016

Copy link to clipboard

Copied

Okay, I deleted the .cpd but, unfortunately, that didn't solve the topic list problem. Thanks for the suggestion though.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2016 0
Adobe Community Professional ,
Mar 31, 2016

Copy link to clipboard

Copied

Is there a project that you can share where you have not attempted to upgrade it? See the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

We can see if it will upgrade in a different environment.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2016 0
Explorer ,
Mar 31, 2016

Copy link to clipboard

Copied

Hi Peter,

Unfortunately, due to company policy, I'm not able to share it. I wish I could though, because I'd be interested to see if a different environment would yield different results. Thanks for the offer and the assistance on this, it's greatly appreciated.

Pat

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2016 0
Adobe Community Professional ,
Mar 31, 2016

Copy link to clipboard

Copied

Would they let Adobe take a look if I can arrange that? Can't promise but

happy to try.

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 31, 2016 0